aboutsummaryrefslogtreecommitdiff
path: root/sysutils/hal
diff options
context:
space:
mode:
authorRobert Noland <rnoland@FreeBSD.org>2009-03-03 03:30:20 +0000
committerRobert Noland <rnoland@FreeBSD.org>2009-03-03 03:30:20 +0000
commit04e28f5cf7f0072e7f1b26f8bc1d5382ab4d1fd7 (patch)
treec47e953e7e1822769acf140203dc3cc5e41edebc /sysutils/hal
parent649e3f6291f8ffa3d20bfc7e15a5f118e68567ae (diff)
downloadports-04e28f5cf7f0072e7f1b26f8bc1d5382ab4d1fd7.tar.gz
ports-04e28f5cf7f0072e7f1b26f8bc1d5382ab4d1fd7.zip
Notes
Diffstat (limited to 'sysutils/hal')
-rw-r--r--sysutils/hal/Makefile2
-rw-r--r--sysutils/hal/files/patch-hald_freebsd_hf-usb.c21
-rw-r--r--sysutils/hal/files/patch-hald_freebsd_hf-usb2.c6
3 files changed, 19 insertions, 10 deletions
diff --git a/sysutils/hal/Makefile b/sysutils/hal/Makefile
index c0314cd1e01d..68a1d89e80de 100644
--- a/sysutils/hal/Makefile
+++ b/sysutils/hal/Makefile
@@ -8,7 +8,7 @@
PORTNAME= hal
DISTVERSION= 0.5.11
-PORTREVISION= 19
+PORTREVISION= 20
CATEGORIES= sysutils
MASTER_SITES= http://hal.freedesktop.org/releases/
diff --git a/sysutils/hal/files/patch-hald_freebsd_hf-usb.c b/sysutils/hal/files/patch-hald_freebsd_hf-usb.c
index cefa177fc08a..07424b61ea45 100644
--- a/sysutils/hal/files/patch-hald_freebsd_hf-usb.c
+++ b/sysutils/hal/files/patch-hald_freebsd_hf-usb.c
@@ -1,5 +1,5 @@
---- hald/freebsd/hf-usb.c.orig 2008-05-07 19:24:02.000000000 -0400
-+++ hald/freebsd/hf-usb.c 2009-02-27 14:01:46.000000000 -0500
+--- hald/freebsd/hf-usb.c.orig 2008-05-08 01:24:02.000000000 +0200
++++ hald/freebsd/hf-usb.c 2009-03-02 04:23:32.000000000 +0100
@@ -25,13 +25,18 @@
# include <config.h>
#endif
@@ -31,7 +31,7 @@
typedef struct
{
-@@ -231,7 +241,7 @@ hf_usb_get_full_config_descriptor (int f
+@@ -231,7 +241,7 @@
* Adapted from usb_compute_udi() in linux2/physdev.c and
* usbclass_compute_udi() in linux2/classdev.c.
*/
@@ -40,7 +40,7 @@
hf_usb_device_compute_udi (HalDevice *device)
{
g_return_if_fail(HAL_IS_DEVICE(device));
-@@ -250,12 +260,13 @@ hf_usb_device_compute_udi (HalDevice *de
+@@ -250,12 +260,13 @@
hf_device_set_udi(device, "usb_device_%x_%x_%s",
hal_device_property_get_int(device, "usb_device.vendor_id"),
hal_device_property_get_int(device, "usb_device.product_id"),
@@ -56,7 +56,16 @@
hf_usb_add_webcam_properties (HalDevice *device)
{
int unit;
-@@ -575,6 +586,8 @@ hf_usb_probe_device (HalDevice *parent,
+@@ -424,7 +435,7 @@
+ hf_devtree_device_set_name(device, di->udi_devnames[0]);
+
+ if ((devname = hf_usb_get_devname(di, "ukbd"))) /* USB keyboard */
+- hf_device_set_input(device, "keyboard", devname);
++ hf_device_set_input(device, "keyboard", NULL);
+ else if ((devname = hf_usb_get_devname(di, "ums"))) /* USB mouse */
+ hf_device_set_input(device, "mouse", devname);
+ else if ((devname = hf_usb_get_devname(di, "uhid"))) /* UHID device */
+@@ -575,6 +586,8 @@
{
if (hal_device_has_capability(device, "hiddev"))
hf_runner_run_sync(device, 0, "hald-probe-hiddev", NULL);
@@ -65,7 +74,7 @@
hf_device_add(device);
}
-@@ -633,9 +646,18 @@ hf_usb_privileged_init (void)
+@@ -633,9 +646,18 @@
{
int i;
diff --git a/sysutils/hal/files/patch-hald_freebsd_hf-usb2.c b/sysutils/hal/files/patch-hald_freebsd_hf-usb2.c
index 45a24127d9a8..0da9bc2bc566 100644
--- a/sysutils/hal/files/patch-hald_freebsd_hf-usb2.c
+++ b/sysutils/hal/files/patch-hald_freebsd_hf-usb2.c
@@ -1,5 +1,5 @@
---- hald/freebsd/hf-usb2.c.orig 2009-02-17 18:58:44.000000000 -0500
-+++ hald/freebsd/hf-usb2.c 2009-02-17 23:22:47.000000000 -0500
+--- hald/freebsd/hf-usb2.c.orig 2009-03-02 20:16:10.000000000 -0600
++++ hald/freebsd/hf-usb2.c 2009-03-02 20:33:13.000000000 -0600
@@ -0,0 +1,287 @@
+/***************************************************************************
+ * CVSID: $Id$
@@ -101,7 +101,7 @@
+ if (driver)
+ {
+ if (! strcmp(driver, "ukbd"))
-+ hf_device_set_input(device, "keyboard", devname);
++ hf_device_set_input(device, "keyboard", NULL);
+ else if (! strcmp(driver, "ums"))
+ {
+ hf_device_set_input(device, "mouse", devname);