aboutsummaryrefslogtreecommitdiff
path: root/sysutils/hatop
diff options
context:
space:
mode:
authorKoichiro Iwao <meta@FreeBSD.org>2019-12-10 07:49:47 +0000
committerKoichiro Iwao <meta@FreeBSD.org>2019-12-10 07:49:47 +0000
commitc0921254dc8b8f214f4f40a94fe6a0b79f9f7229 (patch)
treeb8570a4828f0d8eccfd517a03d6280866744d29b /sysutils/hatop
parentf9bbff17a0e8462159b3536c874a712d566754c5 (diff)
downloadports-c0921254dc8b8f214f4f40a94fe6a0b79f9f7229.tar.gz
ports-c0921254dc8b8f214f4f40a94fe6a0b79f9f7229.zip
Notes
Diffstat (limited to 'sysutils/hatop')
-rw-r--r--sysutils/hatop/Makefile2
-rw-r--r--sysutils/hatop/files/patch-bin_hatop11
2 files changed, 11 insertions, 2 deletions
diff --git a/sysutils/hatop/Makefile b/sysutils/hatop/Makefile
index e68e85feb614..0013e51c6468 100644
--- a/sysutils/hatop/Makefile
+++ b/sysutils/hatop/Makefile
@@ -3,7 +3,7 @@
PORTNAME= hatop
PORTVERSION= 0.7.7
-PORTREVISION= 3
+PORTREVISION= 4
DISTVERSIONPREFIX= v
CATEGORIES= sysutils net
diff --git a/sysutils/hatop/files/patch-bin_hatop b/sysutils/hatop/files/patch-bin_hatop
index f836476a4a30..c816e57f0448 100644
--- a/sysutils/hatop/files/patch-bin_hatop
+++ b/sysutils/hatop/files/patch-bin_hatop
@@ -1,5 +1,14 @@
---- bin/hatop.orig 2019-12-03 21:58:07 UTC
+--- bin/hatop.orig 2019-12-09 21:46:21 UTC
+++ bin/hatop
+@@ -404,7 +404,7 @@ class Socket:
+ data = self._socket.recv(HAPROXY_CLI_BUFSIZE)
+ if not data:
+ raise SocketError('error while waiting for prompt')
+- return data
++ return data.decode()
+
+ def connect(self):
+ # Initialize socket connection
@@ -414,16 +414,16 @@ class Socket:
# Enter the interactive socket mode. This requires HAProxy 1.4+ and
# allows us to error out early if connected to an older version.