aboutsummaryrefslogtreecommitdiff
path: root/sysutils/hdrecover
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2012-06-30 02:14:20 +0000
committerCy Schubert <cy@FreeBSD.org>2012-06-30 02:14:20 +0000
commit7e575ae7425cf0ad8ab7d848bb0f1c2366814191 (patch)
tree22f9a2b5254b775391ed005446d8a0f82029042c /sysutils/hdrecover
parent2cb5e8bfc2cd34ad666d7e954b8a3f2cc135758f (diff)
downloadports-7e575ae7425cf0ad8ab7d848bb0f1c2366814191.tar.gz
ports-7e575ae7425cf0ad8ab7d848bb0f1c2366814191.zip
Notes
Diffstat (limited to 'sysutils/hdrecover')
-rw-r--r--sysutils/hdrecover/Makefile1
-rw-r--r--sysutils/hdrecover/files/patch-hdrecover.cpp11
2 files changed, 11 insertions, 1 deletions
diff --git a/sysutils/hdrecover/Makefile b/sysutils/hdrecover/Makefile
index 55dd007cc65d..257aaa688cf5 100644
--- a/sysutils/hdrecover/Makefile
+++ b/sysutils/hdrecover/Makefile
@@ -7,6 +7,7 @@
PORTNAME= hdrecover
PORTVERSION= 0.4
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
diff --git a/sysutils/hdrecover/files/patch-hdrecover.cpp b/sysutils/hdrecover/files/patch-hdrecover.cpp
index 84daf5bd6d1f..9f8f937632a7 100644
--- a/sysutils/hdrecover/files/patch-hdrecover.cpp
+++ b/sysutils/hdrecover/files/patch-hdrecover.cpp
@@ -1,5 +1,5 @@
--- hdrecover.cpp.orig 2011-09-25 04:48:10.000000000 -0700
-+++ hdrecover.cpp 2012-06-29 12:07:43.004361705 -0700
++++ hdrecover.cpp 2012-06-29 16:02:39.000000000 -0700
@@ -26,7 +26,11 @@
#include <sys/stat.h>
#include <fcntl.h>
@@ -12,3 +12,12 @@
#include <errno.h>
#include <string.h>
#include <time.h>
+@@ -260,7 +264,7 @@
+ sprintf(p, "%d seconds", remaining);
+ }
+ printf("Sector %Ld (%02d%%) ETR: %s\n",
+- sectornum, (int) ((sectornum * 100) / length), rs);
++ (long) sectornum, (long int) ((sectornum * 100) / length), rs);
+ }
+ }
+