aboutsummaryrefslogtreecommitdiff
path: root/sysutils/heartbeat
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-09-14 14:30:48 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-09-14 14:30:48 +0000
commit85a584ed52a8f84919bfd6827d99fa42fa769970 (patch)
treeff4017d45c28bf3df0a6bc651faca51f39d7e368 /sysutils/heartbeat
parentc4275caba7e1892b37de1f418c64f5a91b683c4e (diff)
downloadports-85a584ed52a8f84919bfd6827d99fa42fa769970.tar.gz
ports-85a584ed52a8f84919bfd6827d99fa42fa769970.zip
Notes
Diffstat (limited to 'sysutils/heartbeat')
-rw-r--r--sysutils/heartbeat/Makefile31
-rw-r--r--sysutils/heartbeat/files/patch-configure.in27
2 files changed, 26 insertions, 32 deletions
diff --git a/sysutils/heartbeat/Makefile b/sysutils/heartbeat/Makefile
index 723d3da2f627..cfa12e9ecd60 100644
--- a/sysutils/heartbeat/Makefile
+++ b/sysutils/heartbeat/Makefile
@@ -22,11 +22,9 @@ LIB_DEPENDS= libgnutls.so:${PORTSDIR}/security/gnutls \
libuuid.so:${PORTSDIR}/misc/e2fsprogs-libuuid \
libxml2.so:${PORTSDIR}/textproc/libxml2
BUILD_DEPENDS= bison:${PORTSDIR}/devel/bison
-PATCH_DEPENDS= libtoolize:${PORTSDIR}/devel/libtool
USE_AUTOTOOLS= autoconf autoheader automake aclocal libltdl libtoolize
-AUTOMAKE_ARGS+= --add-missing --include-deps --copy
-ACLOCAL_ARGS+= -I ${LOCALBASE}/share/aclocal
+AUTOMAKE_ARGS= --add-missing --include-deps --copy
USES= gettext gmake libtool pkgconfig tar:bzip2 shebangfix
SHEBANG_FILES= ldirectord/ldirectord.in
@@ -35,6 +33,7 @@ USE_LDCONFIG= yes
USE_PYTHON= yes
GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
USERS= hacluster
GROUPS= haclient
@@ -42,8 +41,7 @@ GROUPS= haclient
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libnet11
LDFLAGS+= -L${LOCALBASE}/lib -L${LOCALBASE}/lib/libnet11
-CONFIGURE_ARGS= --prefix=${PREFIX} \
- --localstatedir=/var \
+CONFIGURE_ARGS= --localstatedir=/var \
--with-miBsdir=${PREFIX}/snmp/mibs \
--with-initdir=${PREFIX}/etc/rc.d \
--with-group-id=275 \
@@ -128,18 +126,6 @@ post-extract:
@${CP} -f ${FILESDIR}/heartbeat.in ${WRKSRC}/heartbeat/init.d/
post-patch:
- @${LN} -s ${WRKSRC}/include/config.h ${WRKSRC}/config.h
-
- @${LN} -s $AUTOCONF ${WRKSRC}/autoconf
- @${LN} -s $AUTOHEADER ${WRKSRC}/autoheader
- @${LN} -s $AUTOMAKE ${WRKSRC}/automake
- @${LN} -s $LIBTOOL ${WRKSRC}/libtool
-
- @cd ${WRKSRC} && \
- ${LIBTOOLIZE} --automake --ltdl --force --copy && \
- ${TAR} -cf libltdl.tar libltdl && \
- ${RM} -rf libltdl
-
.if ${PORT_OPTIONS:MDOCS}
@${REINPLACE_CMD} -e 's|^\(docdir.*doc/\).*|\1${PORTNAME}|' \
${WRKSRC}/configure.in \
@@ -149,21 +135,10 @@ post-patch:
${WRKSRC}/Makefile.am
.endif
-pre-install:
- @${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
-
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/*.so.*
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/heartbeat/plugins/*/*.so
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/pils/plugins/InterfaceMgr/generic.so
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/stonith/plugins/stonith2/*.so
${MKDIR} -m 0750 ${STAGEDIR}/var/run/heartbeat/pengine
${TOUCH} ${STAGEDIR}/var/run/heartbeat.pid
-.if ${PORT_OPTIONS:MMGMT}
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/heartbeat-gui/_pymgmt.so.0.0.0
-.endif
-
.if ${PORT_OPTIONS:MDOCS}
# Install sample configuration
${CP} -p ${STAGEDIR}${DOCSDIR}/authkeys ${STAGEDIR}${PREFIX}/etc/ha.d/authkeys.sample
diff --git a/sysutils/heartbeat/files/patch-configure.in b/sysutils/heartbeat/files/patch-configure.in
index fa3c8bcf0cd0..eb918671bd45 100644
--- a/sysutils/heartbeat/files/patch-configure.in
+++ b/sysutils/heartbeat/files/patch-configure.in
@@ -31,7 +31,26 @@
AC_PROG_CC_STDC
dnl ************************************************************************
-@@ -542,7 +550,7 @@
+@@ -495,18 +503,6 @@
+ AC_LIBLTDL_CONVENIENCE dnl make libltdl a convenience lib
+ AC_PROG_LIBTOOL
+
+-dnl Replacing AC_PROG_LIBTOOL with AC_CHECK_PROG because LIBTOOL
+-dnl was NOT being expanded all the time thus causing things to fail.
+-AC_CHECK_PROGS(LIBTOOL, glibtool libtool libtool15 libtool13)
+-AC_MSG_CHECKING(for glibtool or libtool*)
+-if test x"${LIBTOOL}" = x""; then
+- FatalMissingThing "libtool" "You need libtool to build heartbeat." \
+- "You can get the source from ftp://www.gnu.org/pub/gnu/" \
+- "or you can locate it via http://www.gnu.org/software/libtool"
+-else
+- AC_MSG_RESULT($LIBTOOL has been found.)
+-fi
+-
+ AC_CHECK_PROGS(MAKE, gmake make)
+ AC_MSG_CHECKING(for gmake or make)
+ if test x"${MAKE}" = x""; then
+@@ -542,7 +538,7 @@
AC_PATH_PROGS(MAILCMD, mail, mailx)
AC_SUBST(MAILCMD)
AC_DEFINE_UNQUOTED(IFCONFIG, "$IFCONFIG", path to the ifconfig command)
@@ -40,7 +59,7 @@
AC_PATH_PROGS(GETENT, getent)
AC_PATH_PROGS(IP2UTIL, ip, /sbin/ip)
AC_PATH_PROGS(XML2CONFIG, xml2-config)
-@@ -1718,6 +1726,7 @@
+@@ -1718,6 +1714,7 @@
AC_CHECK_SIZEOF(int)
AC_CHECK_SIZEOF(long)
AC_CHECK_SIZEOF(long long)
@@ -48,7 +67,7 @@
AC_ARG_ENABLE([all],
[ --enable-all Activate ALL features
-@@ -2381,7 +2390,7 @@
+@@ -2381,7 +2378,7 @@
AC_MSG_CHECKING(if clock_t is long enough)
@@ -57,7 +76,7 @@
AC_MSG_RESULT(yes)
AC_DEFINE(CLOCK_T_IS_LONG_ENOUGH, 1, [Set if CLOCK_T is adequate by itself for the "indefinite future" (>= 100 years)])
else
-@@ -2393,13 +2402,13 @@
+@@ -2393,13 +2390,13 @@
dnl Note: reduce LIBS; in particular, ltdl can cause confusion.
dnl Possibly better: move 'LIBS="$LIBS -lltdl"' from above to beyond here.
dnl