aboutsummaryrefslogtreecommitdiff
path: root/sysutils/heat
diff options
context:
space:
mode:
authorChris D. Faulhaber <jedgar@FreeBSD.org>2000-05-07 12:54:56 +0000
committerChris D. Faulhaber <jedgar@FreeBSD.org>2000-05-07 12:54:56 +0000
commit9567f89a98d7ca5c8a21ad66556c6986ad74671c (patch)
tree8985c43d706b3443684da0f1655cb888999802a9 /sysutils/heat
parent027b7904506d820f8aca6be6e8cca1200d25b16e (diff)
downloadports-9567f89a98d7ca5c8a21ad66556c6986ad74671c.tar.gz
ports-9567f89a98d7ca5c8a21ad66556c6986ad74671c.zip
Notes
Diffstat (limited to 'sysutils/heat')
-rw-r--r--sysutils/heat/Makefile21
-rw-r--r--sysutils/heat/distinfo1
-rw-r--r--sysutils/heat/files/patch-aa11
-rw-r--r--sysutils/heat/pkg-comment1
-rw-r--r--sysutils/heat/pkg-descr13
-rw-r--r--sysutils/heat/pkg-plist1
6 files changed, 48 insertions, 0 deletions
diff --git a/sysutils/heat/Makefile b/sysutils/heat/Makefile
new file mode 100644
index 000000000000..2353c8d49fbb
--- /dev/null
+++ b/sysutils/heat/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: heat
+# Date created: 28 March 2000
+# Whom: Jeremy Chadwick <yoshi@parodius.com>
+#
+# $FreeBSD$
+
+PORTNAME= heat
+PORTVERSION= 1.0
+CATEGORIES= sysutils
+MASTER_SITES= ftp://ftp.parodius.com/pub/heat/
+
+MAINTAINER= yoshi@parodius.com
+
+BIN1= heat
+
+do-install:
+.for i in ${BIN1}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${i} ${PREFIX}/bin/${i}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/sysutils/heat/distinfo b/sysutils/heat/distinfo
new file mode 100644
index 000000000000..a785d92a6de7
--- /dev/null
+++ b/sysutils/heat/distinfo
@@ -0,0 +1 @@
+MD5 (heat-1.0.tar.gz) = 0da4d35913f8b4b8c48ea423012a21b9
diff --git a/sysutils/heat/files/patch-aa b/sysutils/heat/files/patch-aa
new file mode 100644
index 000000000000..75d2325a2ae2
--- /dev/null
+++ b/sysutils/heat/files/patch-aa
@@ -0,0 +1,11 @@
+--- Makefile.orig Wed Jan 5 09:57:53 2000
++++ Makefile Sun May 7 08:45:50 2000
+@@ -1,7 +1,7 @@
+ #
+ # Makefile
+ #
+-CC = gcc
++CC?= gcc
+ CFLAGS += -Wall -Wunused -Wstrict-prototypes
+ #
+ # __for debugging__
diff --git a/sysutils/heat/pkg-comment b/sysutils/heat/pkg-comment
new file mode 100644
index 000000000000..7d2949aa3055
--- /dev/null
+++ b/sysutils/heat/pkg-comment
@@ -0,0 +1 @@
+A thermal/fan monitoring application for Winbond-based motherboards
diff --git a/sysutils/heat/pkg-descr b/sysutils/heat/pkg-descr
new file mode 100644
index 000000000000..6b3a042b90ad
--- /dev/null
+++ b/sysutils/heat/pkg-descr
@@ -0,0 +1,13 @@
+heat allows you to monitor the thermal aspects measured by the
+Winbond chipset on your motherboard. It also supports the
+ability to monitor fans, and provides workarounds for known bugs
+with certain motherboard models. It does not monitor voltages
+(yet).
+
+Currently, the only supported chipsets are the following:
+ * Winbond 83781D <untested>
+ * Winbond 83627HF <untested>
+ * Winbond 83782D
+ * Winbond 83783S <untested>
+
+- yoshi@parodius.com
diff --git a/sysutils/heat/pkg-plist b/sysutils/heat/pkg-plist
new file mode 100644
index 000000000000..a6cd46a97d07
--- /dev/null
+++ b/sysutils/heat/pkg-plist
@@ -0,0 +1 @@
+bin/heat