aboutsummaryrefslogtreecommitdiff
path: root/sysutils/hfm
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-06-29 03:51:13 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-06-29 03:51:13 +0000
commit3726f942547e374490d375baf83216d7644a7162 (patch)
tree8c7c440762c72012824110ba9cdd44c8c1765017 /sysutils/hfm
parent1de291090d9121f4d238a639b441f64372c239c1 (diff)
Convert all Go ports to USES=go
This allows for port testing with lang/go-devel via GO_PORT, setting up the Go build environment in a single place, and is step one in simplifying Go ports that often define too complicated do-build targets themselves. USES=go gains new arguments 'run' to add lang/go to RUN_DEPENDS and 'no_targets' for ports with composite builds that call 'go' themselves and do not need the do-build/do-install targets of USES=go. PR: 238849 Submitted by: dg@syrec.org (also D20745) Reviewed by: mat, tobik Exp-run by: antoine Differential Revision: https://reviews.freebsd.org/D20746
Notes
Notes: svn path=/head/; revision=505321
Diffstat (limited to 'sysutils/hfm')
-rw-r--r--sysutils/hfm/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/sysutils/hfm/Makefile b/sysutils/hfm/Makefile
index c9aed005cf05..6c3e2ce0c370 100644
--- a/sysutils/hfm/Makefile
+++ b/sysutils/hfm/Makefile
@@ -13,11 +13,10 @@ LICENSE= BSD2CLAUSE
# gb 0.4 includes FreeBSD-specific fixes that this port requires
# https://github.com/constabulary/gb/issues/506
-BUILD_DEPENDS= go>=1.5:lang/go \
- gb>=0.4:devel/gb \
+BUILD_DEPENDS= gb>=0.4:devel/gb \
${LOCALBASE}/lib/libucl.a:textproc/libucl
-USES= compiler:c++11-lang
+USES= compiler:c++11-lang go:no_targets
USE_GITHUB= yes
GH_ACCOUNT= derekmarcotte