aboutsummaryrefslogtreecommitdiff
path: root/sysutils/hploscripts
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2010-02-11 16:46:49 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2010-02-11 16:46:49 +0000
commit96c2c71c3fac75b87102e11be16353b549f44965 (patch)
tree379b9d91287e0ff9cc2accd03e6c2c520c47e574 /sysutils/hploscripts
parentcd71602040a4752b1fe02abebfb74265008df811 (diff)
Notes
Diffstat (limited to 'sysutils/hploscripts')
-rw-r--r--sysutils/hploscripts/Makefile42
-rw-r--r--sysutils/hploscripts/distinfo3
-rw-r--r--sysutils/hploscripts/pkg-descr3
-rw-r--r--sysutils/hploscripts/pkg-plist77
4 files changed, 125 insertions, 0 deletions
diff --git a/sysutils/hploscripts/Makefile b/sysutils/hploscripts/Makefile
new file mode 100644
index 000000000000..c0b551d82673
--- /dev/null
+++ b/sysutils/hploscripts/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: hploscripts
+# Date created: 11 Feb 2010
+# Whom: Emanuel Haupt <ehaupt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hploscripts
+PORTVERSION= 2.40.0
+CATEGORIES= sysutils perl5
+MASTER_SITES= CRITICAL
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= HP Lights-Out management perl scripts
+
+BUILD_DEPENDS= p5-IO-Socket-SSL>=1.19:${PORTSDIR}/security/p5-IO-Socket-SSL
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PERL5= 5.8.0+
+NO_BUILD= yes
+
+PORTDOCS= iLO_perl_xml.pdf linux-LOsamplescripts2.40.0-1.txt
+
+post-patch:
+ @${REINPLACE_CMD} -e '1s|.*|#!${PERL}|' ${WRKSRC}/locfg.pl \
+ ${WRKSRC}/vspconfig.pl
+
+do-install:
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.xml ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/hponcfg_reformat.xsl ${EXAMPLESDIR}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/iLO_perl_xml.pdf ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/linux-LOsamplescripts2.40.0-1.txt ${DOCSDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/locfg.pl ${PREFIX}/bin/locfg
+ ${INSTALL_SCRIPT} ${WRKSRC}/vspconfig.pl ${PREFIX}/bin/vspconfig
+
+regression-test: build
+ @${PERL} -c ${WRKSRC}/locfg.pl
+ @${PERL} -c ${WRKSRC}/vspconfig.pl
+
+.include <bsd.port.mk>
diff --git a/sysutils/hploscripts/distinfo b/sysutils/hploscripts/distinfo
new file mode 100644
index 000000000000..c0620cb16489
--- /dev/null
+++ b/sysutils/hploscripts/distinfo
@@ -0,0 +1,3 @@
+MD5 (hploscripts-2.40.0.tar.gz) = 9d3728c4fa387b16dd8eefccb02a0a72
+SHA256 (hploscripts-2.40.0.tar.gz) = f404a57f8355bd77c5b2757e647700b8f87ee5353c638d4a256c16fbdb5b6d7b
+SIZE (hploscripts-2.40.0.tar.gz) = 37504
diff --git a/sysutils/hploscripts/pkg-descr b/sysutils/hploscripts/pkg-descr
new file mode 100644
index 000000000000..677c16e58695
--- /dev/null
+++ b/sysutils/hploscripts/pkg-descr
@@ -0,0 +1,3 @@
+This is a set of sample XML scripts used to manage the configuration of HP
+Integrated Lights-Out (iLO) management processors and to control servers in
+which iLO devices are in use.
diff --git a/sysutils/hploscripts/pkg-plist b/sysutils/hploscripts/pkg-plist
new file mode 100644
index 000000000000..c15d34e3ab10
--- /dev/null
+++ b/sysutils/hploscripts/pkg-plist
@@ -0,0 +1,77 @@
+bin/locfg
+bin/vspconfig
+%%EXAMPLESDIR%%/Add_User.xml
+%%EXAMPLESDIR%%/Administrator_reset_pw.xml
+%%EXAMPLESDIR%%/Cert_Request.xml
+%%EXAMPLESDIR%%/Change_Password.xml
+%%EXAMPLESDIR%%/Clear_EventLog.xml
+%%EXAMPLESDIR%%/Clear_IML.xml
+%%EXAMPLESDIR%%/Computer_Lock_Config.xml
+%%EXAMPLESDIR%%/Copy_Virtual_Floppy.xml
+%%EXAMPLESDIR%%/Delete_User.xml
+%%EXAMPLESDIR%%/Eject_Virtual_Media.xml
+%%EXAMPLESDIR%%/Get_2Factor.xml
+%%EXAMPLESDIR%%/Get_All_Cables_Status.xml
+%%EXAMPLESDIR%%/Get_All_User_Info.xml
+%%EXAMPLESDIR%%/Get_All_Users.xml
+%%EXAMPLESDIR%%/Get_Diagport.xml
+%%EXAMPLESDIR%%/Get_Directory.xml
+%%EXAMPLESDIR%%/Get_EmHealth.xml
+%%EXAMPLESDIR%%/Get_Enc_Bay_IP_Settings.xml
+%%EXAMPLESDIR%%/Get_FW_Version.xml
+%%EXAMPLESDIR%%/Get_Global.xml
+%%EXAMPLESDIR%%/Get_Host_APO.xml
+%%EXAMPLESDIR%%/Get_Host_Data.xml
+%%EXAMPLESDIR%%/Get_Host_Power.xml
+%%EXAMPLESDIR%%/Get_Host_Power_Reg_Info.xml
+%%EXAMPLESDIR%%/Get_Host_Power_Saver.xml
+%%EXAMPLESDIR%%/Get_Host_Pwr_Micro_Ver.xml
+%%EXAMPLESDIR%%/Get_IML.xml
+%%EXAMPLESDIR%%/Get_Network.xml
+%%EXAMPLESDIR%%/Get_PowerCap.xml
+%%EXAMPLESDIR%%/Get_Power_Readings.xml
+%%EXAMPLESDIR%%/Get_SNMP_IM.xml
+%%EXAMPLESDIR%%/Get_SSO_Settings.xml
+%%EXAMPLESDIR%%/Get_Server_Name.xml
+%%EXAMPLESDIR%%/Get_Topology.xml
+%%EXAMPLESDIR%%/Get_UID_Status.xml
+%%EXAMPLESDIR%%/Get_User.xml
+%%EXAMPLESDIR%%/Get_VM_Status.xml
+%%EXAMPLESDIR%%/Get_VPB_Cable_Status.xml
+%%EXAMPLESDIR%%/Get_iLO_Log.xml
+%%EXAMPLESDIR%%/Hotkey_Config.xml
+%%EXAMPLESDIR%%/Import_2Factor_Certs.xml
+%%EXAMPLESDIR%%/Import_Cert.xml
+%%EXAMPLESDIR%%/Import_SSH_Key.xml
+%%EXAMPLESDIR%%/Insert_Virtual_Media.xml
+%%EXAMPLESDIR%%/License.xml
+%%EXAMPLESDIR%%/Mod_2Factor.xml
+%%EXAMPLESDIR%%/Mod_Blade_Rack.xml
+%%EXAMPLESDIR%%/Mod_DiagPort_Settings.xml
+%%EXAMPLESDIR%%/Mod_Directory.xml
+%%EXAMPLESDIR%%/Mod_Enc_Bay_IP_Settings.xml
+%%EXAMPLESDIR%%/Mod_Global_Settings.xml
+%%EXAMPLESDIR%%/Mod_Network_Settings.xml
+%%EXAMPLESDIR%%/Mod_SNMP_IM_Settings.xml
+%%EXAMPLESDIR%%/Mod_SSO_Settings.xml
+%%EXAMPLESDIR%%/Mod_Schemaless_Directory.xml
+%%EXAMPLESDIR%%/Mod_User.xml
+%%EXAMPLESDIR%%/Mod_VLAN.xml
+%%EXAMPLESDIR%%/Mod_VSP_Flow_Control.xml
+%%EXAMPLESDIR%%/RBSU_POST_IP.xml
+%%EXAMPLESDIR%%/Reset_RIB.xml
+%%EXAMPLESDIR%%/Reset_Server.xml
+%%EXAMPLESDIR%%/Set_Host_APO.xml
+%%EXAMPLESDIR%%/Set_Host_Power.xml
+%%EXAMPLESDIR%%/Set_Host_Power_Saver.xml
+%%EXAMPLESDIR%%/Set_PowerCap.xml
+%%EXAMPLESDIR%%/Set_Server_Name.xml
+%%EXAMPLESDIR%%/Set_VM_Status.xml
+%%EXAMPLESDIR%%/Shared_Network_Port.xml
+%%EXAMPLESDIR%%/UID_Control.xml
+%%EXAMPLESDIR%%/Update_Firmware.xml
+%%EXAMPLESDIR%%/add_sso_rec.xml
+%%EXAMPLESDIR%%/delete_sso_rec.xml
+%%EXAMPLESDIR%%/hponcfgcap.xml
+%%EXAMPLESDIR%%/hponcfg_reformat.xsl
+@dirrm %%EXAMPLESDIR%%