aboutsummaryrefslogtreecommitdiff
path: root/sysutils/htop
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-03-05 19:02:17 +0000
committerPawel Pekala <pawel@FreeBSD.org>2012-03-05 19:02:17 +0000
commitd0830eebe10ff157223af2be70a018068c684fec (patch)
tree623fd166e1731fc43dc6160edad16f2000538c8b /sysutils/htop
parent4fff6bd373490bb2af5c3cd3614688476002633e (diff)
downloadports-d0830eebe10ff157223af2be70a018068c684fec.tar.gz
ports-d0830eebe10ff157223af2be70a018068c684fec.zip
Notes
Diffstat (limited to 'sysutils/htop')
-rw-r--r--sysutils/htop/Makefile3
-rw-r--r--sysutils/htop/distinfo4
-rw-r--r--sysutils/htop/files/patch-FunctionBar.c19
-rw-r--r--sysutils/htop/files/patch-ProcessList.c87
-rw-r--r--sysutils/htop/files/patch-RichString.c14
-rw-r--r--sysutils/htop/files/patch-RichString.h14
-rw-r--r--sysutils/htop/files/patch-configure.ac19
-rw-r--r--sysutils/htop/pkg-message2
8 files changed, 4 insertions, 158 deletions
diff --git a/sysutils/htop/Makefile b/sysutils/htop/Makefile
index 5e3e6a9ca5ac..a0c88c622163 100644
--- a/sysutils/htop/Makefile
+++ b/sysutils/htop/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= htop
-PORTVERSION= 0.9
-PORTREVISION= 1
+PORTVERSION= 1.0.1
CATEGORIES= sysutils
MASTER_SITES= SF
diff --git a/sysutils/htop/distinfo b/sysutils/htop/distinfo
index 045af34459da..efb43f7bdb6a 100644
--- a/sysutils/htop/distinfo
+++ b/sysutils/htop/distinfo
@@ -1,2 +1,2 @@
-SHA256 (htop-0.9.tar.gz) = 4de65c38e1886bccd30ed692b30eb9bf195240680781bfe1eaf5faf84ee6fbfd
-SIZE (htop-0.9.tar.gz) = 418767
+SHA256 (htop-1.0.1.tar.gz) = 07db2cbe02835f9e186b9610ecc3beca330a5c9beadb3b6069dd0a10561506f2
+SIZE (htop-1.0.1.tar.gz) = 384683
diff --git a/sysutils/htop/files/patch-FunctionBar.c b/sysutils/htop/files/patch-FunctionBar.c
deleted file mode 100644
index 1a6c3ecc825a..000000000000
--- a/sysutils/htop/files/patch-FunctionBar.c
+++ /dev/null
@@ -1,19 +0,0 @@
---- FunctionBar.c.orig 2010-01-26 03:50:57.000000000 +0800
-+++ FunctionBar.c 2010-01-26 03:51:50.000000000 +0800
-@@ -52,14 +52,12 @@
- this->functions = malloc(sizeof(char*) * 15);
- this->keys = malloc(sizeof(char*) * 15);
- this->events = malloc(sizeof(int) * 15);
-- int i = 0;
-- while (i < 15 && functions[i]) {
-+ for (int i = 0; i < 15 && functions[i]; i++) {
- this->functions[i] = String_copy(functions[i]);
- this->keys[i] = String_copy(keys[i]);
- this->events[i] = events[i];
-- i++;
-+ this->size = i;
- }
-- this->size = i;
- } else {
- this->staticData = true;
- this->functions = functions ? functions : FunctionBar_FLabels;
diff --git a/sysutils/htop/files/patch-ProcessList.c b/sysutils/htop/files/patch-ProcessList.c
deleted file mode 100644
index 29d7010ce6ae..000000000000
--- a/sysutils/htop/files/patch-ProcessList.c
+++ /dev/null
@@ -1,87 +0,0 @@
---- ./ProcessList.c.orig 2010-11-26 18:50:25.000000000 +0200
-+++ ./ProcessList.c 2011-08-11 13:07:08.000000000 +0300
-@@ -32,6 +32,19 @@
- #include "debug.h"
- #include <assert.h>
-
-+#ifndef PAGE_SIZE
-+#define PAGE_SIZE sysconf(_SC_PAGESIZE)
-+#endif
-+
-+#ifdef __FreeBSD__
-+#define KB 1024
-+#define SYSCTLBYNAME(name, var, len) sysctlbyname(name, &(var), &(len), NULL, 0)
-+#include <kvm.h>
-+#include <paths.h>
-+#include <fcntl.h>
-+#include <sys/sysctl.h>
-+#endif
-+
- /*{
-
- #ifndef PROCDIR
-@@ -665,15 +678,24 @@
-
- void ProcessList_scan(ProcessList* this) {
- unsigned long long int usertime, nicetime, systemtime, systemalltime, idlealltime, idletime, totaltime, virtalltime;
-+ #ifndef __FreeBSD__
- unsigned long long int swapFree = 0;
-+ #endif
-+ int cpus = this->cpuCount;
-+ FILE* file = NULL;
-
-- FILE* file = fopen(PROCMEMINFOFILE, "r");
-+ #ifdef __FreeBSD__
-+ kvm_t *kd = NULL;
-+ struct kvm_swap kvmswapinfo[1];
-+ size_t len = 0;
-+ #endif
-+
-+ #ifndef __FreeBSD__
-+ file = fopen(PROCMEMINFOFILE, "r");
- assert(file != NULL);
-- int cpus = this->cpuCount;
- {
- char buffer[128];
- while (fgets(buffer, 128, file)) {
--
- switch (buffer[0]) {
- case 'M':
- if (String_startsWith(buffer, "MemTotal:"))
-@@ -700,10 +722,35 @@
- }
- }
- }
-+ fclose(file);
-+ #endif
-
-+ #ifdef __FreeBSD__
-+ len = sizeof(this->totalMem);
-+ SYSCTLBYNAME("vm.stats.vm.v_page_count", this->totalMem, len);
-+ this->totalMem *= PAGE_SIZE / KB;
-+ len = sizeof(this->cachedMem);
-+ SYSCTLBYNAME("vm.stats.vm.v_cache_count", this->cachedMem, len);
-+ this->cachedMem *= PAGE_SIZE / KB;
-+ len = sizeof(this->buffersMem);
-+ SYSCTLBYNAME("vfs.bufspace", this->buffersMem, len);
-+ this->buffersMem /= KB;
-+ len = sizeof(this->usedMem);
-+ SYSCTLBYNAME("vm.stats.vm.v_active_count", this->usedMem, len);
-+ this->usedMem = this->usedMem * PAGE_SIZE / KB + this->cachedMem + this->buffersMem;
-+ this->freeMem = this->totalMem - this->usedMem;
-+ kd = kvm_open(NULL, _PATH_DEVNULL, NULL, O_RDONLY, NULL);
-+ assert(kd != NULL);
-+ kvm_getswapinfo(kd, kvmswapinfo, 1, 0);
-+ this->totalSwap = kvmswapinfo[0].ksw_total * PAGE_SIZE / KB;
-+ this->usedSwap = kvmswapinfo[0].ksw_used * PAGE_SIZE / KB;
-+ kvm_close(kd);
-+ #endif
-+
-+ #ifndef __FreeBSD__
- this->usedMem = this->totalMem - this->freeMem;
- this->usedSwap = this->totalSwap - swapFree;
-- fclose(file);
-+ #endif
-
- file = fopen(PROCSTATFILE, "r");
- assert(file != NULL);
diff --git a/sysutils/htop/files/patch-RichString.c b/sysutils/htop/files/patch-RichString.c
deleted file mode 100644
index 0599728b1d7b..000000000000
--- a/sysutils/htop/files/patch-RichString.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- RichString.c.orig
-+++ RichString.c
-@@ -13,7 +13,11 @@
- #include "debug.h"
- #include <assert.h>
- #ifdef HAVE_LIBNCURSESW
-+# ifdef HAVE_NCURSESW_CURSES_H
- #include <ncursesw/curses.h>
-+# else
-+#include <curses.h>
-+# endif
- #else
- #include <curses.h>
- #endif
diff --git a/sysutils/htop/files/patch-RichString.h b/sysutils/htop/files/patch-RichString.h
deleted file mode 100644
index ff753a267e2d..000000000000
--- a/sysutils/htop/files/patch-RichString.h
+++ /dev/null
@@ -1,14 +0,0 @@
---- RichString.h.orig
-+++ RichString.h
-@@ -16,7 +16,11 @@
- #include "debug.h"
- #include <assert.h>
- #ifdef HAVE_LIBNCURSESW
-+# ifdef HAVE_NCURSESW_CURSES_H
- #include <ncursesw/curses.h>
-+# else
-+#include <curses.h>
-+# endif
- #else
- #include <curses.h>
- #endif
diff --git a/sysutils/htop/files/patch-configure.ac b/sysutils/htop/files/patch-configure.ac
deleted file mode 100644
index bea88b28ce17..000000000000
--- a/sysutils/htop/files/patch-configure.ac
+++ /dev/null
@@ -1,19 +0,0 @@
---- ./configure.ac.orig 2010-11-23 17:56:32.000000000 +0200
-+++ ./configure.ac 2011-08-11 12:50:44.000000000 +0300
-@@ -18,6 +18,7 @@
-
- # Checks for libraries.
- AC_CHECK_LIB([m], [ceil], [], [missing_libraries="$missing_libraries libm"])
-+AC_CHECK_LIB([kvm], [kvm_open], [], [missing_libraries="$missing_libraries libkvm"])
-
- # Checks for header files.
- AC_HEADER_DIRENT
-@@ -86,7 +87,7 @@
- AC_ARG_ENABLE(unicode, [AC_HELP_STRING([--enable-unicode], [enable Unicode support])], ,enable_unicode="no")
- if test "x$enable_unicode" = xyes; then
- AC_CHECK_LIB([ncursesw], [refresh], [], [missing_libraries="$missing_libraries libncursesw"])
-- AC_CHECK_HEADERS([ncursesw/curses.h],[:],[missing_headers="$missing_headers $ac_header"])
-+ AC_CHECK_HEADERS([curses.h],[:],[missing_headers="$missing_headers $ac_header"])
- else
- AC_CHECK_LIB([ncurses], [refresh], [], [missing_libraries="$missing_libraries libncurses"])
- AC_CHECK_HEADERS([curses.h],[:],[missing_headers="$missing_headers $ac_header"])
diff --git a/sysutils/htop/pkg-message b/sysutils/htop/pkg-message
index 1e01d504b267..451f7b1296d8 100644
--- a/sysutils/htop/pkg-message
+++ b/sysutils/htop/pkg-message
@@ -1,6 +1,6 @@
***********************************************************
htop(1) requires linprocfs(5) to be mounted. If you don't
have it mounted already, please add this line to /etc/fstab
-and run `mount linproc`:
+and run `mkdir -p /usr/compat/linux/proc; ln -s /usr/compat /compat; mount linproc`:
linproc /compat/linux/proc linprocfs rw 0 0
***********************************************************