aboutsummaryrefslogtreecommitdiff
path: root/sysutils/httplog/Makefile
diff options
context:
space:
mode:
authorAnders Nordby <anders@FreeBSD.org>2002-01-28 00:47:32 +0000
committerAnders Nordby <anders@FreeBSD.org>2002-01-28 00:47:32 +0000
commit2711247858f23ad32908246ee1eaef4848b36f5b (patch)
treef24778c5c25bb9485764dd9322a1eaaad6478e1d /sysutils/httplog/Makefile
parent67358798288f8a65d54b2c3bced5295116b23a51 (diff)
downloadports-2711247858f23ad32908246ee1eaef4848b36f5b.tar.gz
ports-2711247858f23ad32908246ee1eaef4848b36f5b.zip
Notes
Diffstat (limited to 'sysutils/httplog/Makefile')
-rw-r--r--sysutils/httplog/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/sysutils/httplog/Makefile b/sysutils/httplog/Makefile
index d1d67df4241a..6b3fde25a324 100644
--- a/sysutils/httplog/Makefile
+++ b/sysutils/httplog/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= httplog
-PORTVERSION= 1.9
+PORTVERSION= 2.1
CATEGORIES= sysutils www
MASTER_SITES= http://nutbar.chemlab.org/downloads/programs/ \
ftp://ftp.nuug.no/pub/anders/distfiles/
@@ -17,19 +17,21 @@ MAN8= httplog.8
DOCS= ChangeLog README
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX}
+
post-patch:
- (cd ${WRKSRC} && printf \
- "#define VERSION \"1.9\"\n#define USE_ZLIB\n#define USE_DEBUG\n" \
- >defines.h && \
+ (cd ${WRKSRC} && \
${PERL} -pi -e "s@<wait.h>@<sys/wait.h>@" httplog.c && \
- ${PERL} -pi -e "s@/var/lib/apache/bin/httplog@${PREFIX}/bin/httplog@" \
+ ${PERL} -pi -e \
+ "s@/var/lib/apache/bin/httplog@${PREFIX}/sbin/httplog@" \
httplog.8)
do-build:
(cd ${WRKSRC} && ${CC} ${CFLAGS} -o httplog httplog.c -lz)
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/httplog ${PREFIX}/bin/
+ ${INSTALL_PROGRAM} ${WRKSRC}/httplog ${PREFIX}/sbin/
${INSTALL_MAN} ${WRKSRC}/httplog.8 ${PREFIX}/man/man8/
.if !defined(NOPORTDOCS)
${INSTALL} -d -o root -g wheel -m 0755 ${DOCSDIR}