aboutsummaryrefslogtreecommitdiff
path: root/sysutils/iocage-devel
diff options
context:
space:
mode:
authorKris Moore <kmoore@FreeBSD.org>2015-07-14 15:12:05 +0000
committerKris Moore <kmoore@FreeBSD.org>2015-07-14 15:12:05 +0000
commit47b2a2250c31fb923e3d6d7ca841c0fa40310612 (patch)
treee5e92d7efea59615557bfa52f47d4550b59ae606 /sysutils/iocage-devel
parentb4541fc030f77e52b1c588bcdaa5a0a8eb01fc0f (diff)
downloadports-47b2a2250c31fb923e3d6d7ca841c0fa40310612.tar.gz
ports-47b2a2250c31fb923e3d6d7ca841c0fa40310612.zip
Notes
Diffstat (limited to 'sysutils/iocage-devel')
-rw-r--r--sysutils/iocage-devel/Makefile38
-rw-r--r--sysutils/iocage-devel/distinfo2
-rw-r--r--sysutils/iocage-devel/pkg-descr8
-rw-r--r--sysutils/iocage-devel/pkg-plist18
4 files changed, 66 insertions, 0 deletions
diff --git a/sysutils/iocage-devel/Makefile b/sysutils/iocage-devel/Makefile
new file mode 100644
index 000000000000..408d54cf2061
--- /dev/null
+++ b/sysutils/iocage-devel/Makefile
@@ -0,0 +1,38 @@
+# Created by: Johannes Meixner <xmj@chaot.net>
+# $FreeBSD$
+
+PORTNAME= iocage
+PORTVERSION= 1.6.6
+CATEGORIES= sysutils
+
+MAINTAINER= kmoore@freebsd.org
+COMMENT= Full featured, no dependency Jail container manager - devel build
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= pannon
+GH_TAGNAME= 52a68cf
+
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 900044
+BROKEN= This port works only on FreeBSD 9 and newer
+.endif
+
+NO_BUILD= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|/usr/local/lib/iocage|${PREFIX}/lib/iocage|g" ${WRKSRC}/iocage
+
+pre-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/iocage
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/rc.d/iocage ${STAGEDIR}${PREFIX}/etc/rc.d
+ ${INSTALL_SCRIPT} ${WRKSRC}/iocage ${STAGEDIR}${PREFIX}/sbin
+ (cd ${WRKSRC}/lib/ && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/lib/iocage)
+ ${INSTALL_MAN} ${WRKSRC}/iocage.8 ${STAGEDIR}${PREFIX}/man/man8
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/iocage-devel/distinfo b/sysutils/iocage-devel/distinfo
new file mode 100644
index 000000000000..a7b31deb86cf
--- /dev/null
+++ b/sysutils/iocage-devel/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pannon-iocage-1.6.6-52a68cf_GH0.tar.gz) = 452b67ebdff9ccb173e9f8b300989ae1c17c35f8d2f73cfeaa1459aa6611edef
+SIZE (pannon-iocage-1.6.6-52a68cf_GH0.tar.gz) = 289468
diff --git a/sysutils/iocage-devel/pkg-descr b/sysutils/iocage-devel/pkg-descr
new file mode 100644
index 000000000000..65b7cd2a55e6
--- /dev/null
+++ b/sysutils/iocage-devel/pkg-descr
@@ -0,0 +1,8 @@
+iocage is a zero dependency drop in jail/container manager
+amalgamating some of the best features and technologies
+FreeBSD operating system has to offer.
+
+It is geared for ease of use with a simple and easy to
+understand command syntax.
+
+WWW: https://github.com/pannon/iocage
diff --git a/sysutils/iocage-devel/pkg-plist b/sysutils/iocage-devel/pkg-plist
new file mode 100644
index 000000000000..cae838a61384
--- /dev/null
+++ b/sysutils/iocage-devel/pkg-plist
@@ -0,0 +1,18 @@
+etc/rc.d/iocage
+lib/iocage/ioc-cmd
+lib/iocage/ioc-common
+lib/iocage/ioc-configure
+lib/iocage/ioc-globals
+lib/iocage/ioc-hacks
+lib/iocage/ioc-help
+lib/iocage/ioc-image
+lib/iocage/ioc-info
+lib/iocage/ioc-network
+lib/iocage/ioc-rc
+lib/iocage/ioc-rctl
+lib/iocage/ioc-send
+lib/iocage/ioc-snapshot
+lib/iocage/ioc-upgrade
+lib/iocage/ioc-zfs
+man/man8/iocage.8.gz
+sbin/iocage