aboutsummaryrefslogtreecommitdiff
path: root/sysutils/ioping
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2014-01-03 19:31:31 +0000
committerJason Helfman <jgh@FreeBSD.org>2014-01-03 19:31:31 +0000
commit666bbdb36188d5c36ccc49e165c883e2db9b04bc (patch)
tree8d75839d8e982c333049d228674d3a0ff52f56f5 /sysutils/ioping
parent3f4e9f52fa8068f77d54d0074142c3b2770c2ad8 (diff)
downloadports-666bbdb36188d5c36ccc49e165c883e2db9b04bc.tar.gz
ports-666bbdb36188d5c36ccc49e165c883e2db9b04bc.zip
Notes
Diffstat (limited to 'sysutils/ioping')
-rw-r--r--sysutils/ioping/Makefile13
-rw-r--r--sysutils/ioping/distinfo4
-rw-r--r--sysutils/ioping/files/patch-ioping.c32
3 files changed, 9 insertions, 40 deletions
diff --git a/sysutils/ioping/Makefile b/sysutils/ioping/Makefile
index ece663b43b80..75cc3fef4edf 100644
--- a/sysutils/ioping/Makefile
+++ b/sysutils/ioping/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= ioping
-PORTVERSION= 0.7
+PORTVERSION= 0.8
CATEGORIES= sysutils
MASTER_SITES= GOOGLE_CODE
@@ -11,21 +11,16 @@ COMMENT= Simple disk I/0 latency measuring tool
LICENSE= GPLv3
-MAN1= ioping.1
-PLIST_FILES= bin/ioping
+PLIST_FILES= bin/ioping man/man1/ioping.1.gz
MAKE_ENV= VERSION=${PORTVERSION}
-# for the benefit of <80000
-CFLAGS+= -lm
-
-NO_STAGE= yes
do-build:
cd ${WRKSRC}; \
${SETENV} ${MAKE_ENV} ${CC} ${CFLAGS} -DVERSION=${PORTVERSION} ioping.c -o ioping
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/ioping ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/ioping.1 ${MAN1PREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/ioping ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/ioping.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
.include <bsd.port.mk>
diff --git a/sysutils/ioping/distinfo b/sysutils/ioping/distinfo
index 26303abf4801..c2b9746a8d3e 100644
--- a/sysutils/ioping/distinfo
+++ b/sysutils/ioping/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ioping-0.7.tar.gz) = 234e28eeb256e77756a077604b48d59f206a5288c3da6f207629e783f54b13b0
-SIZE (ioping-0.7.tar.gz) = 10011
+SHA256 (ioping-0.8.tar.gz) = e23fdbd7298e26b63986137d6007e5a72d495da7265b9edea4c12f1b0c55fe48
+SIZE (ioping-0.8.tar.gz) = 10590
diff --git a/sysutils/ioping/files/patch-ioping.c b/sysutils/ioping/files/patch-ioping.c
index 2b383fe9c330..3a02e9b29900 100644
--- a/sysutils/ioping/files/patch-ioping.c
+++ b/sysutils/ioping/files/patch-ioping.c
@@ -1,32 +1,6 @@
---- ioping.c.orig 2013-02-02 21:00:59.000000000 +0400
-+++ ioping.c 2013-07-23 15:53:52.000000000 +0400
-@@ -154,11 +154,6 @@
- return FlushFileBuffers(h) ? 0 : -1;
- }
-
--int fdatasync(int fd)
--{
-- return fsync(fd);
--}
--
- void srandom(unsigned int seed)
- {
- srand(seed);
-@@ -178,6 +173,13 @@
-
- #endif /* __MINGW32__ */
-
-+#if defined(__FreeBSD__) || defined(__FreeBSD_kernel__) || defined(__MINGW32__)
-+int fdatasync(int fd)
-+{
-+ return fsync(fd);
-+}
-+#endif /* (__FreeBSD__) || defined(__FreeBSD_kernel__) || defined(__MINGW32__) */
-+
- #ifndef HAVE_POSIX_MEMALIGN
- /* don't free it */
- int posix_memalign(void **memptr, size_t alignment, size_t size)
-@@ -222,7 +224,7 @@
+--- ioping.c.orig 2014-01-03 10:36:08.000000000 +0400
++++ ioping.c 2014-01-03 10:36:48.000000000 +0400
+@@ -247,7 +247,7 @@
void version(void)
{