aboutsummaryrefslogtreecommitdiff
path: root/sysutils/ipa
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-07-31 17:42:34 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-07-31 17:42:34 +0000
commit46290e08118852155f975db999d87cc914a31265 (patch)
treeedd70f29d153bc94a2fee142e9f3da43c67df972 /sysutils/ipa
parentdaa05435e2f8e42b5609ac864ee0bedaec95cd91 (diff)
downloadports-46290e08118852155f975db999d87cc914a31265.tar.gz
ports-46290e08118852155f975db999d87cc914a31265.zip
Notes
Diffstat (limited to 'sysutils/ipa')
-rw-r--r--sysutils/ipa/Makefile6
-rw-r--r--sysutils/ipa/distinfo2
-rw-r--r--sysutils/ipa/files/patch-aa55
-rw-r--r--sysutils/ipa/pkg-plist11
4 files changed, 61 insertions, 13 deletions
diff --git a/sysutils/ipa/Makefile b/sysutils/ipa/Makefile
index 54776c627ad7..4c622a3c1815 100644
--- a/sysutils/ipa/Makefile
+++ b/sysutils/ipa/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ipa
-PORTVERSION= 1.1.3
+PORTVERSION= 1.1.4
CATEGORIES= sysutils
MASTER_SITES= http://www.simon.org.ua/ipa/
@@ -19,4 +19,8 @@ MAN5= ipa.5 ipa.conf.5
MAN8= ipa.8 ipastat.8
MANLANG= "" ru_RU.KOI8-R
+post-patch:
+ @${PERL} -pi -ne "s|/usr/local/|${PREFIX}/|" \
+ ${WRKSRC}/Makefile
+
.include <bsd.port.mk>
diff --git a/sysutils/ipa/distinfo b/sysutils/ipa/distinfo
index 90676754a2f4..9431ab07529c 100644
--- a/sysutils/ipa/distinfo
+++ b/sysutils/ipa/distinfo
@@ -1 +1 @@
-MD5 (ipa-1.1.3.tar.gz) = 79966745dafd16ce909ade55fb10ffc8
+MD5 (ipa-1.1.4.tar.gz) = 996c0d9459c64695971bd6c5b427182d
diff --git a/sysutils/ipa/files/patch-aa b/sysutils/ipa/files/patch-aa
index 142fa47326b2..27c91dcce5cd 100644
--- a/sysutils/ipa/files/patch-aa
+++ b/sysutils/ipa/files/patch-aa
@@ -1,5 +1,5 @@
---- Makefile.orig Sun Jun 24 19:18:49 2001
-+++ Makefile Mon Jun 25 23:08:29 2001
+--- Makefile.orig Mon Jul 16 15:15:34 2001
++++ Makefile Tue Jul 31 14:36:48 2001
@@ -38,7 +38,7 @@
# -O3 - optimize (it seems that -O3 also help to find out some errors);
# -g - produce debugging information.
@@ -9,12 +9,55 @@
#
# DSTBINDIR - where to install binaries
-@@ -204,7 +204,7 @@
+@@ -63,7 +63,7 @@
+ #
+ # DSTSHAREDIR - where to install examples, etc.
+ #
+-DSTSHAREDIR= /usr/local/share/ipa
++DSTSHAREDIR= /usr/local/share/examples/ipa
+
+ #
+ # IP6FW (FreeBSD only)
+@@ -204,25 +204,25 @@
@${ECHO}
.else
@${ECHO} ">> Installing binaries, manual pages and miscellaneous files"
- ${INSTALL} -c -g wheel -o root -m 0555 ipa ipastat ${DSTBINDIR}
-+ ${INSTALL} -c -s -g wheel -o root -m 0555 ipa ipastat ${DSTBINDIR}
++ ${BSD_INSTALL_PROGRAM} ipa ipastat ${DSTBINDIR}
${CHMOD} u+s ${DSTBINDIR}/ipastat
- ${INSTALL} -c -g wheel -o root -m 0444 man/ipa.5 man/ipa.conf.5 ${DSTMANDIR}/man5
- ${INSTALL} -c -g wheel -o root -m 0444 man/ipa.8 man/ipastat.8 ${DSTMANDIR}/man8
+- ${INSTALL} -c -g wheel -o root -m 0444 man/ipa.5 man/ipa.conf.5 ${DSTMANDIR}/man5
+- ${INSTALL} -c -g wheel -o root -m 0444 man/ipa.8 man/ipastat.8 ${DSTMANDIR}/man8
+ .if !exists(${DSTMANDIR}/ru_SU.KOI8-R/man5)
+ ${INSTALL} -d -m 0555 ${DSTMANDIR}/ru_SU.KOI8-R/man5
+ .endif
+ .if !exists(${DSTMANDIR}/ru_SU.KOI8-R/man8)
+ ${INSTALL} -d -m 0555 ${DSTMANDIR}/ru_SU.KOI8-R/man8
+ .endif
++ ${BSD_INSTALL_MAN} man/ipa.5 man/ipa.conf.5 ${DSTMANDIR}/man5
++ ${BSD_INSTALL_MAN} man/ipa.8 man/ipastat.8 ${DSTMANDIR}/man8
+ .if !exists(${DSTMANDIR}/ru_RU.KOI8-R)
+ ${LN} -s ${DSTMANDIR}/ru_SU.KOI8-R ${DSTMANDIR}/ru_RU.KOI8-R
+ .endif
+- ${INSTALL} -c -g wheel -o root -m 0444 man/ru_RU.KOI8-R/ipa.5 man/ru_RU.KOI8-R/ipa.conf.5 ${DSTMANDIR}/ru_RU.KOI8-R/man5
+- ${INSTALL} -c -g wheel -o root -m 0444 man/ru_RU.KOI8-R/ipa.8 man/ru_RU.KOI8-R/ipastat.8 ${DSTMANDIR}/ru_RU.KOI8-R/man8
+- ${INSTALL} -d -m 0555 ${DSTSHAREDIR}/examples
+- ${INSTALL} -c -g wheel -o root -m 0444 examples/* ${DSTSHAREDIR}/examples
++ ${BSD_INSTALL_MAN} man/ru_RU.KOI8-R/ipa.5 man/ru_RU.KOI8-R/ipa.conf.5 ${DSTMANDIR}/ru_RU.KOI8-R/man5
++ ${BSD_INSTALL_MAN} man/ru_RU.KOI8-R/ipa.8 man/ru_RU.KOI8-R/ipastat.8 ${DSTMANDIR}/ru_RU.KOI8-R/man8
++ ${INSTALL} -d -m 0555 ${DSTSHAREDIR}
++ ${BSD_INSTALL_DATA} examples/* ${DSTSHAREDIR}
+ .if exists(${DSTRCDIR})
+- ${INSTALL} -c -g wheel -o root -m 0500 etc/ipa.sh.sample ${DSTRCDIR}
++ ${BSD_INSTALL_DATA} etc/ipa.sh.sample ${DSTRCDIR}
+ .else
+ @${ECHO}
+ @${ECHO} ">> Can't find directory ${DSTRCDIR}, skip installing of ipa.sh.sample"
+@@ -230,7 +230,7 @@
+ @${ECHO}
+ .endif
+ .if exists(${DSTETCDIR})
+- ${INSTALL} -c -g wheel -o root -m 0400 etc/ipa.conf.default ${DSTETCDIR}
++ ${BSD_INSTALL_DATA} -c -g wheel -o root -m 0400 etc/ipa.conf.default ${DSTETCDIR}
+ .else
+ @${ECHO}
+ @${ECHO} ">> Can't find directory ${DSTETCDIR}, skip installing of ipa.conf.default"
diff --git a/sysutils/ipa/pkg-plist b/sysutils/ipa/pkg-plist
index 6124a9c409b5..2ed139400494 100644
--- a/sysutils/ipa/pkg-plist
+++ b/sysutils/ipa/pkg-plist
@@ -1,9 +1,10 @@
bin/ipa
bin/ipastat
etc/ipa.conf.default
+@unexec if [ -f %D/etc/rc.d/ipa.sh ]; then cmp -s %D/etc/rc.d/ipa.sh.sample %D/etc/rc.d/ipa.sh && rm -f %D/etc/rc.d/ipa.sh || echo "If you are permanently removing this port, you should do a ``rm ${PKG_PREFIX}/etc/rc.d/ipa.sh`` to remove startup files left." | fmt ; fi
etc/rc.d/ipa.sh.sample
-share/ipa/examples/README
-share/ipa/examples/example-1
-share/ipa/examples/example-2
-@dirrm share/ipa/examples
-@dirrm share/ipa
+share/examples/ipa/README
+share/examples/ipa/example-1
+share/examples/ipa/example-2
+@dirrm share/examples/ipa
+@unexec rmdir %D/man/ru_SU.KOI8-R/man8 %D/man/ru_SU.KOI8-R/man5 %D/man/ru_SU.KOI8-R && rm %D/man/ru_RU.KOI8-R || true