aboutsummaryrefslogtreecommitdiff
path: root/sysutils/ipmitool
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2012-10-04 10:27:32 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2012-10-04 10:27:32 +0000
commit60820d612b8a6b4b5700dd02145552bb0d6011f2 (patch)
tree2d14c08f1d8301b6da614eaa6d74bdfeb7fe3610 /sysutils/ipmitool
parent8da9eeea9bc847ec985612266eb2cbb0a5c9a0cc (diff)
downloadports-60820d612b8a6b4b5700dd02145552bb0d6011f2.tar.gz
ports-60820d612b8a6b4b5700dd02145552bb0d6011f2.zip
Notes
Diffstat (limited to 'sysutils/ipmitool')
-rw-r--r--sysutils/ipmitool/Makefile31
-rw-r--r--sysutils/ipmitool/distinfo4
-rw-r--r--sysutils/ipmitool/files/patch-configure11
-rw-r--r--sysutils/ipmitool/files/patch-include__ipmitool__ipmi_sdr.h11
-rw-r--r--sysutils/ipmitool/files/patch-lib__ipmi_fru.c21
-rw-r--r--sysutils/ipmitool/files/patch-lib__ipmi_sdr.c83
-rw-r--r--sysutils/ipmitool/files/patch-src__ipmishell.c10
-rw-r--r--sysutils/ipmitool/files/patch-src__plugins__lan__lan.c10
8 files changed, 28 insertions, 153 deletions
diff --git a/sysutils/ipmitool/Makefile b/sysutils/ipmitool/Makefile
index 37fdc9d8506d..8b9ddd08dcad 100644
--- a/sysutils/ipmitool/Makefile
+++ b/sysutils/ipmitool/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= ipmitool
-PORTVERSION= 1.8.11
-PORTREVISION= 4
+PORTVERSION= 1.8.12
CATEGORIES= sysutils
MASTER_SITES= SF
@@ -15,7 +14,6 @@ MAINTAINER= spolyack@collaborativefusion.com
COMMENT= CLI to manage IPMI systems
USE_BZIP2= yes
-DOS2UNIX= ipmi_fwum.c
USE_GMAKE= yes
USE_OPENSSL= yes
GNU_CONFIGURE= yes
@@ -33,25 +31,26 @@ MAN8+= ipmievd.8
PERIODIC_DIR= etc/periodic/daily
+OPTIONS_DEFINE= FREEIPMI
+FREEIPMI_DESC= Enable support for freeipmi
+
.if defined(WITH_DEBUG)
CFLAGS+= -ggdb -Wall
.endif
-.include <bsd.port.pre.mk>
-
-post-install:
- @${MKDIR} ${PREFIX}/${PERIODIC_DIR}
- @${INSTALL_SCRIPT} ${WRKDIR}/status-ipmi.sh ${PREFIX}/${PERIODIC_DIR}/400.status-ipmi
-
.if exists(/usr/include/sys/ipmi.h)
CONFIGURE_ARGS+= --enable-intf-open
.else
CONFIGURE_ARGS+= --disable-intf-open
.endif
-.if defined(WITH_FREEIPMI) || \
- (exists(${LOCALBASE}/include/freeipmi/freeipmi.h) && \
- !defined(WITHOUT_FREEIPMI))
+.include <bsd.port.options.mk>
+
+.if empty(PORT_OPTIONS:MDOCS)
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-Makefile.in
+.endif
+
+.if ${PORT_OPTIONS:MFREEIPMI}
LIB_DEPENDS+= freeipmi:${PORTSDIR}/sysutils/freeipmi
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -60,8 +59,8 @@ CONFIGURE_ARGS+= --enable-intf-free
CONFIGURE_ARGS+= --disable-intf-free
.endif
-.if defined(NOPORTDOCS)
-EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-Makefile.in
-.endif
+post-install:
+ @${MKDIR} ${PREFIX}/${PERIODIC_DIR}
+ @${INSTALL_SCRIPT} ${WRKDIR}/status-ipmi.sh ${PREFIX}/${PERIODIC_DIR}/400.status-ipmi
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/ipmitool/distinfo b/sysutils/ipmitool/distinfo
index 3c0886915e69..622157d77b0e 100644
--- a/sysutils/ipmitool/distinfo
+++ b/sysutils/ipmitool/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ipmitool-1.8.11.tar.bz2) = df219019dc2216c3b7a894edd20286b2118aa636f9990c8405674ce84948eddd
-SIZE (ipmitool-1.8.11.tar.bz2) = 584416
+SHA256 (ipmitool-1.8.12.tar.bz2) = 549b2da65c30905248aee07367a9cae3dd94bceaddd9c122d55075766c868733
+SIZE (ipmitool-1.8.12.tar.bz2) = 684159
diff --git a/sysutils/ipmitool/files/patch-configure b/sysutils/ipmitool/files/patch-configure
new file mode 100644
index 000000000000..03f57716025f
--- /dev/null
+++ b/sysutils/ipmitool/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2012-09-18 21:50:01.000000000 +0200
++++ configure 2012-09-18 21:50:14.000000000 +0200
+@@ -5030,7 +5030,7 @@
+ done
+
+
+-CFLAGS="$CFLAGS -fno-strict-aliasing -Wreturn-type -Wno-unused-result -Wno-packed-bitfield-compat"
++CFLAGS="$CFLAGS -fno-strict-aliasing -Wreturn-type"
+
+ case `pwd` in
+ *\ * | *\ *)
diff --git a/sysutils/ipmitool/files/patch-include__ipmitool__ipmi_sdr.h b/sysutils/ipmitool/files/patch-include__ipmitool__ipmi_sdr.h
deleted file mode 100644
index c8e6db43ffe6..000000000000
--- a/sysutils/ipmitool/files/patch-include__ipmitool__ipmi_sdr.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./include/ipmitool/ipmi_sdr.h.orig 2009-02-25 15:38:52.000000000 -0500
-+++ ./include/ipmitool/ipmi_sdr.h 2010-07-23 14:46:07.000000000 -0400
-@@ -277,7 +277,7 @@
- uint16_t settable:8;
- #endif
- } read;
-- };
-+ } type;
- } threshold;
- } type;
- } __attribute__ ((packed));
diff --git a/sysutils/ipmitool/files/patch-lib__ipmi_fru.c b/sysutils/ipmitool/files/patch-lib__ipmi_fru.c
deleted file mode 100644
index 354f5a97b1de..000000000000
--- a/sysutils/ipmitool/files/patch-lib__ipmi_fru.c
+++ /dev/null
@@ -1,21 +0,0 @@
---- ./lib/ipmi_fru.c.orig 2009-02-25 15:38:52.000000000 -0500
-+++ ./lib/ipmi_fru.c 2010-07-23 14:46:07.000000000 -0400
-@@ -489,7 +489,8 @@
- struct ipmi_rq req;
- uint8_t msg_data[25];
- uint8_t writeLength;
-- uint16_t num_bloc;
-+ uint16_t num_bloc;
-+ t_ipmi_fru_bloc * fru_bloc;
-
- finish = doffset + length; /* destination offset */
- if (finish > fru->size)
-@@ -498,7 +499,7 @@
- return -1;
- }
-
-- t_ipmi_fru_bloc * fru_bloc = build_fru_bloc(intf, fru, id, &num_bloc);
-+ fru_bloc = build_fru_bloc(intf, fru, id, &num_bloc);
-
- memset(&req, 0, sizeof(req));
- req.msg.netfn = IPMI_NETFN_STORAGE;
diff --git a/sysutils/ipmitool/files/patch-lib__ipmi_sdr.c b/sysutils/ipmitool/files/patch-lib__ipmi_sdr.c
deleted file mode 100644
index 92374cb8147e..000000000000
--- a/sysutils/ipmitool/files/patch-lib__ipmi_sdr.c
+++ /dev/null
@@ -1,83 +0,0 @@
---- ./lib/ipmi_sdr.c.orig 2009-02-25 15:38:52.000000000 -0500
-+++ ./lib/ipmi_sdr.c 2010-07-23 14:46:07.000000000 -0400
-@@ -775,7 +775,7 @@
- /* helper macro for printing sensor thresholds */
- #define SENSOR_PRINT_THRESH(NAME, READ, FLAG) \
- if (sensor->sensor.init.thresholds && \
-- sensor->mask.type.threshold.read.FLAG != 0) { \
-+ sensor->mask.type.threshold.type.read.FLAG != 0) { \
- printf(" %-21s : ", NAME); \
- printf("%.3f\n", sdr_convert_sensor_reading( \
- sensor, sensor->threshold.READ)); \
-@@ -1247,17 +1247,17 @@
- sensor->normal_min);
- SENSOR_PRINT_CSV(sensor->analog_flag.normal_max,
- sensor->normal_max);
-- SENSOR_PRINT_CSV(sensor->mask.type.threshold.read.unr,
-+ SENSOR_PRINT_CSV(sensor->mask.type.threshold.type.read.unr,
- sensor->threshold.upper.non_recover);
-- SENSOR_PRINT_CSV(sensor->mask.type.threshold.read.ucr,
-+ SENSOR_PRINT_CSV(sensor->mask.type.threshold.type.read.ucr,
- sensor->threshold.upper.critical);
-- SENSOR_PRINT_CSV(sensor->mask.type.threshold.read.unc,
-+ SENSOR_PRINT_CSV(sensor->mask.type.threshold.type.read.unc,
- sensor->threshold.upper.non_critical);
-- SENSOR_PRINT_CSV(sensor->mask.type.threshold.read.lnr,
-+ SENSOR_PRINT_CSV(sensor->mask.type.threshold.type.read.lnr,
- sensor->threshold.lower.non_recover);
-- SENSOR_PRINT_CSV(sensor->mask.type.threshold.read.lcr,
-+ SENSOR_PRINT_CSV(sensor->mask.type.threshold.type.read.lcr,
- sensor->threshold.lower.critical);
-- SENSOR_PRINT_CSV(sensor->mask.type.threshold.read.lnc,
-+ SENSOR_PRINT_CSV(sensor->mask.type.threshold.type.read.lnc,
- sensor->threshold.lower.non_critical);
-
- printf("%.3f,%.3f",
-@@ -1485,17 +1485,17 @@
- break;
- case 1: /* readable according to mask */
- case 2: /* readable and settable according to mask */
-- if (sensor->mask.type.threshold.read.lnr)
-+ if (sensor->mask.type.threshold.type.read.lnr)
- printf("lnr ");
-- if (sensor->mask.type.threshold.read.lcr)
-+ if (sensor->mask.type.threshold.type.read.lcr)
- printf("lcr ");
-- if (sensor->mask.type.threshold.read.lnc)
-+ if (sensor->mask.type.threshold.type.read.lnc)
- printf("lnc ");
-- if (sensor->mask.type.threshold.read.unc)
-+ if (sensor->mask.type.threshold.type.read.unc)
- printf("unc ");
-- if (sensor->mask.type.threshold.read.ucr)
-+ if (sensor->mask.type.threshold.type.read.ucr)
- printf("ucr ");
-- if (sensor->mask.type.threshold.read.unr)
-+ if (sensor->mask.type.threshold.type.read.unr)
- printf("unr ");
- printf("\n");
- break;
-@@ -1511,17 +1511,17 @@
- break;
- case 1: /* readable according to mask */
- case 2: /* readable and settable according to mask */
-- if (sensor->mask.type.threshold.set.lnr)
-+ if (sensor->mask.type.threshold.type.set.lnr)
- printf("lnr ");
-- if (sensor->mask.type.threshold.set.lcr)
-+ if (sensor->mask.type.threshold.type.set.lcr)
- printf("lcr ");
-- if (sensor->mask.type.threshold.set.lnc)
-+ if (sensor->mask.type.threshold.type.set.lnc)
- printf("lnc ");
-- if (sensor->mask.type.threshold.set.unc)
-+ if (sensor->mask.type.threshold.type.set.unc)
- printf("unc ");
-- if (sensor->mask.type.threshold.set.ucr)
-+ if (sensor->mask.type.threshold.type.set.ucr)
- printf("ucr ");
-- if (sensor->mask.type.threshold.set.unr)
-+ if (sensor->mask.type.threshold.type.set.unr)
- printf("unr ");
- printf("\n");
- break;
diff --git a/sysutils/ipmitool/files/patch-src__ipmishell.c b/sysutils/ipmitool/files/patch-src__ipmishell.c
deleted file mode 100644
index d68cc9bb3230..000000000000
--- a/sysutils/ipmitool/files/patch-src__ipmishell.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./src/ipmishell.c.orig 2009-02-25 15:38:52.000000000 -0500
-+++ ./src/ipmishell.c 2010-07-23 14:46:07.000000000 -0400
-@@ -57,7 +57,6 @@
- #ifdef HAVE_READLINE
-
- /* avoid warnings errors due to non-ANSI type declarations in readline.h */
--#define _FUNCTION_DEF
- #define USE_VARARGS
- #define PREFER_STDARG
-
diff --git a/sysutils/ipmitool/files/patch-src__plugins__lan__lan.c b/sysutils/ipmitool/files/patch-src__plugins__lan__lan.c
deleted file mode 100644
index 18673895430e..000000000000
--- a/sysutils/ipmitool/files/patch-src__plugins__lan__lan.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./src/plugins/lan/lan.c.orig 2009-02-25 15:38:53.000000000 -0500
-+++ ./src/plugins/lan/lan.c 2010-07-23 14:46:07.000000000 -0400
-@@ -36,6 +36,7 @@
- #include <string.h>
- #include <sys/types.h>
- #include <sys/socket.h>
-+#include <sys/time.h>
- #include <netinet/in.h>
- #include <arpa/inet.h>
- #include <errno.h>