aboutsummaryrefslogtreecommitdiff
path: root/sysutils/jps
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-06-27 03:43:03 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-06-27 03:43:03 +0000
commitb5dcba72319540e1a68a3c0035a96f5018fb5116 (patch)
treeb5df78cb71b27c663ed1cc4cb0494ddd25b34f3b /sysutils/jps
parentf9a4673b3f39106248bb8e3ef2f13927a7749ccf (diff)
downloadports-b5dcba72319540e1a68a3c0035a96f5018fb5116.tar.gz
ports-b5dcba72319540e1a68a3c0035a96f5018fb5116.zip
Notes
Diffstat (limited to 'sysutils/jps')
-rw-r--r--sysutils/jps/Makefile8
-rw-r--r--sysutils/jps/files/patch-Makefile13
2 files changed, 16 insertions, 5 deletions
diff --git a/sysutils/jps/Makefile b/sysutils/jps/Makefile
index fbc7932e1e08..243d648832a2 100644
--- a/sysutils/jps/Makefile
+++ b/sysutils/jps/Makefile
@@ -12,10 +12,8 @@ COMMENT= Wrapper to ps(1) that maps pids to jails
BUILD_DEPENDS= p5-Term-ReadKey>=0:${PORTSDIR}/devel/p5-Term-ReadKey
RUN_DEPENDS:= ${BUILD_DEPENDS}
-MAN1= jps.1
-MANCOMPRESSED= yes
-USES= perl5
-PLIST_FILES= bin/jps
+USES= perl5 shebangfix
+PLIST_FILES= bin/jps man/man1/jps.1.gz
+SHEBANG_FILES= jps.pl
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/sysutils/jps/files/patch-Makefile b/sysutils/jps/files/patch-Makefile
new file mode 100644
index 000000000000..3f8ec1881c3b
--- /dev/null
+++ b/sysutils/jps/files/patch-Makefile
@@ -0,0 +1,13 @@
+--- Makefile.orig 2014-06-27 11:33:54.689401738 +0800
++++ Makefile 2014-06-27 11:34:10.118431813 +0800
+@@ -40,8 +40,8 @@ clean:
+ ${RM} -rf ${TARGETS}
+
+ install: all
+- ${INSTALL_BIN} ${PKG} ${PFX}/bin
+- ${INSTALL_MAN} ${PKG}.${MAN_SFX}.gz ${PFX}/${MAN_DIR}
++ ${INSTALL_BIN} ${PKG} $(DESTDIR)${PFX}/bin
++ ${INSTALL_MAN} ${PKG}.${MAN_SFX}.gz $(DESTDIR)${PFX}/${MAN_DIR}
+
+ deinstall:
+ ${RM} -f ${PFX}/bin/${PKG}