aboutsummaryrefslogtreecommitdiff
path: root/sysutils/k3b-kde4
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-10-21 20:41:54 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-10-21 20:41:54 +0000
commita146c864dc491c9d08e3d9b119fe830d66845fad (patch)
tree182fb4b1c73677af4ee6691554a0933cfee2ba7b /sysutils/k3b-kde4
parentc8223c167a892358517ce0b9e2bc136ddd4de47a (diff)
downloadports-a146c864dc491c9d08e3d9b119fe830d66845fad.tar.gz
ports-a146c864dc491c9d08e3d9b119fe830d66845fad.zip
Notes
Diffstat (limited to 'sysutils/k3b-kde4')
-rw-r--r--sysutils/k3b-kde4/Makefile2
-rw-r--r--sysutils/k3b-kde4/files/patch-ffmpeg219
-rw-r--r--sysutils/k3b-kde4/files/patch-libav922
3 files changed, 42 insertions, 1 deletions
diff --git a/sysutils/k3b-kde4/Makefile b/sysutils/k3b-kde4/Makefile
index 203958e92a6a..93d569b76331 100644
--- a/sysutils/k3b-kde4/Makefile
+++ b/sysutils/k3b-kde4/Makefile
@@ -3,7 +3,7 @@
PORTNAME= k3b
PORTVERSION= 2.0.2
-PORTREVISION= 12
+PORTREVISION= 13
CATEGORIES= sysutils multimedia kde
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}
diff --git a/sysutils/k3b-kde4/files/patch-ffmpeg2 b/sysutils/k3b-kde4/files/patch-ffmpeg2
new file mode 100644
index 000000000000..09248c5938ab
--- /dev/null
+++ b/sysutils/k3b-kde4/files/patch-ffmpeg2
@@ -0,0 +1,19 @@
+https://bugs.gentoo.org/show_bug.cgi?id=476494
+
+A better patch using avcodec_decode_audio4 will be needed but for now this
+fixes the problem.
+
+Index: k3b-2.0.2/plugins/decoder/ffmpeg/k3bffmpegwrapper.cpp
+===================================================================
+--- plugins/decoder/ffmpeg/k3bffmpegwrapper.cpp.orig
++++ plugins/decoder/ffmpeg/k3bffmpegwrapper.cpp
+@@ -37,6 +37,9 @@ extern "C" {
+
+ #include <klocale.h>
+
++#ifndef AVCODEC_MAX_AUDIO_FRAME_SIZE
++#define AVCODEC_MAX_AUDIO_FRAME_SIZE (192000 * 4)
++#endif
+
+ #if LIBAVFORMAT_BUILD < 4629
+ #define FFMPEG_BUILD_PRE_4629
diff --git a/sysutils/k3b-kde4/files/patch-libav9 b/sysutils/k3b-kde4/files/patch-libav9
new file mode 100644
index 000000000000..6ea8ed5fcc8f
--- /dev/null
+++ b/sysutils/k3b-kde4/files/patch-libav9
@@ -0,0 +1,22 @@
+Index: k3b-2.0.2/plugins/decoder/ffmpeg/k3bffmpegwrapper.cpp
+===================================================================
+--- plugins/decoder/ffmpeg/k3bffmpegwrapper.cpp.orig 2013-04-22 17:46:13.523959500 +0200
++++ plugins/decoder/ffmpeg/k3bffmpegwrapper.cpp 2013-04-22 18:40:49.890007513 +0200
+@@ -95,7 +95,7 @@ bool K3bFFMpegFile::open()
+ }
+
+ // analyze the streams
+- ::av_find_stream_info( d->formatContext );
++ ::avformat_find_stream_info( d->formatContext, 0 );
+
+ // we only handle files containing one audio stream
+ if( d->formatContext->nb_streams != 1 ) {
+@@ -129,7 +129,7 @@ bool K3bFFMpegFile::open()
+
+ // open the codec on our context
+ kDebug() << "(K3bFFMpegFile) found codec for " << m_filename;
+- if( ::avcodec_open( codecContext, d->codec ) < 0 ) {
++ if( ::avcodec_open2( codecContext, d->codec, 0 ) < 0 ) {
+ kDebug() << "(K3bFFMpegDecoderFactory) could not open codec.";
+ return false;
+ }