aboutsummaryrefslogtreecommitdiff
path: root/sysutils/klineakconfig
diff options
context:
space:
mode:
authorMarkus Brueffer <markus@FreeBSD.org>2007-03-19 21:03:32 +0000
committerMarkus Brueffer <markus@FreeBSD.org>2007-03-19 21:03:32 +0000
commit434a6cce44fb0c644ab131845fb8529b13cff511 (patch)
tree1b403e6401685b097a2f1e826e6bde08db0d8e7e /sysutils/klineakconfig
parent70a5178671da952d29f6c9da528f14a7163a0f30 (diff)
downloadports-434a6cce44fb0c644ab131845fb8529b13cff511.tar.gz
ports-434a6cce44fb0c644ab131845fb8529b13cff511.zip
Notes
Diffstat (limited to 'sysutils/klineakconfig')
-rw-r--r--sysutils/klineakconfig/Makefile29
-rw-r--r--sysutils/klineakconfig/distinfo3
-rw-r--r--sysutils/klineakconfig/files/patch-klineakconfig__klineakconfig.cpp211
-rw-r--r--sysutils/klineakconfig/pkg-descr5
-rw-r--r--sysutils/klineakconfig/pkg-plist22
5 files changed, 270 insertions, 0 deletions
diff --git a/sysutils/klineakconfig/Makefile b/sysutils/klineakconfig/Makefile
new file mode 100644
index 000000000000..35b4e807d434
--- /dev/null
+++ b/sysutils/klineakconfig/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: klineakconfig
+# Date created: 5 July 2002
+# Whom: Kay Lehmann <kay_lehmann@web.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= klineakconfig
+PORTVERSION= 0.9
+CATEGORIES= sysutils kde
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= lineak
+DIST_SUBDIR= lineak
+
+MAINTAINER= kay_lehmann@web.de
+COMMENT= Configure lineakd through a KDE interface
+
+LIB_DEPENDS= lineak.8:${PORTSDIR}/sysutils/lineakd
+
+USE_KDELIBS_VER=3
+USE_GMAKE= yes
+USE_AUTOTOOLS= libtool:15
+
+post-patch:
+ @${TOUCH} ${WRKSRC}/config.h.in
+ @${REINPLACE_CMD} -e 's|-ldl||;s|-O2||g;s|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/sysutils/klineakconfig/distinfo b/sysutils/klineakconfig/distinfo
new file mode 100644
index 000000000000..199ddd287f2c
--- /dev/null
+++ b/sysutils/klineakconfig/distinfo
@@ -0,0 +1,3 @@
+MD5 (lineak/klineakconfig-0.9.tar.gz) = b673575854f8d31443e05614ebb3e238
+SHA256 (lineak/klineakconfig-0.9.tar.gz) = 00f2f6f30e03b59b1b6be952869f56e82eb0f95ebf27059394254da3319ebce8
+SIZE (lineak/klineakconfig-0.9.tar.gz) = 970001
diff --git a/sysutils/klineakconfig/files/patch-klineakconfig__klineakconfig.cpp b/sysutils/klineakconfig/files/patch-klineakconfig__klineakconfig.cpp
new file mode 100644
index 000000000000..8e0633ad99e2
--- /dev/null
+++ b/sysutils/klineakconfig/files/patch-klineakconfig__klineakconfig.cpp
@@ -0,0 +1,211 @@
+--- klineakconfig/klineakconfig.cpp.orig Mon Jun 5 18:36:05 2006
++++ klineakconfig/klineakconfig.cpp Mon Jun 5 18:39:06 2006
+@@ -55,7 +55,7 @@
+ QString parsefile = QString::null;
+ parsefile = QDir::homeDirPath() + CONFFILE;
+
+- msg("Loading the plugin manager");
++ lineak_core_functions::msg("Loading the plugin manager");
+ plugins = new PluginManager;
+ vector<string> pluginlist = plugins->scanForPlugins();
+ /** Load the plugins */
+@@ -68,7 +68,7 @@
+ macrolist = plugins->getMacroList();
+ /** Get a list of directives from the plugins and their defaults that we support here */
+ dnd = plugins->getDirectivesList();
+- msg("Setting dnd!");
++ lineak_core_functions::msg("Setting dnd!");
+ /** Add to the list of directives and defaults that we support implicitly. */
+ dnd.addValue(_CD_KEYBOARD_TYPE, snull);
+ dnd.addValue(_CD_USERCONFFILE, snull);
+@@ -95,7 +95,7 @@
+ signal(SIGTERM, signalquit);
+ signal(SIGABRT, signalquit);
+ signal(SIGINT, signalquit);
+- signal(SIGCLD,signalchild);
++ signal(SIGCHLD,signalchild);
+ /* and for a rehash when we catch SIGHUP */
+ signal(SIGHUP,signalhup);
+
+@@ -142,16 +142,16 @@
+ /* Make sure we have a config file. */
+ filename.setName(parsefile);
+ if (!filename.exists()) {
+- msg("Creating a basic config file.");
++ lineak_core_functions::msg("Creating a basic config file.");
+ createBasic(parsefile);
+ }
+
+- msg("Parsing the config files.");
++ lineak_core_functions::msg("Parsing the config files.");
+ /** Parse the users ~/.lineak/lineakd.conf file */
+ if (!(got_conf = parseconf()))
+ quit();
+
+- msg("Setting commands!");
++ lineak_core_functions::msg("Setting commands!");
+ usleep(400000);
+ myKbd.setCommands(myConfig);
+
+@@ -165,10 +165,10 @@
+ connect(keyopts,SIGNAL(apply()),this,SLOT(slotRefreshKeylist(void)));
+
+ // Show the panel
+- msg("Showing the system tray.");
++ lineak_core_functions::msg("Showing the system tray.");
+ systemTrayApp->show();
+ // Show all the data in the gui widgets.
+- msg("Refreshing GUI data");
++ lineak_core_functions::msg("Refreshing GUI data");
+ refreshGUIdata();
+ // Test and see if there are any lineakd processes running. If there are kill them or exit.
+
+@@ -181,7 +181,7 @@
+ usleep(400000);
+ attempt++;
+ }
+- msg("Starting lineakd");
++ lineak_core_functions::msg("Starting lineakd");
+ startLineakd();
+
+ }
+@@ -235,7 +235,7 @@
+ until the new file has been reparsed.*/
+
+ changing_from_signal = true;
+- msg("reparsing");
++ lineak_core_functions::msg("reparsing");
+ bool res = false;
+
+ if (parsefile != QString::null)
+@@ -297,7 +297,7 @@
+ QMessageBox::critical(this, "KLineakConfig", "Failed to parse the configuration file.");
+ return false;
+ }
+- //msg("Do we have a def yet?");
++ //lineak_core_functions::msg("Do we have a def yet?");
+ /** If we parsed a definition's file */
+ if (got_def) {
+ string kbdtxt = myConfig[_CD_KEYBOARD_TYPE];
+@@ -306,7 +306,7 @@
+ error("myConfig is empty!");
+
+ if (myDef.hasKeyboard(kbdtxt)) {
+- msg("Returning the keyboard.");
++ lineak_core_functions::msg("Returning the keyboard.");
+ myKbd = myDef.getKeyboard(kbdtxt);
+ }
+ else {
+@@ -314,9 +314,9 @@
+ return false;
+ }
+
+- //msg("is myKbd empty?");
++ //lineak_core_functions::msg("is myKbd empty?");
+ if (myKbd.isEmpty()) {
+- msg("OH OH! it's an empty keyboard definition!");
++ lineak_core_functions::msg("OH OH! it's an empty keyboard definition!");
+ QString homedir = QDir::homeDirPath(); //getenv("HOME");
+ homedir+=LINEAKDIR;
+ homedir+=DEFFILE;
+@@ -329,13 +329,13 @@
+ "%2\n").arg(LINEAKKB_FILE).arg(homedir));
+ quit();
+ } else
+- msg("myKbd is not empty");
++ lineak_core_functions::msg("myKbd is not empty");
+ }
+ else {
+ error("Attepting to load the user .conf setting before we have keyboard data!");
+ return false;
+ }
+- msg("Returning from parseConf");
++ lineak_core_functions::msg("Returning from parseConf");
+ return true;
+ }
+
+@@ -422,7 +422,7 @@
+ Return true if we hupped the daemon.
+ Return false if the daemon was not hupped */
+ bool KlineakConfig::hupLineakd() {
+- msg("hupLineakd()");
++ lineak_core_functions::msg("hupLineakd()");
+ msgPasser message;
+ message.start();
+ message.sendMessage(msgPasser::HUP,"hup");
+@@ -468,7 +468,7 @@
+ /** Stop the lineakd daemon. If we killed it return true. Else if it could not be killed
+ return false */
+ bool KlineakConfig::stopLineakd() {
+- msg("Stopping Lineakd");
++ lineak_core_functions::msg("Stopping Lineakd");
+ msgPasser message;
+ message.start();
+ message.sendMessage(msgPasser::EXIT,"exit");
+@@ -640,7 +640,7 @@
+
+ //changing_text_from_signal = false;
+ selected_key = 0;
+- //msg("leaving setKeyboard");
++ //lineak_core_functions::msg("leaving setKeyboard");
+ }
+
+ /** select a new keyboard by model name. The brand name is obtained by
+@@ -655,9 +655,9 @@
+ // of the keys defined.
+ myKbd.setCommands(myConfig);
+ if (verbose) {
+- msg("SELECTED NEW KEYBOARD");
++ lineak_core_functions::msg("SELECTED NEW KEYBOARD");
+ cout << myKbd << endl;
+- msg("--END SELECTED NEW KEYBOARD--");
++ lineak_core_functions::msg("--END SELECTED NEW KEYBOARD--");
+ }
+
+ //changing_text_from_signal = true;
+@@ -693,7 +693,7 @@
+ KURL source, dest;
+ QString name;
+ QString returnMsg;
+- msg("Backup conffile");
++ lineak_core_functions::msg("Backup conffile");
+ name = (myConfig[_CD_USERCONFFILE]).c_str();
+ if (verbose) cout << name << " to " << name + ".backup" << endl;
+ source.setPath(name);
+@@ -722,14 +722,14 @@
+ // Now save the thing.
+ Saver tmp(myConfig.getFilename());
+ if (verbose) {
+- msg("Saving!");
++ lineak_core_functions::msg("Saving!");
+ cout << myConfig << endl;
+ }
+
+ bool r = tmp.saveFile(myConfig);
+
+ if (r)
+- msg("Saved!");
++ lineak_core_functions::msg("Saved!");
+ else
+ error("Could not save the config file.");
+
+@@ -737,16 +737,16 @@
+ }
+
+ void KlineakConfig::onAdvancedConfigOptionsButtonClicked(void) {
+- msg("Showing Advanced Configuration Options");
++ lineak_core_functions::msg("Showing Advanced Configuration Options");
+ advancedKbdConfig->setData(myConfig);
+ advancedKbdConfig->show();
+ advancedKbdConfig->raise();
+ }
+
+ void KlineakConfig::onAdvancedKeyOptionsButtonClicked(void) {
+- msg("onAdvancedKeyOptionsButtonClicked()");
++ lineak_core_functions::msg("onAdvancedKeyOptionsButtonClicked()");
+ if (lstAvailableKeys->currentItem() == 0)
+- msg("The current item is null.");
++ lineak_core_functions::msg("The current item is null.");
+ else {
+ string key = lstAvailableKeys->currentItem()->text(0).latin1();
+ //cout << "Outputting myKbd" << endl;
diff --git a/sysutils/klineakconfig/pkg-descr b/sysutils/klineakconfig/pkg-descr
new file mode 100644
index 000000000000..2fc920294e4c
--- /dev/null
+++ b/sysutils/klineakconfig/pkg-descr
@@ -0,0 +1,5 @@
+This is a KDE version of the gtk program lineakconfig by Mark Smulders. It is
+used for configuring a lineak config file for use with the lineakd daemon that
+sets up and handles the control of your easy access keys.
+
+WWW: http://lineak.sourceforge.net/
diff --git a/sysutils/klineakconfig/pkg-plist b/sysutils/klineakconfig/pkg-plist
new file mode 100644
index 000000000000..b0389cc25fff
--- /dev/null
+++ b/sysutils/klineakconfig/pkg-plist
@@ -0,0 +1,22 @@
+bin/klineakconfig
+share/doc/HTML/en/klineakconfig/index.docbook
+share/doc/HTML/en/klineakconfig/index.cache.bz2
+share/doc/HTML/en/klineakconfig/common
+share/locale/de/LC_MESSAGES/klineakconfig.mo
+share/locale/es/LC_MESSAGES/klineakconfig.mo
+share/applnk/Applications/klineakconfig.desktop
+share/icons/locolor/32x32/apps/klineakconfig.png
+share/icons/locolor/16x16/apps/klineakconfig.png
+share/icons/hicolor/16x16/apps/klineakconfig.png
+share/icons/hicolor/32x32/apps/klineakconfig.png
+share/apps/klineakconfig/pics/lineak_logo.xpm
+share/apps/klineakconfig/pics/noimage.xpm
+share/apps/klineakconfig/pics/warning.xpm
+share/apps/klineakconfig/pics/stop.gif
+@dirrm share/doc/HTML/en/klineakconfig
+@dirrmtry share/locale/de/LC_MESSAGES
+@dirrmtry share/locale/de
+@dirrmtry share/locale/es/LC_MESSAGES
+@dirrmtry share/locale/es
+@dirrm share/apps/klineakconfig/pics
+@dirrm share/apps/klineakconfig