aboutsummaryrefslogtreecommitdiff
path: root/sysutils/lcdproc
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-11-06 17:40:05 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-11-06 17:40:05 +0000
commit0e4aaea53687b782547527ccff1586b1ae9e6453 (patch)
tree8945597eca86f01d0021294c30c5adfb0c60300d /sysutils/lcdproc
parentee70c2658200945e86ce511500ca2b4c23001321 (diff)
downloadports-0e4aaea53687b782547527ccff1586b1ae9e6453.tar.gz
ports-0e4aaea53687b782547527ccff1586b1ae9e6453.zip
Notes
Diffstat (limited to 'sysutils/lcdproc')
-rw-r--r--sysutils/lcdproc/Makefile14
-rw-r--r--sysutils/lcdproc/distinfo6
-rw-r--r--sysutils/lcdproc/files/patch-Makefile.am11
-rw-r--r--sysutils/lcdproc/files/patch-clients__lcdexec__Makefile.am10
-rw-r--r--sysutils/lcdproc/files/patch-clients__lcdproc__Makefile.am10
-rw-r--r--sysutils/lcdproc/files/patch-clients__lcdvc__Makefile.am10
-rw-r--r--sysutils/lcdproc/files/patch-server__drivers__CFontz633io.c18
-rw-r--r--sysutils/lcdproc/files/patch-server__drivers__ms6931.c10
-rw-r--r--sysutils/lcdproc/pkg-plist8
9 files changed, 78 insertions, 19 deletions
diff --git a/sysutils/lcdproc/Makefile b/sysutils/lcdproc/Makefile
index 80f97962f476..6f6fa4872c53 100644
--- a/sysutils/lcdproc/Makefile
+++ b/sysutils/lcdproc/Makefile
@@ -6,16 +6,17 @@
#
PORTNAME= lcdproc
-PORTVERSION= 0.5.0
+PORTVERSION= 0.5.1
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= mmdolze@users.sourceforge.net
+MAINTAINER= bsdfan@nurfuerspam.de
COMMENT= A client/server suite for LCD devices
ONLY_FOR_ARCHS= i386
+USE_AUTOTOOLS= autoconf:259 automake:19 aclocal:19
USE_GCC= 3.2+
GNU_CONFIGURE= yes
USE_GETOPT_LONG=yes
@@ -23,10 +24,13 @@ USE_RC_SUBR= LCDd lcdproc
CONFIGURE_ARGS= --enable-drivers=all \
--disable-ldap \
- --disable-doxygen
+ --disable-doxygen \
+ --mandir=${PREFIX}/man \
+ --infodir=${PREFIX}/info
CONFIGURE_ENV= CFLAGS="${CFLAGS}"
MAN1= lcdexec.1 lcdproc.1
+MAN5= lcdproc-config.5
MAN8= LCDd.8
.if defined(WITH_USB)
@@ -43,6 +47,8 @@ post-patch:
post-install:
${INSTALL_DATA} ${WRKSRC}/LCDd.conf ${PREFIX}/etc/LCDd.conf.sample
- ${INSTALL_DATA} ${WRKSRC}/LCDclients.conf ${PREFIX}/etc/LCDclients.conf.sample
+ ${INSTALL_DATA} ${WRKSRC}/clients/lcdproc/lcdproc.conf ${PREFIX}/etc/lcdproc.conf.sample
+ ${INSTALL_DATA} ${WRKSRC}/clients/lcdexec/lcdexec.conf ${PREFIX}/etc/lcdexec.conf.sample
+ ${INSTALL_DATA} ${WRKSRC}/clients/lcdvc/lcdvc.conf ${PREFIX}/etc/lcdvc.conf.sample
.include <bsd.port.mk>
diff --git a/sysutils/lcdproc/distinfo b/sysutils/lcdproc/distinfo
index 4ced8483ffa4..e3692155bcd5 100644
--- a/sysutils/lcdproc/distinfo
+++ b/sysutils/lcdproc/distinfo
@@ -1,3 +1,3 @@
-MD5 (lcdproc-0.5.0.tar.gz) = 4b67e421c19063fa322611a849ab5b80
-SHA256 (lcdproc-0.5.0.tar.gz) = a7567f3f68517008e68d15b33630f36ba539540fbb361a2f9c440ce2ceb8393b
-SIZE (lcdproc-0.5.0.tar.gz) = 711118
+MD5 (lcdproc-0.5.1.tar.gz) = ad13d6cce7a7e068d85a66d30285af95
+SHA256 (lcdproc-0.5.1.tar.gz) = f459280eb4eeb70be584895364c97ffab22b888235b2351a31e1c87ca9710727
+SIZE (lcdproc-0.5.1.tar.gz) = 800205
diff --git a/sysutils/lcdproc/files/patch-Makefile.am b/sysutils/lcdproc/files/patch-Makefile.am
new file mode 100644
index 000000000000..38c8c747062f
--- /dev/null
+++ b/sysutils/lcdproc/files/patch-Makefile.am
@@ -0,0 +1,11 @@
+--- ./Makefile.am.orig Fri Oct 6 09:02:45 2006
++++ ./Makefile.am Mon Oct 16 22:26:06 2006
+@@ -5,7 +5,7 @@
+
+ SUBDIRS = shared clients server docs scripts
+
+-sysconf_DATA = LCDd.conf
++sysconf_DATA =
+
+ EXTRA_DIST = $(sysconf_DATA) CREDITS README.IRman contrib
+
diff --git a/sysutils/lcdproc/files/patch-clients__lcdexec__Makefile.am b/sysutils/lcdproc/files/patch-clients__lcdexec__Makefile.am
new file mode 100644
index 000000000000..b8e6be593469
--- /dev/null
+++ b/sysutils/lcdproc/files/patch-clients__lcdexec__Makefile.am
@@ -0,0 +1,10 @@
+--- ./clients/lcdexec/Makefile.am.orig Sun May 21 22:26:19 2006
++++ ./clients/lcdexec/Makefile.am Mon Oct 16 22:26:06 2006
+@@ -1,6 +1,6 @@
+ ## Process this file with automake to produce Makefile.in
+
+-sysconf_DATA = lcdexec.conf
++sysconf_DATA =
+
+ bin_PROGRAMS = lcdexec
+
diff --git a/sysutils/lcdproc/files/patch-clients__lcdproc__Makefile.am b/sysutils/lcdproc/files/patch-clients__lcdproc__Makefile.am
new file mode 100644
index 000000000000..ec3a92d614f0
--- /dev/null
+++ b/sysutils/lcdproc/files/patch-clients__lcdproc__Makefile.am
@@ -0,0 +1,10 @@
+--- ./clients/lcdproc/Makefile.am.orig Fri Oct 6 09:02:46 2006
++++ ./clients/lcdproc/Makefile.am Mon Oct 16 22:26:06 2006
+@@ -1,6 +1,6 @@
+ ## Process this file with automake to produce Makefile.in
+
+-sysconf_DATA = lcdproc.conf
++sysconf_DATA =
+
+ bin_PROGRAMS = lcdproc
+
diff --git a/sysutils/lcdproc/files/patch-clients__lcdvc__Makefile.am b/sysutils/lcdproc/files/patch-clients__lcdvc__Makefile.am
new file mode 100644
index 000000000000..bc9bb327fe9c
--- /dev/null
+++ b/sysutils/lcdproc/files/patch-clients__lcdvc__Makefile.am
@@ -0,0 +1,10 @@
+--- ./clients/lcdvc/Makefile.am.orig Sun May 21 22:26:19 2006
++++ ./clients/lcdvc/Makefile.am Mon Oct 16 22:26:06 2006
+@@ -1,6 +1,6 @@
+ ## Process this file with automake to produce Makefile.in
+
+-sysconf_DATA = lcdvc.conf
++sysconf_DATA =
+
+ bin_PROGRAMS = lcdvc
+
diff --git a/sysutils/lcdproc/files/patch-server__drivers__CFontz633io.c b/sysutils/lcdproc/files/patch-server__drivers__CFontz633io.c
new file mode 100644
index 000000000000..d31efee5c547
--- /dev/null
+++ b/sysutils/lcdproc/files/patch-server__drivers__CFontz633io.c
@@ -0,0 +1,18 @@
+--- ./server/drivers/CFontz633io.c.orig Mon Oct 16 22:26:21 2006
++++ ./server/drivers/CFontz633io.c Mon Oct 16 22:28:58 2006
+@@ -49,12 +49,9 @@
+
+ #include "config.h"
+
+-#if defined(HAVE_SYS_SELECT_H)
+-# include <sys/select.h>
+-#else
+-# include <sys/time.h>
+-# include <sys/types.h>
+-#endif /* defined(HAVE_SYS_SELECT_H) */
++#include <sys/select.h>
++#include <sys/time.h>
++#include <sys/types.h>
+
+ #include "CFontz633io.h"
+
diff --git a/sysutils/lcdproc/files/patch-server__drivers__ms6931.c b/sysutils/lcdproc/files/patch-server__drivers__ms6931.c
deleted file mode 100644
index 26f0b214d538..000000000000
--- a/sysutils/lcdproc/files/patch-server__drivers__ms6931.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./server/drivers/ms6931.c.orig Wed May 3 15:54:21 2006
-+++ ./server/drivers/ms6931.c Wed May 3 15:54:32 2006
-@@ -32,6 +32,7 @@
- #include <string.h>
- #include <errno.h>
- #include <syslog.h>
-+#include <sys/time.h>
-
- #ifdef HAVE_CONFIG_H
- # include "config.h"
diff --git a/sysutils/lcdproc/pkg-plist b/sysutils/lcdproc/pkg-plist
index 4b2ee825537d..aece5c30e7d9 100644
--- a/sysutils/lcdproc/pkg-plist
+++ b/sysutils/lcdproc/pkg-plist
@@ -1,18 +1,22 @@
bin/fortune.pl
bin/iosock.pl
bin/lcdexec
-bin/lcdheadlines
bin/lcdmetar.pl
bin/lcdproc
+bin/lcdvc
bin/tail.pl
bin/x11amp.pl
-etc/LCDclients.conf.sample
etc/LCDd.conf.sample
+etc/lcdexec.conf.sample
+etc/lcdproc.conf.sample
+etc/lcdvc.conf.sample
lib/lcdproc/CFontz.so
lib/lcdproc/CFontz633.so
lib/lcdproc/CFontzPacket.so
lib/lcdproc/CwLnx.so
+lib/lcdproc/EyeboxOne.so
%%USB%%lib/lcdproc/IOWarrior.so
+lib/lcdproc/MD8800.so
lib/lcdproc/MtxOrb.so
lib/lcdproc/NoritakeVFD.so
lib/lcdproc/bayrad.so