aboutsummaryrefslogtreecommitdiff
path: root/sysutils/libfvde
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2012-08-09 00:46:10 +0000
committerJason Helfman <jgh@FreeBSD.org>2012-08-09 00:46:10 +0000
commit9eff808d5524a9201119c1d0e7e400f034c59571 (patch)
treea831bcd9090f39c2177dbf79591bda651b1590b3 /sysutils/libfvde
parent087da9474661099d7c318d92a8897fcc76e4e63d (diff)
downloadports-9eff808d5524a9201119c1d0e7e400f034c59571.tar.gz
ports-9eff808d5524a9201119c1d0e7e400f034c59571.zip
Notes
Diffstat (limited to 'sysutils/libfvde')
-rw-r--r--sysutils/libfvde/Makefile26
-rw-r--r--sysutils/libfvde/distinfo2
-rw-r--r--sysutils/libfvde/pkg-descr14
-rw-r--r--sysutils/libfvde/pkg-plist17
4 files changed, 59 insertions, 0 deletions
diff --git a/sysutils/libfvde/Makefile b/sysutils/libfvde/Makefile
new file mode 100644
index 000000000000..75336ef73ab2
--- /dev/null
+++ b/sysutils/libfvde/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: libfvde
+# Date created: 07 August 2012
+# Whom: Kubilay Kocak <koobs.freebsd@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libfvde
+PORTVERSION= 20120519
+CATEGORIES= sysutils
+MASTER_SITES= GOOGLE_CODE
+DISTFILES= ${PORTNAME}-experimental-${PORTVERSION}${EXTRACT_SUFX}
+
+MAINTAINER= koobs.freebsd@gmail.com
+COMMENT= Library and tools for reading FileVault (FVDE) encrypted volumes
+
+LICENSE= LGPL3
+
+GNU_CONFIGURE= yes
+USE_GNOME= libxml2 gnomehack
+USE_LDCONFIG= yes
+
+MAN1= bdeinfo.1 bdemount.1
+MAN3= libbde.3
+
+.include <bsd.port.mk>
diff --git a/sysutils/libfvde/distinfo b/sysutils/libfvde/distinfo
new file mode 100644
index 000000000000..de4fbc136bb5
--- /dev/null
+++ b/sysutils/libfvde/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libfvde-experimental-20120519.tar.gz) = fb819f6d5f6bb1010561e0fd2e4c379560132e0049fc4e7ffb4dcedf3f5198ea
+SIZE (libfvde-experimental-20120519.tar.gz) = 993132
diff --git a/sysutils/libfvde/pkg-descr b/sysutils/libfvde/pkg-descr
new file mode 100644
index 000000000000..460a5daf2c96
--- /dev/null
+++ b/sysutils/libfvde/pkg-descr
@@ -0,0 +1,14 @@
+Library and tools for reading FileVault2 Drive Encryption (FVDE) encrypted
+volumes. The FVDE format is used by MacOS-X, as of Lion, to encrypt data
+on a storage media volume.
+
+Supported FVDE formats:
+
+ FileVault2 Lion
+
+Supported protection methods:
+
+ password
+ recovery password
+
+WWW: https://code.google.com/p/libfvde/
diff --git a/sysutils/libfvde/pkg-plist b/sysutils/libfvde/pkg-plist
new file mode 100644
index 000000000000..0e20f2e882e7
--- /dev/null
+++ b/sysutils/libfvde/pkg-plist
@@ -0,0 +1,17 @@
+@comment $FreeBSD$
+bin/fvdeinfo
+bin/fvdemount
+include/libfvde.h
+include/libfvde/codepage.h
+include/libfvde/definitions.h
+include/libfvde/error.h
+include/libfvde/extern.h
+include/libfvde/features.h
+include/libfvde/types.h
+lib/libfvde.so.1
+lib/libfvde.so
+lib/libfvde.la
+lib/libfvde.a
+libdata/pkgconfig/libfvde.pc
+@dirrmtry lib/pkgconfig
+@dirrm include/libfvde