aboutsummaryrefslogtreecommitdiff
path: root/sysutils/lineak-defaultplugin/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-01-15 23:33:19 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-01-15 23:33:19 +0000
commita77d9933867100b0e7991676a55111583508da81 (patch)
tree1671f45a511afa8a6a315497924f2c1af5b0202e /sysutils/lineak-defaultplugin/Makefile
parent3d13efd3564594c752e7631cc6aed802e4270414 (diff)
downloadports-a77d9933867100b0e7991676a55111583508da81.tar.gz
ports-a77d9933867100b0e7991676a55111583508da81.zip
Notes
Diffstat (limited to 'sysutils/lineak-defaultplugin/Makefile')
-rw-r--r--sysutils/lineak-defaultplugin/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/sysutils/lineak-defaultplugin/Makefile b/sysutils/lineak-defaultplugin/Makefile
new file mode 100644
index 000000000000..91229c7fcfc4
--- /dev/null
+++ b/sysutils/lineak-defaultplugin/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: lineak_defaultplugin
+# Date created: 2004-12-29
+# Whom: Kay Lehmann <kay_lehmann@web.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lineak_defaultplugin
+PORTVERSION= 0.8.2
+CATEGORIES= sysutils deskutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= lineak
+DIST_SUBDIR= lineak
+
+MAINTAINER= kay_lehmann@web.de
+COMMENT= Default plugins for lineakd
+
+LIB_DEPENDS= lineak.8:${PORTSDIR}/sysutils/lineakd
+
+USE_GMAKE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CONFIGURE_ARGS+= --program-prefix=''
+USE_REINPLACE= yes
+
+MAN1= lineak_defaultplugin.1
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+# lineakd is compiled with 3.4 on FreeBSD 4.x, so plugins must be too
+USE_GCC= 3.4
+GNU_CONFIGURE= yes
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-ltmain.sh
+.else
+USE_LIBTOOL_VER=15
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-ldl||' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-O2||' ${WRKSRC}/configure
+
+.include <bsd.port.post.mk>