aboutsummaryrefslogtreecommitdiff
path: root/sysutils/lineak-xosdplugin/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-04-10 12:38:39 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-04-10 12:38:39 +0000
commit7dc7cee62b5f2ea79276399e3375aa925e953d07 (patch)
tree06998a400d0a6328fadece0d35581c5b5e57d0db /sysutils/lineak-xosdplugin/Makefile
parentffea341df08b2970b798e0158513ffb53bc7a0b0 (diff)
downloadports-7dc7cee62b5f2ea79276399e3375aa925e953d07.tar.gz
ports-7dc7cee62b5f2ea79276399e3375aa925e953d07.zip
Notes
Diffstat (limited to 'sysutils/lineak-xosdplugin/Makefile')
-rw-r--r--sysutils/lineak-xosdplugin/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/sysutils/lineak-xosdplugin/Makefile b/sysutils/lineak-xosdplugin/Makefile
new file mode 100644
index 000000000000..e7ce61250b31
--- /dev/null
+++ b/sysutils/lineak-xosdplugin/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: lineak_xosdplugin
+# Date created: 2004-12-29
+# Whom: Kay Lehmann <kay_lehmann@web.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lineak_xosdplugin
+PORTVERSION= 0.8.3
+CATEGORIES= sysutils deskutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR=lineak
+DIST_SUBDIR= lineak
+
+MAINTAINER= kay_lehmann@web.de
+COMMENT= Xosd-plugin for lineakd
+
+LIB_DEPENDS= lineak.8:${PORTSDIR}/sysutils/lineakd \
+ xosd.4:${PORTSDIR}/misc/xosd
+
+USE_GMAKE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CONFIGURE_ARGS= --program-prefix=''
+USE_REINPLACE= yes
+USE_LIBTOOL_VER=15
+INSTALLS_SHLIB= yes
+
+MAN1= lineak_xosdplugin.1
+PLIST_FILES= lib/lineakd/plugins/xosdplugin.so
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+USE_GCC= 3.4
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-ldl||' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-O2||' ${WRKSRC}/configure
+
+.include <bsd.port.post.mk>