aboutsummaryrefslogtreecommitdiff
path: root/sysutils/lineak-xosdplugin
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-04-10 12:38:39 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-04-10 12:38:39 +0000
commit7dc7cee62b5f2ea79276399e3375aa925e953d07 (patch)
tree06998a400d0a6328fadece0d35581c5b5e57d0db /sysutils/lineak-xosdplugin
parentffea341df08b2970b798e0158513ffb53bc7a0b0 (diff)
downloadports-7dc7cee62b5f2ea79276399e3375aa925e953d07.tar.gz
ports-7dc7cee62b5f2ea79276399e3375aa925e953d07.zip
Notes
Diffstat (limited to 'sysutils/lineak-xosdplugin')
-rw-r--r--sysutils/lineak-xosdplugin/Makefile42
-rw-r--r--sysutils/lineak-xosdplugin/distinfo2
-rw-r--r--sysutils/lineak-xosdplugin/files/patch-configure11
-rw-r--r--sysutils/lineak-xosdplugin/pkg-descr4
4 files changed, 59 insertions, 0 deletions
diff --git a/sysutils/lineak-xosdplugin/Makefile b/sysutils/lineak-xosdplugin/Makefile
new file mode 100644
index 000000000000..e7ce61250b31
--- /dev/null
+++ b/sysutils/lineak-xosdplugin/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: lineak_xosdplugin
+# Date created: 2004-12-29
+# Whom: Kay Lehmann <kay_lehmann@web.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lineak_xosdplugin
+PORTVERSION= 0.8.3
+CATEGORIES= sysutils deskutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR=lineak
+DIST_SUBDIR= lineak
+
+MAINTAINER= kay_lehmann@web.de
+COMMENT= Xosd-plugin for lineakd
+
+LIB_DEPENDS= lineak.8:${PORTSDIR}/sysutils/lineakd \
+ xosd.4:${PORTSDIR}/misc/xosd
+
+USE_GMAKE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CONFIGURE_ARGS= --program-prefix=''
+USE_REINPLACE= yes
+USE_LIBTOOL_VER=15
+INSTALLS_SHLIB= yes
+
+MAN1= lineak_xosdplugin.1
+PLIST_FILES= lib/lineakd/plugins/xosdplugin.so
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+USE_GCC= 3.4
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-ldl||' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-O2||' ${WRKSRC}/configure
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/lineak-xosdplugin/distinfo b/sysutils/lineak-xosdplugin/distinfo
new file mode 100644
index 000000000000..e2671a976b81
--- /dev/null
+++ b/sysutils/lineak-xosdplugin/distinfo
@@ -0,0 +1,2 @@
+MD5 (lineak/lineak_xosdplugin-0.8.3.tar.gz) = 837e417b80632c994294d13d0879fed6
+SIZE (lineak/lineak_xosdplugin-0.8.3.tar.gz) = 722345
diff --git a/sysutils/lineak-xosdplugin/files/patch-configure b/sysutils/lineak-xosdplugin/files/patch-configure
new file mode 100644
index 000000000000..e1075fe2aac4
--- /dev/null
+++ b/sysutils/lineak-xosdplugin/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Fri Mar 4 18:18:18 2005
++++ configure Sun Apr 3 12:19:59 2005
+@@ -21299,7 +21299,7 @@
+ echo "${ECHO_T}libraries $x_libraries, headers $x_includes" >&6
+ fi
+
+- LDFLAGS="$all_libraries -L${x_libraries} $X_LDFLAGS -lX11 -lXext -ldl"
++ LDFLAGS="$all_libraries -L${x_libraries} $LDFLAGS $X_LDFLAGS -lX11 -lXext -ldl"
+ CPPFLAGS="$all_includes -I${x_includes} ${CPPFLAGS} "
+ echo "$as_me:$LINENO: checking for ac_check_lineak in -llineak" >&5
+ echo $ECHO_N "checking for ac_check_lineak in -llineak... $ECHO_C" >&6
diff --git a/sysutils/lineak-xosdplugin/pkg-descr b/sysutils/lineak-xosdplugin/pkg-descr
new file mode 100644
index 000000000000..45721dd2d159
--- /dev/null
+++ b/sysutils/lineak-xosdplugin/pkg-descr
@@ -0,0 +1,4 @@
+Xosd-plugin for lineak to display some nice information about the commands
+being executed by lineakd.
+
+WWW: http://lineak.sf.net/