aboutsummaryrefslogtreecommitdiff
path: root/sysutils/linux-megamgr/Makefile
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2006-09-07 06:14:52 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2006-09-07 06:14:52 +0000
commit0c3c828c94112f534a7ef7a9f6fb2639b4e2eca0 (patch)
tree586194c9837c3686d651986ffe0763aa9e2b9375 /sysutils/linux-megamgr/Makefile
parentaca9126d60fca64613800cebdc8c496a3903b0b9 (diff)
Notes
Diffstat (limited to 'sysutils/linux-megamgr/Makefile')
-rw-r--r--sysutils/linux-megamgr/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/sysutils/linux-megamgr/Makefile b/sysutils/linux-megamgr/Makefile
new file mode 100644
index 000000000000..a02439582324
--- /dev/null
+++ b/sysutils/linux-megamgr/Makefile
@@ -0,0 +1,44 @@
+# Ports collection makefile for: linux-megamgr
+# Date created: Tue, Sep 5th, 2006
+# Whom: Patrick M. Hausen (pmh@hausen.com)
+#
+# $FreeBSD$
+#
+
+PORTNAME= linux-megamgr
+PORTVERSION= 5.20
+CATEGORIES= sysutils linux
+MASTER_SITES= http://www.lsi.com/files/support/rsa/utilities/megamgr/
+DISTNAME= ut_linux_mgr_5.20
+
+MAINTAINER= pmh@hausen.com
+COMMENT= LSI MegaRAID controller management utility
+
+NO_WRKSUBDIR= yes
+USE_ZIP= yes
+RESTRICTED= Redistribution prohibited, see: http://www.lsi.com/cm/License.do
+ONLY_FOR_ARCHS= i386
+USE_LINUX= yes
+SUB_FILES= megamgr.sh
+
+do-build:
+ @${BRANDELF} -t Linux ${WRKSRC}/megamgr.bin
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/megamgr.sh ${PREFIX}/sbin/megamgr
+ ${INSTALL_PROGRAM} ${WRKSRC}/megamgr.bin ${PREFIX}/libexec
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/${DISTNAME}.txt ${DOCSDIR}/readme.txt
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 601000
+IGNORE= needs at least FreeBSD 6.1 and amd_linux.ko
+.endif
+
+.include <bsd.port.post.mk>