aboutsummaryrefslogtreecommitdiff
path: root/sysutils/linux-megamgr
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2006-09-07 06:14:52 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2006-09-07 06:14:52 +0000
commit0c3c828c94112f534a7ef7a9f6fb2639b4e2eca0 (patch)
tree586194c9837c3686d651986ffe0763aa9e2b9375 /sysutils/linux-megamgr
parentaca9126d60fca64613800cebdc8c496a3903b0b9 (diff)
downloadports-0c3c828c94112f534a7ef7a9f6fb2639b4e2eca0.tar.gz
ports-0c3c828c94112f534a7ef7a9f6fb2639b4e2eca0.zip
Notes
Diffstat (limited to 'sysutils/linux-megamgr')
-rw-r--r--sysutils/linux-megamgr/Makefile44
-rw-r--r--sysutils/linux-megamgr/distinfo3
-rw-r--r--sysutils/linux-megamgr/files/megamgr.sh.in24
-rw-r--r--sysutils/linux-megamgr/pkg-descr10
-rw-r--r--sysutils/linux-megamgr/pkg-message8
-rw-r--r--sysutils/linux-megamgr/pkg-plist4
6 files changed, 93 insertions, 0 deletions
diff --git a/sysutils/linux-megamgr/Makefile b/sysutils/linux-megamgr/Makefile
new file mode 100644
index 000000000000..a02439582324
--- /dev/null
+++ b/sysutils/linux-megamgr/Makefile
@@ -0,0 +1,44 @@
+# Ports collection makefile for: linux-megamgr
+# Date created: Tue, Sep 5th, 2006
+# Whom: Patrick M. Hausen (pmh@hausen.com)
+#
+# $FreeBSD$
+#
+
+PORTNAME= linux-megamgr
+PORTVERSION= 5.20
+CATEGORIES= sysutils linux
+MASTER_SITES= http://www.lsi.com/files/support/rsa/utilities/megamgr/
+DISTNAME= ut_linux_mgr_5.20
+
+MAINTAINER= pmh@hausen.com
+COMMENT= LSI MegaRAID controller management utility
+
+NO_WRKSUBDIR= yes
+USE_ZIP= yes
+RESTRICTED= Redistribution prohibited, see: http://www.lsi.com/cm/License.do
+ONLY_FOR_ARCHS= i386
+USE_LINUX= yes
+SUB_FILES= megamgr.sh
+
+do-build:
+ @${BRANDELF} -t Linux ${WRKSRC}/megamgr.bin
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/megamgr.sh ${PREFIX}/sbin/megamgr
+ ${INSTALL_PROGRAM} ${WRKSRC}/megamgr.bin ${PREFIX}/libexec
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/${DISTNAME}.txt ${DOCSDIR}/readme.txt
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 601000
+IGNORE= needs at least FreeBSD 6.1 and amd_linux.ko
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/linux-megamgr/distinfo b/sysutils/linux-megamgr/distinfo
new file mode 100644
index 000000000000..bbb2d1183273
--- /dev/null
+++ b/sysutils/linux-megamgr/distinfo
@@ -0,0 +1,3 @@
+MD5 (ut_linux_mgr_5.20.zip) = 0417bd48936518322c3634a414b3c8d1
+SHA256 (ut_linux_mgr_5.20.zip) = e7313ed8f59897f132ffed55ed606f19dc72a5d529e6b647cb157a39f0d79123
+SIZE (ut_linux_mgr_5.20.zip) = 253549
diff --git a/sysutils/linux-megamgr/files/megamgr.sh.in b/sysutils/linux-megamgr/files/megamgr.sh.in
new file mode 100644
index 000000000000..a4523a8ad810
--- /dev/null
+++ b/sysutils/linux-megamgr/files/megamgr.sh.in
@@ -0,0 +1,24 @@
+#!/bin/sh
+
+# check for root user
+#
+if [ `id -u` -ne 0 ]
+then
+ echo You must be root to run `basename $0`.
+ exit 1
+fi
+
+# check for active amr_linux.ko
+#
+if ! kldstat -q -m amr_linux
+then
+ if kldload amr_linux
+ then
+ echo 'amr_linux module loaded.'
+ else
+ echo 'amr_linux module failed to load.'
+ exit 1
+ fi
+fi
+
+exec %%PREFIX%%/libexec/megamgr.bin
diff --git a/sysutils/linux-megamgr/pkg-descr b/sysutils/linux-megamgr/pkg-descr
new file mode 100644
index 000000000000..65caca7be2e7
--- /dev/null
+++ b/sysutils/linux-megamgr/pkg-descr
@@ -0,0 +1,10 @@
+LSI Logic MegaRAID Megamgr Release
+
+This is the Linux console based management utility for the LSI
+MegaRAID family of controllers.
+
+FreeBSD >= 6.1 supports running this tool by the means of the
+amr_linux.ko kernel module and the /dev/megadev0 device.
+
+Author: LSI Logic Corporation
+WWW: http://www.lsi.com/
diff --git a/sysutils/linux-megamgr/pkg-message b/sysutils/linux-megamgr/pkg-message
new file mode 100644
index 000000000000..67c8180025ed
--- /dev/null
+++ b/sysutils/linux-megamgr/pkg-message
@@ -0,0 +1,8 @@
+
+===================================================================
+This port installed a commercial software product with a restricted
+license. Please review the license terms at this URL:
+
+ http://www.lsi.com/cm/License.do
+
+===================================================================
diff --git a/sysutils/linux-megamgr/pkg-plist b/sysutils/linux-megamgr/pkg-plist
new file mode 100644
index 000000000000..c06d02292002
--- /dev/null
+++ b/sysutils/linux-megamgr/pkg-plist
@@ -0,0 +1,4 @@
+sbin/megamgr
+libexec/megamgr.bin
+%%PORTDOCS%%%%DOCSDIR%%/readme.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%