aboutsummaryrefslogtreecommitdiff
path: root/sysutils/linux-procfs/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2007-09-07 06:43:30 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2007-09-07 06:43:30 +0000
commit3895150628f16d8839acf97668c96222d98c68de (patch)
tree2709a2a5baf3c779aafda70be6bd5cc535a9d601 /sysutils/linux-procfs/Makefile
parente536dbe49699cbb42469c29eae88d27fb9f4c7a1 (diff)
downloadports-3895150628f16d8839acf97668c96222d98c68de.tar.gz
ports-3895150628f16d8839acf97668c96222d98c68de.zip
Notes
Diffstat (limited to 'sysutils/linux-procfs/Makefile')
-rw-r--r--sysutils/linux-procfs/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/sysutils/linux-procfs/Makefile b/sysutils/linux-procfs/Makefile
new file mode 100644
index 000000000000..3fd2c6451d9e
--- /dev/null
+++ b/sysutils/linux-procfs/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: linux-procps
+# Date created: 2007-04-04
+# Whom: leres
+#
+# $FreeBSD$
+#
+
+PORTNAME= procps
+PORTVERSION= 3.2.5
+CATEGORIES= sysutils linux
+DISTNAME= ${PORTNAME}-${PORTVERSION}-6.4
+
+MAINTAINER= freebsd-emulation@FreeBSD.org
+COMMENT= Linux psproc binaries
+
+USE_LINUX_RPM= yes
+ONLY_FOR_ARCHS= i386
+LINUX_DIST_VER= 4
+USE_LDCONFIG= yes
+BRANDELF_DIRS= bin sbin usr/bin
+PLIST_SUB+= PORTVERSION="${PORTVERSION}"
+
+PROCFS= /compat/linux/proc
+
+post-install:
+ @df ${PROCFS} 2>&1 | ${EGREP} '^linprocfs ' > /dev/null 2>&1 || (echo ">>>" ; echo ">>> You still need to mount ${PROCFS}; see linprocfs(5)" ; echo ">>> for more information" ; echo ">>>")
+
+.include <bsd.port.mk>