aboutsummaryrefslogtreecommitdiff
path: root/sysutils/logtool/Makefile
diff options
context:
space:
mode:
authorJing-Tang Keith Jang <keith@FreeBSD.org>2001-01-12 18:47:04 +0000
committerJing-Tang Keith Jang <keith@FreeBSD.org>2001-01-12 18:47:04 +0000
commit8eab677955e80c4559cf3e5a5eb89ed3c72574e6 (patch)
tree0e0e93ac566caf6f437100b6627d65e174dec3f6 /sysutils/logtool/Makefile
parent5726ba99ab42348bdfeb1906a26a3479bfe80c70 (diff)
downloadports-8eab677955e80c4559cf3e5a5eb89ed3c72574e6.tar.gz
ports-8eab677955e80c4559cf3e5a5eb89ed3c72574e6.zip
Notes
Diffstat (limited to 'sysutils/logtool/Makefile')
-rw-r--r--sysutils/logtool/Makefile15
1 files changed, 14 insertions, 1 deletions
diff --git a/sysutils/logtool/Makefile b/sysutils/logtool/Makefile
index fa42950c7861..f5eda995ac39 100644
--- a/sysutils/logtool/Makefile
+++ b/sysutils/logtool/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= logtool
-PORTVERSION= 1.0.1
+PORTVERSION= 1.0.2
CATEGORIES= sysutils
MASTER_SITES= http://users.digitex.net/~max/
@@ -17,6 +17,12 @@ LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
USE_GMAKE= yes
ALL_TARGET= build
+.if defined(NOPORTDOCS)
+NODOCS= "@comment "
+.endif
+
+PLIST_SUB= NOPORTDOCS=${NODOCS}
+
post-patch:
@${PERL} -pi -e "s|make|${GMAKE}|g" ${WRKSRC}/Makefile
.for file in logtool/Makefile logtail/Makefile
@@ -24,4 +30,11 @@ post-patch:
.endfor
@${PERL} -pi -e "s|/etc|${PREFIX}/etc|g" ${WRKSRC}/logtool/config.h
+post-install:
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} "===> Installing logtool docs in ${PREFIX}/share/doc/logtool"
+ @${MKDIR} ${PREFIX}/share/doc/logtool && ${CHMOD} a+rx ${PREFIX}/share/doc/logtool
+ @${CP} -r ${WRKSRC}/doc/* ${PREFIX}/share/doc/logtool
+.endif
+
.include <bsd.port.mk>