aboutsummaryrefslogtreecommitdiff
path: root/sysutils/lscpu
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2017-09-29 11:52:28 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2017-09-29 11:52:28 +0000
commit53cedd5675c4907f87eb768428fb2c7741994ae8 (patch)
tree8089ebcdb23bb91ff32972785e02a85954ccce5b /sysutils/lscpu
parent862fdc12d441149ccd26bd323d9a79d0f8b48f0b (diff)
Notes
Diffstat (limited to 'sysutils/lscpu')
-rw-r--r--sysutils/lscpu/Makefile22
-rw-r--r--sysutils/lscpu/distinfo3
-rw-r--r--sysutils/lscpu/pkg-descr9
3 files changed, 34 insertions, 0 deletions
diff --git a/sysutils/lscpu/Makefile b/sysutils/lscpu/Makefile
new file mode 100644
index 000000000000..4afa5b2a81bd
--- /dev/null
+++ b/sysutils/lscpu/Makefile
@@ -0,0 +1,22 @@
+# Created by: Ryan Steinmetz <zi@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= lscpu
+PORTVERSION= 1.0.0
+CATEGORIES= sysutils
+
+MAINTAINER= zi@FreeBSD.org
+COMMENT= Display information about the CPU architecture
+
+LICENSE= BSD3CLAUSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= NanXiao
+
+PLIST_FILES= bin/${PORTNAME} man/man1/${PORTNAME}.1.gz
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1/${PORTNAME}.1
+
+.include <bsd.port.mk>
diff --git a/sysutils/lscpu/distinfo b/sysutils/lscpu/distinfo
new file mode 100644
index 000000000000..9df08540351b
--- /dev/null
+++ b/sysutils/lscpu/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1506685333
+SHA256 (NanXiao-lscpu-1.0.0_GH0.tar.gz) = 04f3c44090a5afbd510065b8d9c16a67936c9b652a0b055bec6bd74c3739c4c4
+SIZE (NanXiao-lscpu-1.0.0_GH0.tar.gz) = 7055
diff --git a/sysutils/lscpu/pkg-descr b/sysutils/lscpu/pkg-descr
new file mode 100644
index 000000000000..4ffbbc3cf009
--- /dev/null
+++ b/sysutils/lscpu/pkg-descr
@@ -0,0 +1,9 @@
+lscpu gathers CPU architecture information about the current CPU. The
+command output is optimized for parsing or for easy readability by
+humans. The information includes, for example, the number of CPUs,
+threads, cores, and sockets.
+
+There is also information about the CPU caches, family, model,
+byte order, and stepping.
+
+WWW: https://github.com/NanXiao/lscpu