aboutsummaryrefslogtreecommitdiff
path: root/sysutils/luma/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-06-02 21:33:42 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-06-02 21:33:42 +0000
commitcc6f74d29c54e5e3fad86acda38be28400463bc6 (patch)
treed659b9569cb2347db622402464254dbc2cc64d9d /sysutils/luma/Makefile
parent30cf3b6f06ce264d1ee3819735b242749e94ec08 (diff)
downloadports-cc6f74d29c54e5e3fad86acda38be28400463bc6.tar.gz
ports-cc6f74d29c54e5e3fad86acda38be28400463bc6.zip
Notes
Diffstat (limited to 'sysutils/luma/Makefile')
-rw-r--r--sysutils/luma/Makefile18
1 files changed, 6 insertions, 12 deletions
diff --git a/sysutils/luma/Makefile b/sysutils/luma/Makefile
index e9d745e57851..15e473624a32 100644
--- a/sysutils/luma/Makefile
+++ b/sysutils/luma/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= luma
-PORTVERSION= 1.2
+PORTVERSION= 1.3
CATEGORIES= sysutils net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,21 +15,15 @@ MAINTAINER= alecn2002@yandex.ru
COMMENT= A graphical tool for accessing and managing LDAP servers
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_ldap.so:${PORTSDIR}/net/py-ldap2 \
+ ${PYTHON_SITELIBDIR}/smbpasswd.so:${PORTSDIR}/net/py-smbpasswd \
pyuic:${PORTSDIR}/x11-toolkits/py-qt
USE_BZIP2= yes
USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+PYSETUP= install.py
+PYDISTUTILS_BUILDARGS= --compile-only
+PYDISTUTILS_INSTALLARGS= --prefix=${PREFIX}
USE_OPENLDAP= yes
-WANTS_OPENLDAP_VER= 2.1
-NO_BUILD= yes
-
-INSTALLCMD= install.py
-INSTALLARGS= --prefix=${PREFIX}
-
-post-extract:
- ${FIND} ${WRKSRC} \( -name '.#*' -o -name '*~*' \) -delete
-
-do-install:
- @(cd ${INSTALL_WRKSRC}; ${PYTHON_CMD} ${INSTALLCMD} ${INSTALLARGS})
.include <bsd.port.mk>