aboutsummaryrefslogtreecommitdiff
path: root/sysutils/lxterminal
diff options
context:
space:
mode:
authorKris Moore <kmoore@FreeBSD.org>2010-09-30 14:39:33 +0000
committerKris Moore <kmoore@FreeBSD.org>2010-09-30 14:39:33 +0000
commite0af562ef037e726ac064e3f050c1edb3de023fd (patch)
tree862512ba182666a76936dd68a538caf2b7c9d6cf /sysutils/lxterminal
parentf49a55d2d2f3c2b34a9c5217ee61ece15387bf5d (diff)
downloadports-e0af562ef037e726ac064e3f050c1edb3de023fd.tar.gz
ports-e0af562ef037e726ac064e3f050c1edb3de023fd.zip
Notes
Diffstat (limited to 'sysutils/lxterminal')
-rw-r--r--sysutils/lxterminal/Makefile37
-rw-r--r--sysutils/lxterminal/distinfo3
-rw-r--r--sysutils/lxterminal/pkg-descr6
-rw-r--r--sysutils/lxterminal/pkg-plist62
4 files changed, 108 insertions, 0 deletions
diff --git a/sysutils/lxterminal/Makefile b/sysutils/lxterminal/Makefile
new file mode 100644
index 000000000000..8a865d9da307
--- /dev/null
+++ b/sysutils/lxterminal/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: lxterminal
+# Date created: 2010/09/24
+# Whom: Kris Moore <kmoore@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lxterminal
+PORTVERSION= 0.1.9
+CATEGORIES= sysutils
+MASTER_SITES= SF/lxde/LXTerminal%20%28terminal%20emulator%29/LXTerminal%20${PORTVERSION}
+
+MAINTAINER= kmoore@FreeBSD.org
+COMMENT= A lightweight terminal emulator from the LXDE project
+
+LIB_DEPENDS= vte.9:${PORTSDIR}/x11-toolkits/vte
+
+USE_GNOME= gtk20 intlhack
+USE_GMAKE= yes
+USE_ICONV= yes
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+CONFIGURE_ARGS= --prefix=${PREFIX}
+MAN1= lxterminal.1
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/lxterminal/distinfo b/sysutils/lxterminal/distinfo
new file mode 100644
index 000000000000..16f28f309ed6
--- /dev/null
+++ b/sysutils/lxterminal/distinfo
@@ -0,0 +1,3 @@
+MD5 (lxterminal-0.1.9.tar.gz) = cb10cc667611dce3c141294712049c43
+SHA256 (lxterminal-0.1.9.tar.gz) = 847676534977c30b671e7d3225e2274a9272aa967ef4a56b75594b1df9be5c68
+SIZE (lxterminal-0.1.9.tar.gz) = 280846
diff --git a/sysutils/lxterminal/pkg-descr b/sysutils/lxterminal/pkg-descr
new file mode 100644
index 000000000000..47e8fa7d498f
--- /dev/null
+++ b/sysutils/lxterminal/pkg-descr
@@ -0,0 +1,6 @@
+LXterminal is a VTE-based terminal emulator with support for multiple tabs.
+It is completely desktop-independent and does not have any unnecessary
+dependencies. In order to reduce memory usage and increase the performance
+all instances of the terminal are sharing a single process.
+
+WWW: http://lxde.sourceforge.net/
diff --git a/sysutils/lxterminal/pkg-plist b/sysutils/lxterminal/pkg-plist
new file mode 100644
index 000000000000..474f1b295678
--- /dev/null
+++ b/sysutils/lxterminal/pkg-plist
@@ -0,0 +1,62 @@
+bin/lxterminal
+%%NLS%%share/locale/af/LC_MESSAGES/lxterminal.mo
+%%NLS%%share/locale/ar/LC_MESSAGES/lxterminal.mo
+%%NLS%%share/locale/bg/LC_MESSAGES/lxterminal.mo
+%%NLS%%share/locale/bn_IN/LC_MESSAGES/lxterminal.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/lxterminal.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/lxterminal.mo
+%%NLS%%share/locale/da/LC_MESSAGES/lxterminal.mo
+%%NLS%%share/locale/de/LC_MESSAGES/lxterminal.mo
+%%NLS%%share/locale/el/LC_MESSAGES/lxterminal.mo
+%%NLS%%share/locale/es/LC_MESSAGES/lxterminal.mo
+%%NLS%%share/locale/es_VE/LC_MESSAGES/lxterminal.mo
+%%NLS%%share/locale/et/LC_MESSAGES/lxterminal.mo
+%%NLS%%share/locale/eu/LC_MESSAGES/lxterminal.mo
+%%NLS%%share/locale/fa/LC_MESSAGES/lxterminal.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/lxterminal.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/lxterminal.mo
+%%NLS%%share/locale/frp/LC_MESSAGES/lxterminal.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/lxterminal.mo
+%%NLS%%share/locale/he/LC_MESSAGES/lxterminal.mo
+%%NLS%%share/locale/hr/LC_MESSAGES/lxterminal.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/lxterminal.mo
+%%NLS%%share/locale/id/LC_MESSAGES/lxterminal.mo
+%%NLS%%share/locale/it/LC_MESSAGES/lxterminal.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/lxterminal.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/lxterminal.mo
+%%NLS%%share/locale/lt/LC_MESSAGES/lxterminal.mo
+%%NLS%%share/locale/ml/LC_MESSAGES/lxterminal.mo
+%%NLS%%share/locale/ms/LC_MESSAGES/lxterminal.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/lxterminal.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/lxterminal.mo
+%%NLS%%share/locale/nn/LC_MESSAGES/lxterminal.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/lxterminal.mo
+%%NLS%%share/locale/ps/LC_MESSAGES/lxterminal.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/lxterminal.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/lxterminal.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/lxterminal.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/lxterminal.mo
+%%NLS%%share/locale/sl/LC_MESSAGES/lxterminal.mo
+%%NLS%%share/locale/sr/LC_MESSAGES/lxterminal.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/lxterminal.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/lxterminal.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/lxterminal.mo
+%%NLS%%share/locale/ur/LC_MESSAGES/lxterminal.mo
+%%NLS%%share/locale/ur_PK/LC_MESSAGES/lxterminal.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/lxterminal.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/lxterminal.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/lxterminal.mo
+share/applications/lxterminal.desktop
+share/pixmaps/lxterminal.png
+share/lxterminal/lxterminal.conf
+share/lxterminal/lxterminal-preferences.ui
+@dirrm share/lxterminal
+@dirrmtry share/applications
+%%NLS%%@dirrmtry share/locale/nb_NO/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/nb_NO
+%%NLS%%@dirrmtry share/locale/es_VE/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/es_VE
+%%NLS%%@dirrmtry share/locale/frp/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/frp
+%%NLS%%@dirrmtry share/locale/ur_PK/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/ur_PK