aboutsummaryrefslogtreecommitdiff
path: root/sysutils/massadmin
diff options
context:
space:
mode:
authorGanael LAPLANCHE <martymac@FreeBSD.org>2010-09-29 20:36:31 +0000
committerGanael LAPLANCHE <martymac@FreeBSD.org>2010-09-29 20:36:31 +0000
commit320bed4f0aec8c69d390c060195cb53fd7de308d (patch)
tree13848ef7a7e9f07fec1a0fd774b39e7ec9667e3a /sysutils/massadmin
parent2ed50afd68565701dd76ddf77f9a01bbf6da0f6c (diff)
downloadports-320bed4f0aec8c69d390c060195cb53fd7de308d.tar.gz
ports-320bed4f0aec8c69d390c060195cb53fd7de308d.zip
Notes
Diffstat (limited to 'sysutils/massadmin')
-rw-r--r--sysutils/massadmin/Makefile38
-rw-r--r--sysutils/massadmin/distinfo3
-rw-r--r--sysutils/massadmin/pkg-descr12
3 files changed, 53 insertions, 0 deletions
diff --git a/sysutils/massadmin/Makefile b/sysutils/massadmin/Makefile
new file mode 100644
index 000000000000..ca13d61271f9
--- /dev/null
+++ b/sysutils/massadmin/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: massadmin
+# Date created: 27 Sep 2010
+# Whom: Sascha Klauder <sklauder@trimind.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= massadmin
+PORTVERSION= 2.3
+CATEGORIES= sysutils
+MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}
+
+MAINTAINER= sklauder@trimind.de
+COMMENT= Send system commands to a group of remote servers simultaneously
+
+RUN_DEPENDS= p5-Expect>=1.21:${PORTSDIR}/lang/p5-Expect \
+ p5-Net-Telnet>=3.03:${PORTSDIR}/net/p5-Net-Telnet \
+ p5-Net-Ping>=2.36:${PORTSDIR}/net/p5-Net-Ping \
+ p5-Proc-Queue>=1.23:${PORTSDIR}/devel/p5-Proc-Queue \
+ p5-IO-Tty>=1.08:${PORTSDIR}/devel/p5-IO-Tty
+
+NO_BUILD= yes
+USE_PERL5= yes
+
+LICENSE= GPLv3
+
+.if !defined(NO_INSTALL_MANPAGES)
+MAN1= massadmin.1
+.endif
+PLIST_FILES= bin/massadmin
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/massadmin ${PREFIX}/bin
+.if !defined(NO_INSTALL_MANPAGES)
+ (cd ${WRKSRC}/doc && ${INSTALL_MAN} ${MAN1} ${PREFIX}/man/man1)
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/massadmin/distinfo b/sysutils/massadmin/distinfo
new file mode 100644
index 000000000000..6b205e6405d3
--- /dev/null
+++ b/sysutils/massadmin/distinfo
@@ -0,0 +1,3 @@
+MD5 (massadmin-2.3.tar.gz) = 6b0807146e808e8e2075da4196335af7
+SHA256 (massadmin-2.3.tar.gz) = 7fa163900fff0c90db0ae81ad4d36b6cde5a8ea58aa807b4b5e998a07a0be475
+SIZE (massadmin-2.3.tar.gz) = 168387
diff --git a/sysutils/massadmin/pkg-descr b/sysutils/massadmin/pkg-descr
new file mode 100644
index 000000000000..6745c7048755
--- /dev/null
+++ b/sysutils/massadmin/pkg-descr
@@ -0,0 +1,12 @@
+This program is used to send multiple system commands to a group of UNIX-like
+remote servers simultaneously using concurrent processes. Supported protocols:
+FTP, SFTP, TELNET, SSH and SCP. With telnet and ssh all system command are
+supported provided that they are not interactive.
+
+Its main usage is to send repetitive sysadmin tasks to a group of servers but
+you can also use it for automatic ftp or scp backup and much more.
+
+Commands are exactly those you type on your terminal. It also allow you to use
+'su -' to execute your commands under the TELNET and SSH protocols.
+
+WWW: http://massadmin.darold.net/