aboutsummaryrefslogtreecommitdiff
path: root/sysutils/mcelog
diff options
context:
space:
mode:
authorRichard Gallamore <ultima@FreeBSD.org>2017-06-12 20:27:42 +0000
committerRichard Gallamore <ultima@FreeBSD.org>2017-06-12 20:27:42 +0000
commitec4c0fb8dfad51c5e418883706a336a43160f280 (patch)
treeec1abd2d9f39ec19d0cb3c48e7eb531cffb2ff7d /sysutils/mcelog
parent362798bad50835d988d6699c3cfbaa5a864d57ca (diff)
downloadports-ec4c0fb8dfad51c5e418883706a336a43160f280.tar.gz
ports-ec4c0fb8dfad51c5e418883706a336a43160f280.zip
Notes
Diffstat (limited to 'sysutils/mcelog')
-rw-r--r--sysutils/mcelog/Makefile2
-rw-r--r--sysutils/mcelog/distinfo6
-rw-r--r--sysutils/mcelog/files/patch-server.c38
3 files changed, 34 insertions, 12 deletions
diff --git a/sysutils/mcelog/Makefile b/sysutils/mcelog/Makefile
index 45b73a0f4e5f..56cf1045ec4b 100644
--- a/sysutils/mcelog/Makefile
+++ b/sysutils/mcelog/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= mcelog
-PORTVERSION= 151
+PORTVERSION= 153
DISTVERSIONPREFIX= v
CATEGORIES= sysutils
diff --git a/sysutils/mcelog/distinfo b/sysutils/mcelog/distinfo
index b89e82c34c70..ca4dc6d05aff 100644
--- a/sysutils/mcelog/distinfo
+++ b/sysutils/mcelog/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1495807224
-SHA256 (andikleen-mcelog-v151_GH0.tar.gz) = a98268d782c66bcb3c657b81038871a47d6c841f4a5322471c7def88e33eb9f8
-SIZE (andikleen-mcelog-v151_GH0.tar.gz) = 297043
+TIMESTAMP = 1497297738
+SHA256 (andikleen-mcelog-v153_GH0.tar.gz) = 9b827f708855804b6952de6f6cbf2f6523fa1203c621e6050064388f459646f1
+SIZE (andikleen-mcelog-v153_GH0.tar.gz) = 297099
diff --git a/sysutils/mcelog/files/patch-server.c b/sysutils/mcelog/files/patch-server.c
index ec80e0347057..23ce5342f5cf 100644
--- a/sysutils/mcelog/files/patch-server.c
+++ b/sysutils/mcelog/files/patch-server.c
@@ -1,6 +1,6 @@
---- server.c.orig 2016-02-10 18:38:43 UTC
+--- server.c.orig 2017-06-11 18:52:26 UTC
+++ server.c
-@@ -101,7 +101,9 @@ static void dispatch_dump(FILE *fh, char
+@@ -101,7 +101,9 @@ static void dispatch_dump(FILE *fh, char *s)
static void dispatch_pages(FILE *fh)
{
@@ -10,7 +10,7 @@
fprintf(fh, "done\n");
}
-@@ -137,6 +139,7 @@ static void process_cmd(struct clientcon
+@@ -137,6 +139,7 @@ static void process_cmd(struct clientcon *cc)
Enomem();
}
@@ -18,12 +18,12 @@
/* check if client is allowed to access */
static int access_check(int fd, struct msghdr *msg)
{
-@@ -162,11 +165,44 @@ static int access_check(int fd, struct m
+@@ -162,11 +165,44 @@ static int access_check(int fd, struct msghdr *msg)
sendstring(fd, "permission denied\n");
return -1;
}
+#endif
-+
+
+#ifdef __FreeBSD__
+/* check if client is allowed to access */
+static int access_check(int fd, struct msghdr *msg)
@@ -51,7 +51,7 @@
+ return -1;
+}
+#endif
-
++
/* retrieve commands from client */
static int client_input(int fd, struct clientcon *cc)
{
@@ -63,7 +63,7 @@
struct iovec miov;
struct msghdr msg = {
.msg_iov = &miov,
-@@ -242,18 +278,22 @@ static void client_accept(struct pollfd
+@@ -242,18 +278,22 @@ static void client_accept(struct pollfd *pfd, void *da
{
struct clientcon *cc = NULL;
int nfd = accept(pfd->fd, NULL, 0);
@@ -86,7 +86,7 @@
cc = xalloc(sizeof(struct clientcon));
if (register_pollcb(nfd, POLLIN, client_event, cc) < 0) {
-@@ -301,7 +341,12 @@ static int server_ping(struct sockaddr_u
+@@ -301,7 +341,12 @@ static int server_ping(struct sockaddr_un *un)
if (sigsetjmp(ping_timeout_ctx, 1) == 0) {
ret = -1;
alarm(initial_ping_timeout);
@@ -99,3 +99,25 @@
goto cleanup;
if (write(fd, PAIR("ping\n")) < 0)
goto cleanup;
+@@ -322,7 +367,9 @@ void server_setup(void)
+ {
+ int fd;
+ struct sockaddr_un adr;
++#ifdef __Linux__
+ int on;
++#endif
+
+ server_config();
+
+@@ -363,9 +410,11 @@ void server_setup(void)
+ listen(fd, 10);
+ /* Set SO_PASSCRED to avoid race with client connecting too fast */
+ /* Ignore error for old kernels */
++#ifdef __Linux__
+ on = 1;
+ setsockopt(fd, SOL_SOCKET, SO_PASSCRED, &on, sizeof(on));
+
++#endif
+ register_pollcb(fd, POLLIN, client_accept, NULL);
+ return;
+