aboutsummaryrefslogtreecommitdiff
path: root/sysutils/mcollective-puppet-client
diff options
context:
space:
mode:
authorRomain Tartière <romain@FreeBSD.org>2016-04-05 16:30:09 +0000
committerRomain Tartière <romain@FreeBSD.org>2016-04-05 16:30:09 +0000
commit86406699e5208f8b940816930f86b9230e194014 (patch)
tree0c2eaae75403ac6bfdf7e8bffa479623d1613418 /sysutils/mcollective-puppet-client
parent07d76bdb5652a7fd49840f1c8fa2e4ed6f4bd20f (diff)
Notes
Diffstat (limited to 'sysutils/mcollective-puppet-client')
-rw-r--r--sysutils/mcollective-puppet-client/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/sysutils/mcollective-puppet-client/Makefile b/sysutils/mcollective-puppet-client/Makefile
new file mode 100644
index 000000000000..5bef713cdd43
--- /dev/null
+++ b/sysutils/mcollective-puppet-client/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= mcollective-puppet-client
+
+COMMENT= MCollective client to manage the Puppet Agent
+
+# See MASTERDIR for MAINTAINER.
+
+RUN_DEPENDS= mcollective-puppet-common>=${PORTVERSION}:${PORTSDIR}/sysutils/mcollective-puppet-common
+
+MASTERDIR= ${.CURDIR}/../mcollective-puppet-common
+
+PLIST_FILES= share/mcollective/application/puppet.rb \
+ share/mcollective/aggregate/boolean_summary.ddl \
+ share/mcollective/aggregate/boolean_summary.rb
+
+do-install:
+ cd ${WRKSRC} && ${COPYTREE_SHARE} "aggregate application" ${STAGEDIR}${PREFIX}/share/mcollective
+
+.include "${MASTERDIR}/Makefile"