aboutsummaryrefslogtreecommitdiff
path: root/sysutils/mcollective-puppet-common
diff options
context:
space:
mode:
authorRomain Tartière <romain@FreeBSD.org>2016-04-05 16:30:09 +0000
committerRomain Tartière <romain@FreeBSD.org>2016-04-05 16:30:09 +0000
commit86406699e5208f8b940816930f86b9230e194014 (patch)
tree0c2eaae75403ac6bfdf7e8bffa479623d1613418 /sysutils/mcollective-puppet-common
parent07d76bdb5652a7fd49840f1c8fa2e4ed6f4bd20f (diff)
downloadports-86406699e5208f8b940816930f86b9230e194014.tar.gz
ports-86406699e5208f8b940816930f86b9230e194014.zip
Notes
Diffstat (limited to 'sysutils/mcollective-puppet-common')
-rw-r--r--sysutils/mcollective-puppet-common/Makefile46
-rw-r--r--sysutils/mcollective-puppet-common/distinfo2
-rw-r--r--sysutils/mcollective-puppet-common/pkg-descr3
3 files changed, 51 insertions, 0 deletions
diff --git a/sysutils/mcollective-puppet-common/Makefile b/sysutils/mcollective-puppet-common/Makefile
new file mode 100644
index 000000000000..8511c6e3a82c
--- /dev/null
+++ b/sysutils/mcollective-puppet-common/Makefile
@@ -0,0 +1,46 @@
+# $FreeBSD$
+
+PORTNAME?= mcollective-puppet-common
+PORTVERSION= 1.10.0
+CATEGORIES= sysutils
+
+MAINTAINER= anes@anes.su
+COMMENT?= MCollective common files to manage the Puppet Agent
+
+LICENSE= APACHE20
+
+RUN_DEPENDS?= mcollective>=2:${PORTSDIR}/sysutils/mcollective
+
+USE_GITHUB= yes
+GH_ACCOUNT= puppetlabs
+GH_PROJECT= mcollective-puppet-agent
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+PLIST_FILES?= share/mcollective/agent/puppet.ddl \
+ share/mcollective/data/puppet_data.ddl \
+ share/mcollective/data/puppet_data.rb \
+ share/mcollective/data/resource_data.ddl \
+ share/mcollective/data/resource_data.rb \
+ share/mcollective/util/puppet_agent_mgr.rb \
+ share/mcollective/util/puppet_agent_mgr/mgr_v2.rb \
+ share/mcollective/util/puppet_agent_mgr/mgr_v3.rb \
+ share/mcollective/util/puppet_agent_mgr/mgr_windows.rb \
+ share/mcollective/util/puppet_server_address_validation.rb \
+ share/mcollective/util/puppetrunner.rb \
+ share/mcollective/validator/puppet_resource_validator.ddl \
+ share/mcollective/validator/puppet_resource_validator.rb \
+ share/mcollective/validator/puppet_server_address_validator.ddl \
+ share/mcollective/validator/puppet_server_address_validator.rb \
+ share/mcollective/validator/puppet_tags_validator.ddl \
+ share/mcollective/validator/puppet_tags_validator.rb \
+ share/mcollective/validator/puppet_variable_validator.ddl \
+ share/mcollective/validator/puppet_variable_validator.rb
+
+.if !target(do-install)
+do-install:
+ cd ${WRKSRC} && ${COPYTREE_SHARE} "agent/*.ddl data util validator" ${STAGEDIR}${PREFIX}/share/mcollective
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/mcollective-puppet-common/distinfo b/sysutils/mcollective-puppet-common/distinfo
new file mode 100644
index 000000000000..7c4802e56ed2
--- /dev/null
+++ b/sysutils/mcollective-puppet-common/distinfo
@@ -0,0 +1,2 @@
+SHA256 (puppetlabs-mcollective-puppet-agent-1.10.0_GH0.tar.gz) = 8b074bced98e70fdc668396516892c96aff0c83e79c3726f881ca221e947ea86
+SIZE (puppetlabs-mcollective-puppet-agent-1.10.0_GH0.tar.gz) = 44759
diff --git a/sysutils/mcollective-puppet-common/pkg-descr b/sysutils/mcollective-puppet-common/pkg-descr
new file mode 100644
index 000000000000..2f94991138e6
--- /dev/null
+++ b/sysutils/mcollective-puppet-common/pkg-descr
@@ -0,0 +1,3 @@
+The mcollective puppet agent manages the puppet agent via MCollective.
+
+WWW: https://github.com/puppetlabs/mcollective-puppet-agent