aboutsummaryrefslogtreecommitdiff
path: root/sysutils/memdump
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2004-07-20 07:24:05 +0000
committerVolker Stolz <vs@FreeBSD.org>2004-07-20 07:24:05 +0000
commit409cbf8587dcec2082f6916c515c5092eecdd39c (patch)
tree03d92c1683b4c6e75d5b368e0e270e1baf85d297 /sysutils/memdump
parent03f8a50048b92596f9f7d84c0635b55f778037f4 (diff)
downloadports-409cbf8587dcec2082f6916c515c5092eecdd39c.tar.gz
ports-409cbf8587dcec2082f6916c515c5092eecdd39c.zip
Notes
Diffstat (limited to 'sysutils/memdump')
-rw-r--r--sysutils/memdump/Makefile37
-rw-r--r--sysutils/memdump/distinfo2
-rw-r--r--sysutils/memdump/files/patch-Makefile11
-rw-r--r--sysutils/memdump/pkg-descr5
4 files changed, 55 insertions, 0 deletions
diff --git a/sysutils/memdump/Makefile b/sysutils/memdump/Makefile
new file mode 100644
index 000000000000..e40c2fe3db35
--- /dev/null
+++ b/sysutils/memdump/Makefile
@@ -0,0 +1,37 @@
+# Ports collection makefile for: memdump
+# Date created: 16 June 2004
+# Whom: Yonatan <Yonatan@xpert.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= memdump
+PORTVERSION= 1.0
+CATEGORIES= sysutils
+MASTER_SITES= http://www.porcupine.org/forensics/
+
+MAINTAINER= yonatan@xpert.com
+COMMENT= Forensic utility for memory-dumping
+
+.include <bsd.port.pre.mk>
+
+.if ( ${OSVERSION} >= 500000 )
+IGNORE= Only supports FreeBSD up to 4.x (yet?)
+.endif
+
+ALL_TARGET= what
+
+PLIST_FILES= bin/memdump
+PORTDOCS= README LICENSE
+MAN1= memdump.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/memdump ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/memdump.1 ${MANPREFIX}/man/man1
+. if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/LICENSE ${DOCSDIR}
+. endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/memdump/distinfo b/sysutils/memdump/distinfo
new file mode 100644
index 000000000000..86f63d062cd7
--- /dev/null
+++ b/sysutils/memdump/distinfo
@@ -0,0 +1,2 @@
+MD5 (memdump-1.0.tar.gz) = 90c331de23ea6146a978a6e5ed6d9c34
+SIZE (memdump-1.0.tar.gz) = 12669
diff --git a/sysutils/memdump/files/patch-Makefile b/sysutils/memdump/files/patch-Makefile
new file mode 100644
index 000000000000..8064650a1845
--- /dev/null
+++ b/sysutils/memdump/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig Wed Jun 16 23:37:28 2004
++++ Makefile Wed Jun 16 23:37:47 2004
+@@ -3,7 +3,7 @@
+ OPT = -O
+ DEBUG = -g
+ PROGS = memdump
+-CFLAGS = $(OPT) $(DEBUG) -I. $(XFLAGS) $(DEFS)
++CFLAGS += $(OPT) $(DEBUG) -I. $(XFLAGS) $(DEFS)
+ OBJS = memdump.o convert_size.o error.o mymalloc.o
+ PROGS = memdump
+ MAN = memdump.1
diff --git a/sysutils/memdump/pkg-descr b/sysutils/memdump/pkg-descr
new file mode 100644
index 000000000000..5b8bf7b4d96a
--- /dev/null
+++ b/sysutils/memdump/pkg-descr
@@ -0,0 +1,5 @@
+This program dumps system memory to the standard output stream,
+skipping over holes in memory maps.
+By default, the program dumps the contents of physical memory.
+
+WWW: http://www.porcupine.org/forensics/