aboutsummaryrefslogtreecommitdiff
path: root/sysutils/memdump
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2014-01-21 06:21:14 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2014-01-21 06:21:14 +0000
commita5794020d80f26d1bae303ebe0f36b51f0f71009 (patch)
tree669edc416b55158ff737175f5ade5fb17672cb20 /sysutils/memdump
parent308e8e616b7c3d4193b1b8fa7ca541bf5974af16 (diff)
downloadports-a5794020d80f26d1bae303ebe0f36b51f0f71009.tar.gz
ports-a5794020d80f26d1bae303ebe0f36b51f0f71009.zip
Notes
Diffstat (limited to 'sysutils/memdump')
-rw-r--r--sysutils/memdump/Makefile33
-rw-r--r--sysutils/memdump/files/patch-makedefs22
-rw-r--r--sysutils/memdump/files/patch-memdump.c10
-rw-r--r--sysutils/memdump/pkg-descr11
4 files changed, 44 insertions, 32 deletions
diff --git a/sysutils/memdump/Makefile b/sysutils/memdump/Makefile
index 48b9c2e313c1..e91d516cf493 100644
--- a/sysutils/memdump/Makefile
+++ b/sysutils/memdump/Makefile
@@ -7,28 +7,23 @@ CATEGORIES= sysutils
MASTER_SITES= http://www.porcupine.org/forensics/
MAINTAINER= onatan@gmail.com
-COMMENT= Forensic utility for memory-dumping
+COMMENT= Forensic utility for memory dumping
+
+LICENSE= IBM
+LICENSE_NAME= IBM Public License 1.0
+LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
ALL_TARGET= what
+MAKE_ARGS= OPT="${CFLAGS}" DEBUG=''
-PLIST_FILES= bin/memdump
-PORTDOCS= README LICENSE
-MAN1= memdump.1
+PORTDOCS= README
+PLIST_FILES= bin/memdump man/man1/memdump.1.gz
-NO_STAGE= yes
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/memdump ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/memdump.1 ${MANPREFIX}/man/man1
-. if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/LICENSE ${DOCSDIR}
-. endif
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 900000
-BROKEN= unsupported FreeBSD version
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/memdump ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/memdump.1 ${STAGEDIR}${MANPREFIX}/man/man1
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/memdump/files/patch-makedefs b/sysutils/memdump/files/patch-makedefs
index c4f886a40bb5..227bc4d1d4f4 100644
--- a/sysutils/memdump/files/patch-makedefs
+++ b/sysutils/memdump/files/patch-makedefs
@@ -1,11 +1,21 @@
--- ./makedefs.orig 2005-08-30 23:03:40.000000000 +0000
+++ ./makedefs 2007-11-30 18:54:11.000000000 +0000
-@@ -14,6 +14,8 @@
+@@ -2,17 +2,7 @@ SYSTEM=`(uname -s) 2>/dev/null`
+ RELEASE=`(uname -r) 2>/dev/null`
+
+ case "$SYSTEM.$RELEASE" in
+- FreeBSD.2*) DEFS="-DFREEBSD2"
+- ;;
+- FreeBSD.3*) DEFS="-DFREEBSD3"
+- ;;
+- FreeBSD.4*) DEFS="-DFREEBSD4"
+- ;;
+- FreeBSD.5*) DEFS="-DFREEBSD5"
+- ;;
+- FreeBSD.6*) DEFS="-DFREEBSD6"
+- ;;
+- FreeBSD.7*) DEFS="-DFREEBSD7"
++ FreeBSD.*) DEFS="-DFREEBSD"
;;
- FreeBSD.7*) DEFS="-DFREEBSD7"
- ;;
-+ FreeBSD.8*) DEFS="-DFREEBSD8"
-+ ;;
OpenBSD.2*) DEFS="-DOPENBSD2"
;;
- OpenBSD.3*) DEFS="-DOPENBSD3"
diff --git a/sysutils/memdump/files/patch-memdump.c b/sysutils/memdump/files/patch-memdump.c
index 7576614f8434..bc84dff81c11 100644
--- a/sysutils/memdump/files/patch-memdump.c
+++ b/sysutils/memdump/files/patch-memdump.c
@@ -1,10 +1,12 @@
--- ./memdump.c.orig 2005-08-30 23:04:18.000000000 +0000
+++ ./memdump.c 2007-11-30 18:54:11.000000000 +0000
-@@ -109,6 +109,7 @@
+@@ -107,8 +107,7 @@
+ #define SUPPORTED
+ #endif
- #if defined(FREEBSD2) || defined(FREEBSD3) || defined(FREEBSD4) \
- || defined(FREEBSD5) || defined(FREEBSD6) || defined(FREEBSD7) \
-+ || defined(FREEBSD8) \
+-#if defined(FREEBSD2) || defined(FREEBSD3) || defined(FREEBSD4) \
+- || defined(FREEBSD5) || defined(FREEBSD6) || defined(FREEBSD7) \
++#if defined(FREEBSD) \
|| defined(OPENBSD2) || defined(OPENBSD3) \
|| defined(BSDI2) || defined(BSDI3) || defined(BSDI4)
#include <sys/param.h>
diff --git a/sysutils/memdump/pkg-descr b/sysutils/memdump/pkg-descr
index b88a609b9577..578bfae7e0bf 100644
--- a/sysutils/memdump/pkg-descr
+++ b/sysutils/memdump/pkg-descr
@@ -1,5 +1,10 @@
-This program dumps system memory to the standard output stream,
-skipping over holes in memory maps.
-By default, the program dumps the contents of physical memory.
+This program dumps system memory to the standard output stream, skipping
+over holes in memory maps. By default, the program dumps the contents of
+physical memory.
+
+Note: consider using Brian Carrier's Sleuthkit, available as `sysutils/
+sleuthkit' port. It is the official successor, based on parts from TCT.
+Development of the Coroner's Toolkit was stopped years ago. It is only
+updated for bugfixes, which are very rare.
WWW: http://www.porcupine.org/forensics/tct.html