aboutsummaryrefslogtreecommitdiff
path: root/sysutils/memfetch
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2014-01-21 06:21:35 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2014-01-21 06:21:35 +0000
commitde1b6c2e1898e1183ac2bb4cf841cb20192862cc (patch)
tree7af835c7832a1e4d17c6656f4a09f27d2b09c1b4 /sysutils/memfetch
parenta5794020d80f26d1bae303ebe0f36b51f0f71009 (diff)
downloadports-de1b6c2e1898e1183ac2bb4cf841cb20192862cc.tar.gz
ports-de1b6c2e1898e1183ac2bb4cf841cb20192862cc.zip
Notes
Diffstat (limited to 'sysutils/memfetch')
-rw-r--r--sysutils/memfetch/Makefile22
-rw-r--r--sysutils/memfetch/files/patch-Makefile13
-rw-r--r--sysutils/memfetch/pkg-descr19
-rw-r--r--sysutils/memfetch/pkg-message7
4 files changed, 16 insertions, 45 deletions
diff --git a/sysutils/memfetch/Makefile b/sysutils/memfetch/Makefile
index e7a2d3f97f85..2947c4dd3059 100644
--- a/sysutils/memfetch/Makefile
+++ b/sysutils/memfetch/Makefile
@@ -9,24 +9,20 @@ DISTNAME= ${PORTNAME}
EXTRACT_SUFX= .tgz
MAINTAINER= onatan@gmail.com
-COMMENT= Utility to dump process memory
+COMMENT= Utility to dump memory of a running process
+
+LICENSE= GPLv2
-WRKSRC= ${WRKDIR}/${PORTNAME}
USES= perl5
USE_PERL5= run
+MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}"
-CFLAGS+= ${CPPFLAGS}
+WRKSRC= ${WRKDIR}/${PORTNAME}
-NO_STAGE= yes
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- ${INSTALL_SCRIPT} ${WRKSRC}/mffind.pl ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
-.endif
-
-post-install:
- @${CAT} ${PKGMESSAGE}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/mffind.pl ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/sysutils/memfetch/files/patch-Makefile b/sysutils/memfetch/files/patch-Makefile
deleted file mode 100644
index c83916124c58..000000000000
--- a/sysutils/memfetch/files/patch-Makefile
+++ /dev/null
@@ -1,13 +0,0 @@
---- Makefile.orig Thu Nov 25 15:30:12 2004
-+++ Makefile Thu Nov 25 15:31:32 2004
-@@ -7,8 +7,8 @@
- #
-
- FILE = memfetch
--CFLAGS = -Wall -O9
--CC = gcc
-+CFLAGS?= -Wall -O9
-+CC ?= gcc
-
- all: $(FILE)
-
diff --git a/sysutils/memfetch/pkg-descr b/sysutils/memfetch/pkg-descr
index f2dea6e4d7b8..c9fbf1c910ad 100644
--- a/sysutils/memfetch/pkg-descr
+++ b/sysutils/memfetch/pkg-descr
@@ -1,16 +1,7 @@
-Memfetch is a very simple utility that can be used to dump process memory of
-any userspace process running on the system without affecting its execution.
-Why bother? Well, quite often it is desirable to see what code and what data
-actually resides in memory under some pid (/proc entries are not always
-accurate). Debuggers like gdb are pretty good for examining small sections
-of code or memory, but are pretty much useless for massive comparison,
-sophisticated searches and such. It's good to be able to retrieve full
-memory image to run it thru grep, strings, your favorite viewer or any other
-tool. Quite obviously, I developed this code not because it's extremely
-difficult to do it on your own, but because it is a valuable shell utility
-for all kinds of deep hacking activities that simply saves you time.
-
-Memfetch is a convenient screenshot grabber for ssh or screen sessions, by
-the way ;-)
+Memfetch is a simple utility to dump all memory of a running process, either
+immediately, or when a fault condition is discovered. It is an attractive
+alternative to the vastly inferior search capabilities of many debuggers and
+tracers -- and a convenient way to grab "screen shots" from many types of
+text-based interactive utilities, like ssh or screen sessions.
WWW: http://lcamtuf.coredump.cx/
diff --git a/sysutils/memfetch/pkg-message b/sysutils/memfetch/pkg-message
index ae01e0cca472..e69b5f0b1d85 100644
--- a/sysutils/memfetch/pkg-message
+++ b/sysutils/memfetch/pkg-message
@@ -1,5 +1,2 @@
-
-Security Warning:
-This port requires that you mount procfs(5) filesystem in /proc.
-Please note that this can pose a security risk.
-
+ This port requires procfs(5) filesystem mounted under /proc.
+ Please note that this can pose a security risk.