aboutsummaryrefslogtreecommitdiff
path: root/sysutils/memgrep
diff options
context:
space:
mode:
authorFoxfair Hu <foxfair@FreeBSD.org>2003-05-22 03:55:03 +0000
committerFoxfair Hu <foxfair@FreeBSD.org>2003-05-22 03:55:03 +0000
commitc3d65c185bc5057c861e81439d9cba29c51f8f2b (patch)
tree1c7f06b0f63a3e2863bd6c64220e55818d95bd78 /sysutils/memgrep
parent6969414b2a5690f5696fe7757dcfb059869a8457 (diff)
downloadports-c3d65c185bc5057c861e81439d9cba29c51f8f2b.tar.gz
ports-c3d65c185bc5057c861e81439d9cba29c51f8f2b.zip
Notes
Diffstat (limited to 'sysutils/memgrep')
-rw-r--r--sysutils/memgrep/Makefile25
-rw-r--r--sysutils/memgrep/distinfo1
-rw-r--r--sysutils/memgrep/files/patch-Makefile.in21
-rw-r--r--sysutils/memgrep/pkg-descr6
-rw-r--r--sysutils/memgrep/pkg-plist27
5 files changed, 80 insertions, 0 deletions
diff --git a/sysutils/memgrep/Makefile b/sysutils/memgrep/Makefile
new file mode 100644
index 000000000000..bf5c9bfea67d
--- /dev/null
+++ b/sysutils/memgrep/Makefile
@@ -0,0 +1,25 @@
+# New ports collection Makefile for: memgrep
+# Date created: 22 February 2003
+# Whom: Clement Laforet <sheepkiller@cultdeadsheep.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= memgrep
+PORTVERSION= 0.7.0
+CATEGORIES= sysutils
+MASTER_SITES= http://www.hick.org/code/skape/memgrep/
+
+MAINTAINER= sheepkiller@cultdeadsheep.org
+COMMENT= Utility to manipulate memory from running processes and core files
+
+HAS_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}/html
+ ${INSTALL_DATA} ${WRKSRC}/docs/html/* ${DOCSDIR}/html
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/memgrep/distinfo b/sysutils/memgrep/distinfo
new file mode 100644
index 000000000000..2741430dcf50
--- /dev/null
+++ b/sysutils/memgrep/distinfo
@@ -0,0 +1 @@
+MD5 (memgrep-0.7.0.tar.gz) = 935787217d081c54b7f9ed9100bb7ab6
diff --git a/sysutils/memgrep/files/patch-Makefile.in b/sysutils/memgrep/files/patch-Makefile.in
new file mode 100644
index 000000000000..5dc89213b299
--- /dev/null
+++ b/sysutils/memgrep/files/patch-Makefile.in
@@ -0,0 +1,21 @@
+--- Makefile.in.orig Sat Feb 22 00:41:31 2003
++++ Makefile.in Sat Feb 22 14:04:54 2003
+@@ -6,13 +6,13 @@
+ cd examples && make
+
+ install:
+- cp include/memgrep.h /usr/include
+- cp libmemgrep.so /usr/lib
+- cp libmemgrep.a /usr/lib
+- cp memgrep /usr/bin
++ ${INSTALL} include/memgrep.h ${PREFIX}/include
++ ${INSTALL} libmemgrep.so ${PREFIX}/lib
++ ${INSTALL} libmemgrep.a ${PREFIX}/lib
++ ${INSTALL} memgrep ${PREFIX}/bin
+
+ uninstall:
+- rm -f /usr/lib/libmemgrep.so /usr/lib/libmemgrep.a /usr/bin/memgrep /usr/include/memgrep.h
++ rm -f ${PREFIX}/lib/libmemgrep.so ${PREFIX}/lib/libmemgrep.a ${PREFIX}/bin/memgrep ${PREFIX}/include/memgrep.h
+
+ clean:
+ cd examples && make clean
diff --git a/sysutils/memgrep/pkg-descr b/sysutils/memgrep/pkg-descr
new file mode 100644
index 000000000000..f1a0144b467a
--- /dev/null
+++ b/sysutils/memgrep/pkg-descr
@@ -0,0 +1,6 @@
+memgrep is an utility to search/replace/dump memory from running processes
+and core files.
+It also provides an API to write you own tools.
+
+WWW: http://www.hick.org/code.html
+Authors : hick.org community
diff --git a/sysutils/memgrep/pkg-plist b/sysutils/memgrep/pkg-plist
new file mode 100644
index 000000000000..8ab17104f0e2
--- /dev/null
+++ b/sysutils/memgrep/pkg-plist
@@ -0,0 +1,27 @@
+bin/memgrep
+include/memgrep.h
+lib/libmemgrep.so
+lib/libmemgrep.a
+%%PORTDOCS%%share/doc/memgrep/html/annotated.html
+%%PORTDOCS%%share/doc/memgrep/html/doxygen.css
+%%PORTDOCS%%share/doc/memgrep/html/doxygen.png
+%%PORTDOCS%%share/doc/memgrep/html/examples.html
+%%PORTDOCS%%share/doc/memgrep/html/files.html
+%%PORTDOCS%%share/doc/memgrep/html/functions.html
+%%PORTDOCS%%share/doc/memgrep/html/group__memgrep.html
+%%PORTDOCS%%share/doc/memgrep/html/index.html
+%%PORTDOCS%%share/doc/memgrep/html/memgrep_8h-source.html
+%%PORTDOCS%%share/doc/memgrep/html/modules.html
+%%PORTDOCS%%share/doc/memgrep/html/simple_8c-example.html
+%%PORTDOCS%%share/doc/memgrep/html/struct__core__memory__sections.html
+%%PORTDOCS%%share/doc/memgrep/html/struct__mem__ctx.html
+%%PORTDOCS%%share/doc/memgrep/html/struct__mem__ctx__core__data.html
+%%PORTDOCS%%share/doc/memgrep/html/struct__memgrep__functions.html
+%%PORTDOCS%%share/doc/memgrep/html/struct__memgrep__result.html
+%%PORTDOCS%%share/doc/memgrep/html/struct__memgrep__result__row.html
+%%PORTDOCS%%share/doc/memgrep/html/struct__memgrep__result__row__dump.html
+%%PORTDOCS%%share/doc/memgrep/html/struct__memgrep__result__row__replace.html
+%%PORTDOCS%%share/doc/memgrep/html/struct__memgrep__result__row__search.html
+%%PORTDOCS%%share/doc/memgrep/html/struct__process__section__addrs.html
+%%PORTDOCS%%@dirrm share/doc/memgrep/html
+%%PORTDOCS%%@dirrm share/doc/memgrep