aboutsummaryrefslogtreecommitdiff
path: root/sysutils/memtest86+
diff options
context:
space:
mode:
authorDmitry Morozovsky <marck@FreeBSD.org>2012-04-18 20:55:35 +0000
committerDmitry Morozovsky <marck@FreeBSD.org>2012-04-18 20:55:35 +0000
commit92e17569b388aca8cd4dfe74ea30521ad1e2f666 (patch)
tree43316d9e5c26e4f96ee73436e4bb3126da21088c /sysutils/memtest86+
parent814610a8f6bf7bb18649c6135ceca11807cc21f8 (diff)
downloadports-92e17569b388aca8cd4dfe74ea30521ad1e2f666.tar.gz
ports-92e17569b388aca8cd4dfe74ea30521ad1e2f666.zip
Notes
Diffstat (limited to 'sysutils/memtest86+')
-rw-r--r--sysutils/memtest86+/Makefile11
-rw-r--r--sysutils/memtest86+/files/extra-patch-config.h3
-rw-r--r--sysutils/memtest86+/files/extra-patch-config.h-11520020
3 files changed, 29 insertions, 5 deletions
diff --git a/sysutils/memtest86+/Makefile b/sysutils/memtest86+/Makefile
index 5016824da442..30fce8bf72b2 100644
--- a/sysutils/memtest86+/Makefile
+++ b/sysutils/memtest86+/Makefile
@@ -7,7 +7,7 @@
PORTNAME= memtest86+
PORTVERSION= 4.20
-#PORTREVISION= 1
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://www.memtest.org/download/${PORTVERSION}/
@@ -26,7 +26,8 @@ BOOT_DIR?= /boot/opt
OPTIONS= ISO "Build bootable ISO image" off \
BOOT "Build ELF image loadable by boot2 and loader" on \
- SERIAL "Enable serial console at COM1/115200" off
+ SERIAL "Enable serial console at COM1/9600" off \
+ HISPEED "Set COM1 serial console speed to 115200" off
.include <bsd.port.pre.mk>
@@ -45,8 +46,12 @@ ALL_TARGET+= iso
.endif
.if defined(WITH_SERIAL)
-EXTRA_PATCHES+= ${PATCHDIR}//extra-patch-config.h
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-config.h
+
+.if defined(WITH_HISPEED)
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-config.h-115200
.endif
+.endif # WITH_SERIAL
.if ${OSVERSION} < 700042
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-Makefile
diff --git a/sysutils/memtest86+/files/extra-patch-config.h b/sysutils/memtest86+/files/extra-patch-config.h
index 9033f592759e..aadccec9de48 100644
--- a/sysutils/memtest86+/files/extra-patch-config.h
+++ b/sysutils/memtest86+/files/extra-patch-config.h
@@ -14,8 +14,7 @@ $FreeBSD$
#define SERIAL_TTY 0
/* SERIAL_BAUD_RATE - Baud rate for the serial console */
--#define SERIAL_BAUD_RATE 9600
-+#define SERIAL_BAUD_RATE 115200
+ #define SERIAL_BAUD_RATE 9600
/* BEEP_MODE - Beep on error. Default off, Change to 1 to enable */
#define BEEP_MODE 0
diff --git a/sysutils/memtest86+/files/extra-patch-config.h-115200 b/sysutils/memtest86+/files/extra-patch-config.h-115200
new file mode 100644
index 000000000000..9ed71911b425
--- /dev/null
+++ b/sysutils/memtest86+/files/extra-patch-config.h-115200
@@ -0,0 +1,20 @@
+
+$FreeBSD$
+
+--- config.h.orig
++++ config.h
+@@ -13,13 +13,13 @@
+ /* SERIAL_CONSOLE_DEFAULT - The default state of the serial console. */
+ /* This is normally off since it slows down testing. Change to a 1 */
+ /* to enable. */
+ #define SERIAL_CONSOLE_DEFAULT 1
+
+ /* SERIAL_TTY - The default serial port to use. 0=ttyS0, 1=ttyS1 */
+ #define SERIAL_TTY 0
+
+ /* SERIAL_BAUD_RATE - Baud rate for the serial console */
+-#define SERIAL_BAUD_RATE 9600
++#define SERIAL_BAUD_RATE 115200
+
+ /* BEEP_MODE - Beep on error. Default off, Change to 1 to enable */
+ #define BEEP_MODE 0