aboutsummaryrefslogtreecommitdiff
path: root/sysutils/mkisofs
diff options
context:
space:
mode:
authorJoerg Wunsch <joerg@FreeBSD.org>1997-10-22 06:13:44 +0000
committerJoerg Wunsch <joerg@FreeBSD.org>1997-10-22 06:13:44 +0000
commitc38fb7c7a2c2c5878294edaff40ea38d4aabb482 (patch)
tree91a172125de484cc655e9d69113bf0f4e914a1e8 /sysutils/mkisofs
parentf1e2854159bff962873f31da76dc77419e40ef4a (diff)
downloadports-c38fb7c7a2c2c5878294edaff40ea38d4aabb482.tar.gz
ports-c38fb7c7a2c2c5878294edaff40ea38d4aabb482.zip
Notes
Diffstat (limited to 'sysutils/mkisofs')
-rw-r--r--sysutils/mkisofs/Makefile6
-rw-r--r--sysutils/mkisofs/distinfo2
-rw-r--r--sysutils/mkisofs/files/patch-ac5
-rw-r--r--sysutils/mkisofs/files/patch-ad29
4 files changed, 16 insertions, 26 deletions
diff --git a/sysutils/mkisofs/Makefile b/sysutils/mkisofs/Makefile
index 4901f60410eb..0f1a037e02c9 100644
--- a/sysutils/mkisofs/Makefile
+++ b/sysutils/mkisofs/Makefile
@@ -1,12 +1,12 @@
# New ports collection makefile for: mkisofs
-# Version required: 1.10
+# Version required: 1.11.1
# Date created: 07 Aug 1996
# Whom: jkh
#
-# $Id: Makefile,v 1.4 1997/03/15 00:04:01 asami Exp $
+# $Id: Makefile,v 1.5 1997/04/28 11:30:44 joerg Exp $
#
-DISTNAME= mkisofs-1.10
+DISTNAME= mkisofs-1.11.1
CATEGORIES= sysutils
MASTER_SITES= ftp://ftp.cdrom.com/pub/linux/tsx-11/packages/mkisofs/
diff --git a/sysutils/mkisofs/distinfo b/sysutils/mkisofs/distinfo
index e904839c0d13..73b93849b3d2 100644
--- a/sysutils/mkisofs/distinfo
+++ b/sysutils/mkisofs/distinfo
@@ -1 +1 @@
-MD5 (mkisofs-1.10.tar.gz) = a5c7022f606e3ad2e1c0e0247a5519b0
+MD5 (mkisofs-1.11.1.tar.gz) = f97b359c1525a46088546e280c312cd8
diff --git a/sysutils/mkisofs/files/patch-ac b/sysutils/mkisofs/files/patch-ac
index fe9584601618..b0ca127e41a8 100644
--- a/sysutils/mkisofs/files/patch-ac
+++ b/sysutils/mkisofs/files/patch-ac
@@ -22,9 +22,10 @@
+ memcpy (copy, name, strlen(name) + 1);
+ pnt = copy;
+ last_dot = strrchr (pnt,'.');
- *last_dot = '\0';
+ c = last_dot;
+ *c = '\0';
last_dot = strrchr (pnt,'.');
-- *last_dot = '.';
+- *c = '.';
}
while(*pnt)
diff --git a/sysutils/mkisofs/files/patch-ad b/sysutils/mkisofs/files/patch-ad
index f7f28be83269..378f47208d88 100644
--- a/sysutils/mkisofs/files/patch-ad
+++ b/sysutils/mkisofs/files/patch-ad
@@ -1,21 +1,10 @@
---- eltorito.c.orig Mon May 5 15:46:11 1997
-+++ eltorito.c Mon May 5 16:11:42 1997
-@@ -33,6 +33,9 @@
- #include "mkisofs.h"
- #include "iso9660.h"
+--- multi.c.orig Mon Oct 13 04:46:46 1997
++++ multi.c Fri Oct 17 14:49:16 1997
+@@ -437,6 +437,7 @@
+ if( tt_extent != 0 && tt_size != 0 )
+ {
+ tt_buf = (unsigned char *) e_malloc(tt_size);
++ memset(tt_buf, 0, tt_size);
+ readsecs(tt_extent, tt_buf, tt_size/SECTOR_SIZE);
-+#undef MIN
-+#define MIN(a, b) (((a) < (b))? (a): (b))
-+
- static struct eltorito_validation_entry valid_desc;
- static struct eltorito_defaultboot_entry default_desc;
-
-@@ -158,7 +161,7 @@
- * but who really reads this stuff!
- */
- if (publisher)
-- memcpy_max(valid_desc.id, publisher, strlen(publisher));
-+ memcpy_max(valid_desc.id, publisher, MIN(31, strlen(publisher)));
-
- valid_desc.key1[0] = 0x55;
- valid_desc.key2[0] = 0xAA;
+ /*