aboutsummaryrefslogtreecommitdiff
path: root/sysutils/mog
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2017-03-01 13:35:49 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2017-03-01 13:35:49 +0000
commitddd87a4c4a06ba9d312068d15bafecd382fe59cf (patch)
treee9d0d2cbb8f2191bac954de70064c2f838af6a1b /sysutils/mog
parentcb5cceecea5e5032f9c477c30740bd320c8abc88 (diff)
downloadports-ddd87a4c4a06ba9d312068d15bafecd382fe59cf.tar.gz
ports-ddd87a4c4a06ba9d312068d15bafecd382fe59cf.zip
Notes
Diffstat (limited to 'sysutils/mog')
-rw-r--r--sysutils/mog/Makefile25
-rw-r--r--sysutils/mog/distinfo3
-rw-r--r--sysutils/mog/pkg-descr12
3 files changed, 40 insertions, 0 deletions
diff --git a/sysutils/mog/Makefile b/sysutils/mog/Makefile
new file mode 100644
index 000000000000..37cff953acc1
--- /dev/null
+++ b/sysutils/mog/Makefile
@@ -0,0 +1,25 @@
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= mog
+PORTVERSION= 0.4
+CATEGORIES= sysutils
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Different take on the UNIX tool cat
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pygments>0:textproc/py-pygments \
+ mdv:devel/py-mdv
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USES= python
+USE_GITHUB= yes
+USE_PYTHON= autoplist distutils
+NO_ARCH= yes
+
+GH_ACCOUNT= witchard
+
+.include <bsd.port.mk>
diff --git a/sysutils/mog/distinfo b/sysutils/mog/distinfo
new file mode 100644
index 000000000000..956d18b2853d
--- /dev/null
+++ b/sysutils/mog/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1488372190
+SHA256 (witchard-mog-0.4_GH0.tar.gz) = 41f2592de8716b5609bce957a973f66d4acb4544a6cf021daaefa5d4da5bb2b5
+SIZE (witchard-mog-0.4_GH0.tar.gz) = 61029
diff --git a/sysutils/mog/pkg-descr b/sysutils/mog/pkg-descr
new file mode 100644
index 000000000000..413fc7076259
--- /dev/null
+++ b/sysutils/mog/pkg-descr
@@ -0,0 +1,12 @@
+The man page for cat says that it can: concatenate files and print on the
+standard output. Often its main use is for the latter. mog tries to help you
+"print on the standard output" in a more intelligent way. For example, it can
+be configured to:
+
+ * Syntax highlight scripts
+ * Print a hex dump of binary files
+ * Show details of image files
+ * Perform objdump on executables
+ * List a directory
+
+WWW: https://github.com/witchard/mog/