aboutsummaryrefslogtreecommitdiff
path: root/sysutils/monit/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-04-09 23:54:00 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-04-09 23:54:00 +0000
commit03ecbd8b9caf4b35ca26a9b2b48e593f1d7f7f89 (patch)
treee197e889880c3814150b4e13c48844148bae5b86 /sysutils/monit/Makefile
parent8fb08bb3f9a62563bd5d15519f575290a89b77f1 (diff)
downloadports-03ecbd8b9caf4b35ca26a9b2b48e593f1d7f7f89.tar.gz
ports-03ecbd8b9caf4b35ca26a9b2b48e593f1d7f7f89.zip
Notes
Diffstat (limited to 'sysutils/monit/Makefile')
-rw-r--r--sysutils/monit/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/sysutils/monit/Makefile b/sysutils/monit/Makefile
index 675d8feb1ef5..211501f83e2c 100644
--- a/sysutils/monit/Makefile
+++ b/sysutils/monit/Makefile
@@ -7,6 +7,7 @@
PORTNAME= monit
PORTVERSION= 4.10.1
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://www.tildeslash.com/monit/dist/
@@ -25,7 +26,8 @@ CONFIGURE_ENV= CC="${CC}" CPPFLAGS="${CPPFLAGS}" \
LDFLAGS="${LDFLAGS}" CONFIG_SHELL="${SH}" \
LOCALBASE="${LOCALBASE}"
-OPTIONS= SSL "Enable SSL support" on
+OPTIONS= SSL "Enable SSL support" on \
+ RESOURCE "Enable resource support (not for jail)" on
PLIST_FILES= bin/monit \
etc/monitrc.sample
@@ -44,6 +46,12 @@ CONFIGURE_ARGS+= --enable-ssl --with-openssl="${OPENSSLBASE}"
CONFIGURE_ARGS+= --without-ssl
.endif
+.if defined(WITH_RESOURCE)
+CONFIGURE_ARGS+= --with-resource
+.else
+CONFIGURE_ARGS+= --without-resource
+.endif
+
post-install:
${INSTALL_SCRIPT} -m 600 ${WRKDIR}/${DISTNAME}/monitrc ${PREFIX}/etc/monitrc.sample
.if !defined(NOPORTDOCS)