aboutsummaryrefslogtreecommitdiff
path: root/sysutils/monit
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2013-09-04 01:15:45 +0000
committerMark Felder <feld@FreeBSD.org>2013-09-04 01:15:45 +0000
commit0e4287f43517c19d4605e04221ef3c7c27b0512c (patch)
tree55e7e7831a6ddff506b24fea7335f218ea83f515 /sysutils/monit
parent6c993d7d94559fa2cbf931c4006a11690f79f2b4 (diff)
downloadports-0e4287f43517c19d4605e04221ef3c7c27b0512c.tar.gz
ports-0e4287f43517c19d4605e04221ef3c7c27b0512c.zip
Notes
Diffstat (limited to 'sysutils/monit')
-rw-r--r--sysutils/monit/Makefile19
-rw-r--r--sysutils/monit/distinfo4
-rw-r--r--sysutils/monit/files/monit.in14
3 files changed, 18 insertions, 19 deletions
diff --git a/sysutils/monit/Makefile b/sysutils/monit/Makefile
index 79f54a898cf4..da9089400fbf 100644
--- a/sysutils/monit/Makefile
+++ b/sysutils/monit/Makefile
@@ -2,17 +2,17 @@
# $FreeBSD$
PORTNAME= monit
-PORTVERSION= 5.5.1
+PORTVERSION= 5.6
CATEGORIES= sysutils
MASTER_SITES= http://www.mmonit.com/monit/dist/
MAINTAINER= martinp@tildeslash.com
COMMENT= Unix system management and proactive monitoring
-MAN1= monit.1
+MAN1= monit.1
GNU_CONFIGURE= yes
-USES= bison
+USES= bison
USE_GMAKE= yes
USE_RC_SUBR= ${PORTNAME}
@@ -20,27 +20,26 @@ CONFIGURE_ENV= CONFIG_SHELL="${SH}" \
LOCALBASE="${LOCALBASE}"
OPTIONS_DEFINE= SSL
-OPTIONS_DEFAULT=SSL
+OPTIONS_DEFAULT= SSL
PLIST_FILES= bin/monit \
etc/monitrc.sample
SUB_FILES= pkg-message
-DOCS= CHANGES COPYING README
-PORTDOCS= ${DOCS:T}
+PORTDOCS= CHANGES COPYING README
.include <bsd.port.options.mk>
-.if empty(PORT_OPTIONS:MSSL)
+.if ! ${PORT_OPTIONS:MSSL}
CONFIGURE_ARGS+= --without-ssl
.endif
post-install:
${INSTALL} -m 600 ${WRKSRC}/monitrc ${PREFIX}/etc/monitrc.sample
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL} -m 644 ${DOCS} ${DOCSDIR}/
+.if ${PORT_OPTIONS:MDOCS}
+ ${INSTALL} -d ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL} -m 644 ${PORTDOCS} ${DOCSDIR}
.endif
@${CAT} ${PKGMESSAGE}
diff --git a/sysutils/monit/distinfo b/sysutils/monit/distinfo
index df16589a83d2..882cf97c706d 100644
--- a/sysutils/monit/distinfo
+++ b/sysutils/monit/distinfo
@@ -1,2 +1,2 @@
-SHA256 (monit-5.5.1.tar.gz) = dbe4b4744a7100e2d5f4eac353dfb2df0549848e2c7661d9c19acc31cdef2c78
-SIZE (monit-5.5.1.tar.gz) = 1260093
+SHA256 (monit-5.6.tar.gz) = 38e09bd8b39abc59e6b9a9bb7a78f7eac2b02a92f4de1f3a6dc24e84dfedae0d
+SIZE (monit-5.6.tar.gz) = 1263370
diff --git a/sysutils/monit/files/monit.in b/sysutils/monit/files/monit.in
index 83ecd7c959a2..ccf26a36e25b 100644
--- a/sysutils/monit/files/monit.in
+++ b/sysutils/monit/files/monit.in
@@ -17,20 +17,21 @@
#
. /etc/rc.subr
-name="monit"
+name=monit
rcvar=monit_enable
+load_rc_config ${name}
-restart_precmd="monit_checkconfig"
-reload_precmd="monit_checkconfig"
-[ -z "$monit_enable" ] && monit_enable="NO"
+: ${monit_enable:=NO}
-load_rc_config $name
+extra_commands=reload
+restart_precmd=monit_checkconfig
+reload_precmd=monit_checkconfig
default_config=%%PREFIX%%/etc/monitrc
required_files=${default_config}
command="%%PREFIX%%/bin/monit"
command_args="-c ${default_config}"
-pidfile="/var/run/monit.pid"
+pidfile=/var/run/monit.pid
monit_checkconfig()
{
@@ -38,5 +39,4 @@ monit_checkconfig()
${command} ${command_args} -t
}
-extra_commands="reload"
run_rc_command "$1"