aboutsummaryrefslogtreecommitdiff
path: root/sysutils/moreutils/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2010-11-18 09:34:12 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2010-11-18 09:34:12 +0000
commit571e1b9ae13e175edeaee0bce048f4fa16449a1d (patch)
tree72e755d36fd88852f8058dfdf862c3a5babdd3a9 /sysutils/moreutils/Makefile
parentf07fc9d34eef94c84bac37ac221e22c26939b49e (diff)
Notes
Diffstat (limited to 'sysutils/moreutils/Makefile')
-rw-r--r--sysutils/moreutils/Makefile23
1 files changed, 10 insertions, 13 deletions
diff --git a/sysutils/moreutils/Makefile b/sysutils/moreutils/Makefile
index 99e2ee481f52..075243bb3541 100644
--- a/sysutils/moreutils/Makefile
+++ b/sysutils/moreutils/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= moreutils
-PORTVERSION= 0.42
+PORTVERSION= 0.43
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_DEBIAN_POOL}
DISTNAME= ${PORTNAME}_${PORTVERSION}
@@ -17,9 +17,12 @@ COMMENT= Additional Unix utilities
CONFLICTS= parallel-[0-9]*
+RUN_DEPENDS= ${SITE_PERL}/IPC/Run.pm:${PORTSDIR}/devel/p5-IPC-Run
+
USE_PERL5= yes
-PLIST_FILES= bin/combine \
+PLIST_FILES= bin/chronic \
+ bin/combine \
bin/ifne \
bin/isutf8 \
bin/lckdo \
@@ -36,10 +39,9 @@ ALL_TARGET= bins
WRKSRC= ${WRKDIR}/${PORTNAME}
-.include <bsd.port.pre.mk>
-
.if !defined(NO_INSTALL_MANPAGES)
-MAN1= combine.1 \
+MAN1= chronic.1 \
+ combine.1 \
ifne.1 \
isutf8.1 \
lckdo.1 \
@@ -64,15 +66,10 @@ CANNED_MAN= ifne.1 \
sponge.1
post-patch:
-.for f in ${CANNED_MAN}
- ${CP} ${FILESDIR}/${f} ${WRKSRC}
-.endfor
+ cd ${FILESDIR} && ${CP} ${CANNED_MAN} ${WRKSRC}/
post-install:
-.for manpage in ${MAN1}
- ${INSTALL_MAN} ${WRKSRC}/${manpage} ${MANPREFIX}/man/man1
-.endfor
-
+ cd ${WRKSRC} && ${INSTALL_MAN} ${MAN1} ${MANPREFIX}/man/man1/
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>