aboutsummaryrefslogtreecommitdiff
path: root/sysutils/moreutils/Makefile
diff options
context:
space:
mode:
authorDennis Herrmann <dhn@FreeBSD.org>2009-06-21 10:24:50 +0000
committerDennis Herrmann <dhn@FreeBSD.org>2009-06-21 10:24:50 +0000
commit1e26add69bf114d6d78b9c196b416cdd84a71c19 (patch)
tree9e2ed2fc1152fd22b3260d07b1daa4807e1ab81a /sysutils/moreutils/Makefile
parent61c574f03bebd2e100f66025c9e31ec18a3f3657 (diff)
Notes
Diffstat (limited to 'sysutils/moreutils/Makefile')
-rw-r--r--sysutils/moreutils/Makefile74
1 files changed, 74 insertions, 0 deletions
diff --git a/sysutils/moreutils/Makefile b/sysutils/moreutils/Makefile
new file mode 100644
index 000000000000..104a09a7e7a3
--- /dev/null
+++ b/sysutils/moreutils/Makefile
@@ -0,0 +1,74 @@
+# ex:ts=8
+# Ports collection makefile for: moreutils
+# Date created: 16 June 2009
+# Whom: Charlie Kester <corky1951@comcast.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= moreutils
+PORTVERSION= 0.35
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_DEBIAN_POOL}
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= corky1951@comcast.net
+COMMENT= Additional Unix utilities
+
+.if !defined(NO_INSTALL_MANPAGES)
+BUILD_DEPENDS= docbook2man:${PORTSDIR}/textproc/docbook2X \
+ ${LOCALBASE}/share/xml/docbook/4.4/docbookx.dtd:${PORTSDIR}/textproc/docbook-xml-440
+.endif
+
+USE_PERL5= yes
+USE_GMAKE= yes
+
+PLIST_FILES= bin/combine \
+ bin/ifne \
+ bin/isutf8 \
+ bin/lckdo \
+ bin/mispipe \
+ bin/pee \
+ bin/sponge \
+ bin/ts \
+ bin/vidir \
+ bin/vipe \
+ bin/zrun
+
+ALL_TARGET= bins
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+.include <bsd.port.pre.mk>
+
+.if !defined(NO_INSTALL_MANPAGES)
+MAN1= combine.1 \
+ ifne.1 \
+ isutf8.1 \
+ lckdo.1 \
+ mispipe.1 \
+ pee.1 \
+ sponge.1 \
+ ts.1 \
+ vidir.1 \
+ vipe.1 \
+ zrun.1
+
+ALL_TARGET+= mans
+MANCOMPRESSED= no
+
+# portlint will warn about the next line, but we need it this way
+OLD_DTD= /usr/share/xml/docbook/schema/dtd/4.4/docbookx.dtd
+NEW_DTD= ${LOCALBASE}/share/xml/docbook/4.4/docbookx.dtd
+
+post-patch:
+ @${FIND} ${WRKSRC} -type f -name "*.docbook" | ${XARGS} -n 7 -x ${REINPLACE_CMD} -E -e 's|${OLD_DTD}|${NEW_DTD}|g'
+
+post-install:
+.for manpage in ${MAN1}
+ ${INSTALL_MAN} ${WRKSRC}/${manpage} ${MANPREFIX}/man/man1
+.endfor
+
+.endif
+
+.include <bsd.port.post.mk>