aboutsummaryrefslogtreecommitdiff
path: root/sysutils/moreutils
diff options
context:
space:
mode:
authorDennis Herrmann <dhn@FreeBSD.org>2009-06-21 10:24:50 +0000
committerDennis Herrmann <dhn@FreeBSD.org>2009-06-21 10:24:50 +0000
commit1e26add69bf114d6d78b9c196b416cdd84a71c19 (patch)
tree9e2ed2fc1152fd22b3260d07b1daa4807e1ab81a /sysutils/moreutils
parent61c574f03bebd2e100f66025c9e31ec18a3f3657 (diff)
downloadports-1e26add69bf114d6d78b9c196b416cdd84a71c19.tar.gz
ports-1e26add69bf114d6d78b9c196b416cdd84a71c19.zip
Notes
Diffstat (limited to 'sysutils/moreutils')
-rw-r--r--sysutils/moreutils/Makefile74
-rw-r--r--sysutils/moreutils/distinfo3
-rw-r--r--sysutils/moreutils/files/patch-Makefile37
-rw-r--r--sysutils/moreutils/pkg-descr18
4 files changed, 132 insertions, 0 deletions
diff --git a/sysutils/moreutils/Makefile b/sysutils/moreutils/Makefile
new file mode 100644
index 000000000000..104a09a7e7a3
--- /dev/null
+++ b/sysutils/moreutils/Makefile
@@ -0,0 +1,74 @@
+# ex:ts=8
+# Ports collection makefile for: moreutils
+# Date created: 16 June 2009
+# Whom: Charlie Kester <corky1951@comcast.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= moreutils
+PORTVERSION= 0.35
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_DEBIAN_POOL}
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= corky1951@comcast.net
+COMMENT= Additional Unix utilities
+
+.if !defined(NO_INSTALL_MANPAGES)
+BUILD_DEPENDS= docbook2man:${PORTSDIR}/textproc/docbook2X \
+ ${LOCALBASE}/share/xml/docbook/4.4/docbookx.dtd:${PORTSDIR}/textproc/docbook-xml-440
+.endif
+
+USE_PERL5= yes
+USE_GMAKE= yes
+
+PLIST_FILES= bin/combine \
+ bin/ifne \
+ bin/isutf8 \
+ bin/lckdo \
+ bin/mispipe \
+ bin/pee \
+ bin/sponge \
+ bin/ts \
+ bin/vidir \
+ bin/vipe \
+ bin/zrun
+
+ALL_TARGET= bins
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+.include <bsd.port.pre.mk>
+
+.if !defined(NO_INSTALL_MANPAGES)
+MAN1= combine.1 \
+ ifne.1 \
+ isutf8.1 \
+ lckdo.1 \
+ mispipe.1 \
+ pee.1 \
+ sponge.1 \
+ ts.1 \
+ vidir.1 \
+ vipe.1 \
+ zrun.1
+
+ALL_TARGET+= mans
+MANCOMPRESSED= no
+
+# portlint will warn about the next line, but we need it this way
+OLD_DTD= /usr/share/xml/docbook/schema/dtd/4.4/docbookx.dtd
+NEW_DTD= ${LOCALBASE}/share/xml/docbook/4.4/docbookx.dtd
+
+post-patch:
+ @${FIND} ${WRKSRC} -type f -name "*.docbook" | ${XARGS} -n 7 -x ${REINPLACE_CMD} -E -e 's|${OLD_DTD}|${NEW_DTD}|g'
+
+post-install:
+.for manpage in ${MAN1}
+ ${INSTALL_MAN} ${WRKSRC}/${manpage} ${MANPREFIX}/man/man1
+.endfor
+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/moreutils/distinfo b/sysutils/moreutils/distinfo
new file mode 100644
index 000000000000..b571b119ff83
--- /dev/null
+++ b/sysutils/moreutils/distinfo
@@ -0,0 +1,3 @@
+MD5 (moreutils_0.35.tar.gz) = e3089831539284f740f0180ec589d079
+SHA256 (moreutils_0.35.tar.gz) = 8ac8467171c099a1c5b661f02286d59ba264c2034c77a30832015cc68f62ed2e
+SIZE (moreutils_0.35.tar.gz) = 37009
diff --git a/sysutils/moreutils/files/patch-Makefile b/sysutils/moreutils/files/patch-Makefile
new file mode 100644
index 000000000000..dbe99edc5221
--- /dev/null
+++ b/sysutils/moreutils/files/patch-Makefile
@@ -0,0 +1,37 @@
+--- Makefile.orig 2009-05-05 12:09:22.000000000 -0700
++++ Makefile 2009-06-20 07:59:27.000000000 -0700
+@@ -1,24 +1,24 @@
+-BINS=isutf8 ifdata ifne pee sponge mispipe lckdo
++BINS=isutf8 ifne pee sponge mispipe lckdo
+ PERLSCRIPTS=vidir vipe ts combine zrun
+-MANS=sponge.1 vidir.1 vipe.1 isutf8.1 ts.1 combine.1 ifdata.1 ifne.1 pee.1 zrun.1 mispipe.1 lckdo.1
++MANS=sponge.1 vidir.1 vipe.1 isutf8.1 ts.1 combine.1 ifne.1 pee.1 zrun.1 mispipe.1 lckdo.1
+ CFLAGS=-O2 -g -Wall
+ INSTALL_BIN?=install -s
+-PREFIX=/usr
+
+-DOCBOOK2XMAN=docbook2x-man
++DOCBOOK2XMAN=docbook2man
+
+ all: $(BINS) $(MANS)
+
++bins: $(BINS)
++
++mans: $(MANS)
++
+ clean:
+ rm -f $(BINS) $(MANS)
+
+ install:
+- mkdir -p $(DESTDIR)$(PREFIX)/bin
+- $(INSTALL_BIN) $(BINS) $(DESTDIR)$(PREFIX)/bin
+- install $(PERLSCRIPTS) $(DESTDIR)$(PREFIX)/bin
+-
+- mkdir -p $(DESTDIR)$(PREFIX)/share/man/man1
+- install $(MANS) $(DESTDIR)$(PREFIX)/share/man/man1
++ mkdir -p $(PREFIX)/bin
++ $(INSTALL_BIN) $(BINS) $(PREFIX)/bin
++ install $(PERLSCRIPTS) $(PREFIX)/bin
+
+ check: isutf8
+ ./check-isutf8
diff --git a/sysutils/moreutils/pkg-descr b/sysutils/moreutils/pkg-descr
new file mode 100644
index 000000000000..9dd72ae8be86
--- /dev/null
+++ b/sysutils/moreutils/pkg-descr
@@ -0,0 +1,18 @@
+moreutils is a growing collection of the unix tools that nobody thought to
+write thirty years ago.
+
+So far, it includes the following utilities:
+
+ - sponge: soak up standard input and write to a file
+ - ifne: run a program if the standard input is not empty
+ - vidir: edit a directory in your text editor
+ - vipe: insert a text editor into a pipe
+ - ts: timestamp standard input
+ - combine: combine the lines in two files using boolean operations
+ - pee: tee standard input to pipes
+ - zrun: automatically uncompress arguments to command
+ - mispipe: pipe two commands, returning the exit status of the first
+ - isutf8: check if a file or standard input is utf-8
+ - lckdo: execute a program with a lock held
+
+WWW: http://kitenet.net/~joey/code/moreutils/