aboutsummaryrefslogtreecommitdiff
path: root/sysutils/moreutils
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-02-28 15:15:55 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-02-28 15:15:55 +0000
commit322e65b5b9bce59bb7d235c98fdc27c593ffbe33 (patch)
tree64f231b37fc5c6dcea6f7ee2bbef268fc7cddb95 /sysutils/moreutils
parent337f9e9d28c7473c7d655c00ca6acbf1bba81ed0 (diff)
downloadports-322e65b5b9bce59bb7d235c98fdc27c593ffbe33.tar.gz
ports-322e65b5b9bce59bb7d235c98fdc27c593ffbe33.zip
Notes
Diffstat (limited to 'sysutils/moreutils')
-rw-r--r--sysutils/moreutils/Makefile40
-rw-r--r--sysutils/moreutils/distinfo4
-rw-r--r--sysutils/moreutils/files/errno.1139
-rw-r--r--sysutils/moreutils/files/ifne.192
-rw-r--r--sysutils/moreutils/files/isutf8.193
-rw-r--r--sysutils/moreutils/files/lckdo.1161
-rw-r--r--sysutils/moreutils/files/mispipe.178
-rw-r--r--sysutils/moreutils/files/patch-Makefile76
-rw-r--r--sysutils/moreutils/files/pee.174
-rw-r--r--sysutils/moreutils/files/sponge.176
10 files changed, 421 insertions, 412 deletions
diff --git a/sysutils/moreutils/Makefile b/sysutils/moreutils/Makefile
index 3dc022527070..f7b092af9a62 100644
--- a/sysutils/moreutils/Makefile
+++ b/sysutils/moreutils/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= moreutils
-PORTVERSION= 0.50
+PORTVERSION= 0.51
CATEGORIES= sysutils
MASTER_SITES= DEBIAN_POOL
DISTNAME= ${PORTNAME}_${PORTVERSION}
@@ -18,12 +18,10 @@ OPTIONS_DEFINE= MANPAGES
OPTIONS_DEFAULT=MANPAGES
OPTIONS_SUB= yes
-ALL_TARGET= bins
-USES= perl5
+ALL_TARGET= errnos.h ${CANNED_MANPAGES:R}
+USES= perl5 shebangfix
WRKSRC= ${WRKDIR}/${PORTNAME}
-MANPAGES_ALL_TARGET= mans
-
CANNED_MANPAGES=errno.1 \
ifne.1 \
isutf8.1 \
@@ -31,25 +29,35 @@ CANNED_MANPAGES=errno.1 \
mispipe.1 \
pee.1 \
sponge.1
-MANPAGES= chronic.1 \
+PERL_MANPAGES= chronic.1 \
combine.1 \
ts.1 \
vidir.1 \
vipe.1 \
- zrun.1 \
- ${CANNED_MANPAGES}
+ zrun.1
-.include <bsd.port.options.mk>
+SHEBANG_FILES= ${PERL_MANPAGES:R}
post-patch:
- @${REINPLACE_CMD} -e 's|share/xml/docbook/schema/dtd/|local/share/xml/docbook/|' ${WRKSRC}/*.docbook
-.if ${PORT_OPTIONS:MMANPAGES}
@cd ${FILESDIR}/ && ${CP} ${CANNED_MANPAGES} ${WRKSRC}/
-.endif
-post-install:
-.if ${PORT_OPTIONS:MMANPAGES}
- cd ${WRKSRC}/ && ${INSTALL_MAN} ${MANPAGES} ${STAGEDIR}${PREFIX}/man/man1/
-.endif
+post-build:
+.for man in ${PERL_MANPAGES:R}
+ ${LOCALBASE}/bin/pod2man --center=" " --release="${PORTNAME}" ${WRKSRC}/${man} > ${WRKSRC}/${man}.1
+.endfor
+
+do-install:
+ cd ${WRKSRC}/ && ${INSTALL_PROGRAM} ${CANNED_MANPAGES:R} ${STAGEDIR}${PREFIX}/bin/
+ cd ${WRKSRC}/ && ${INSTALL_SCRIPT} ${PERL_MANPAGES:R} ${STAGEDIR}${PREFIX}/bin/
+ cd ${WRKSRC}/ && ${INSTALL_MAN} ${CANNED_MANPAGES} ${PERL_MANPAGES} ${STAGEDIR}${PREFIX}/man/man1/
+
+# maintainer section:
+# require: docbook-xsl, libxml2, libxslt
+
+updateman: do-clean extract
+.for man in ${CANNED_MANPAGES:R}
+ ${LOCALBASE}/bin/xmllint --noout --valid ${WRKSRC}/${man}.docbook && \
+ ${LOCALBASE}/bin/xsltproc --output ${FILESDIR}/${man}.1 --param man.authors.section.enabled 0 ${LOCALBASE}/share/xsl/docbook/manpages/docbook.xsl ${WRKSRC}/${man}.docbook
+.endfor
.include <bsd.port.mk>
diff --git a/sysutils/moreutils/distinfo b/sysutils/moreutils/distinfo
index 825d23c48f82..5906aae83f89 100644
--- a/sysutils/moreutils/distinfo
+++ b/sysutils/moreutils/distinfo
@@ -1,2 +1,2 @@
-SHA256 (moreutils_0.50.tar.gz) = 4df833f17c2c6781c1d500ac51455af1929db5aeb96d06e45b00489393b37714
-SIZE (moreutils_0.50.tar.gz) = 46952
+SHA256 (moreutils_0.51.tar.gz) = 579e1e61f874d105ec3b6cf898a3ce7e487a58773a44769ce34c2fc7315cb141
+SIZE (moreutils_0.51.tar.gz) = 47404
diff --git a/sysutils/moreutils/files/errno.1 b/sysutils/moreutils/files/errno.1
index 85b2a946ba2b..6bcb6e233600 100644
--- a/sysutils/moreutils/files/errno.1
+++ b/sysutils/moreutils/files/errno.1
@@ -1,75 +1,72 @@
-.\" -*- coding: us-ascii -*-
-.if \n(.g .ds T< \\FC
-.if \n(.g .ds T> \\F[\n[.fam]]
-.de URL
-\\$2 \(la\\$1\(ra\\$3
-..
-.if \n(.g .mso www.tmac
-.TH errno 1 2012-06-05 "" ""
-.SH NAME
-errno \- look up errno names and descriptions
-.SH SYNOPSIS
-'nh
-.fi
-.ad l
-\fBerrno\fR \kx
-.if (\nx>(\n(.l/2)) .nr x (\n(.l/5)
-'in \n(.iu+\nxu
-{\fIname-or-code\fR}
-'in \n(.iu-\nxu
-.ad b
-'hy
-'nh
-.fi
-.ad l
-\fBerrno\fR \kx
-.if (\nx>(\n(.l/2)) .nr x (\n(.l/5)
-'in \n(.iu+\nxu
-[-ls] [--list]
-'in \n(.iu-\nxu
-.ad b
-'hy
-'nh
-.fi
-.ad l
-\fBerrno\fR \kx
-.if (\nx>(\n(.l/2)) .nr x (\n(.l/5)
-'in \n(.iu+\nxu
-[-s] [--search] {\fIword\fR}
-'in \n(.iu-\nxu
-.ad b
-'hy
-'nh
-.fi
+'\" t
+.\" Title: errno
+.\" Author: Lars Wirzenius
+.\" Generator: DocBook XSL Stylesheets v1.76.1 <http://docbook.sf.net/>
+.\" Date: 2012-06-05
+.\" Manual: moreutils
+.\" Source: moreutils
+.\" Language: English
+.\"
+.TH "ERRNO" "1" "2012\-06\-05" "moreutils" "moreutils"
+.\" -----------------------------------------------------------------
+.\" * Define some portability stuff
+.\" -----------------------------------------------------------------
+.\" ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+.\" http://bugs.debian.org/507673
+.\" http://lists.gnu.org/archive/html/groff/2009-02/msg00013.html
+.\" ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+.ie \n(.g .ds Aq \(aq
+.el .ds Aq '
+.\" -----------------------------------------------------------------
+.\" * set default formatting
+.\" -----------------------------------------------------------------
+.\" disable hyphenation
+.nh
+.\" disable justification (adjust text to left margin only)
.ad l
-\fBerrno\fR \kx
-.if (\nx>(\n(.l/2)) .nr x (\n(.l/5)
-'in \n(.iu+\nxu
-[-S] [--search-all-locales] {\fIword\fR}
-'in \n(.iu-\nxu
-.ad b
-'hy
-.SH DESCRIPTION
-\fBerrno\fR looks up errno macro names,
-errno codes, and the corresponding descriptions. For example,
-if given \*(T<ENOENT\*(T> on a Linux system, it
-prints out the code 2 and the description "No such file or directory".
-If given the code 2, it printes \*(T<ENOENT\*(T>
-and the same description.
-.SH OPTIONS
-.TP
-\*(T<\fB\-l\fR\*(T>, \*(T<\fB\-\-list\fR\*(T>
-List all errno values.
-.TP
-\*(T<\fB\-s\fR\*(T>, \*(T<\fB\-\-search\fR\*(T>
-Search for errors whose description contains
-all the given words (case-insensitive).
-.TP
-\*(T<\fB\-S\fR\*(T>, \*(T<\fB\-\-search\-all\-locales\fR\*(T>
-Like \*(T<\fB\-\-search\fR\*(T>, but searches all
-installed locales.
-.SH AUTHOR
+.\" -----------------------------------------------------------------
+.\" * MAIN CONTENT STARTS HERE *
+.\" -----------------------------------------------------------------
+.SH "NAME"
+errno \- look up errno names and descriptions
+.SH "SYNOPSIS"
+.HP \w'\fBerrno\fR\ 'u
+\fBerrno\fR {\fIname\-or\-code\fR}
+.HP \w'\fBerrno\fR\ 'u
+\fBerrno\fR [\-ls] [\-\-list]
+.HP \w'\fBerrno\fR\ 'u
+\fBerrno\fR [\-s] [\-\-search] {\fIword\fR}
+.HP \w'\fBerrno\fR\ 'u
+\fBerrno\fR [\-S] [\-\-search\-all\-locales] {\fIword\fR}
+.SH "DESCRIPTION"
+.PP
+\fBerrno\fR
+looks up errno macro names, errno codes, and the corresponding descriptions\&. For example, if given
+ENOENT
+on a Linux system, it prints out the code 2 and the description "No such file or directory"\&. If given the code 2, it printes
+ENOENT
+and the same description\&.
+.SH "OPTIONS"
+.PP
+\fB\-l\fR, \fB\-\-list\fR
+.RS 4
+List all errno values\&.
+.RE
+.PP
+\fB\-s\fR, \fB\-\-search\fR
+.RS 4
+Search for errors whose description contains all the given words (case\-insensitive)\&.
+.RE
+.PP
+\fB\-S\fR, \fB\-\-search\-all\-locales\fR
+.RS 4
+Like
+\fB\-\-search\fR, but searches all installed locales\&.
+.RE
+.SH "AUTHOR"
+.PP
Lars Wirzenius
-
.SH "SEE ALSO"
+.PP
+
\fBerrno\fR(3)
diff --git a/sysutils/moreutils/files/ifne.1 b/sysutils/moreutils/files/ifne.1
index 4d530760fec3..6afd169edcf7 100644
--- a/sysutils/moreutils/files/ifne.1
+++ b/sysutils/moreutils/files/ifne.1
@@ -1,44 +1,54 @@
-.\" -*- coding: us-ascii -*-
-.if \n(.g .ds T< \\FC
-.if \n(.g .ds T> \\F[\n[.fam]]
-.de URL
-\\$2 \(la\\$1\(ra\\$3
-..
-.if \n(.g .mso www.tmac
-.TH ifne 1 2008-05-01 "" ""
-.SH NAME
-ifne \- Run command if the standard input is not empty
-.SH SYNOPSIS
-'nh
-.fi
-.ad l
-\fBifne [-n] command\fR \kx
-.if (\nx>(\n(.l/2)) .nr x (\n(.l/5)
-'in \n(.iu+\nxu
-'in \n(.iu-\nxu
-.ad b
-'hy
-.SH DESCRIPTION
-\fBifne\fR runs the following command if and only if
-the standard input is not empty.
-.SH OPTIONS
-.TP
-\*(T<\fB\-n\fR\*(T>
-Reverse operation. Run the command if the standard input is empty.
-
-Note that if the standard input is not empty, it is passed through ifne
-in this case.
-.SH EXAMPLE
-'nh
-.fi
+'\" t
+.\" Title: ifne
+.\" Author: Javier Merino
+.\" Generator: DocBook XSL Stylesheets v1.76.1 <http://docbook.sf.net/>
+.\" Date: 2008-05-01
+.\" Manual: moreutils
+.\" Source: moreutils
+.\" Language: English
+.\"
+.TH "IFNE" "1" "2008\-05\-01" "moreutils" "moreutils"
+.\" -----------------------------------------------------------------
+.\" * Define some portability stuff
+.\" -----------------------------------------------------------------
+.\" ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+.\" http://bugs.debian.org/507673
+.\" http://lists.gnu.org/archive/html/groff/2009-02/msg00013.html
+.\" ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+.ie \n(.g .ds Aq \(aq
+.el .ds Aq '
+.\" -----------------------------------------------------------------
+.\" * set default formatting
+.\" -----------------------------------------------------------------
+.\" disable hyphenation
+.nh
+.\" disable justification (adjust text to left margin only)
.ad l
-\fBfind . -name core | ifne mail -s "Core files found" root\fR \kx
-.if (\nx>(\n(.l/2)) .nr x (\n(.l/5)
-'in \n(.iu+\nxu
-'in \n(.iu-\nxu
-.ad b
-'hy
-.SH AUTHOR
-Copyright 2008 by Javier Merino <cibervicho@gmail.com>
+.\" -----------------------------------------------------------------
+.\" * MAIN CONTENT STARTS HERE *
+.\" -----------------------------------------------------------------
+.SH "NAME"
+ifne \- Run command if the standard input is not empty
+.SH "SYNOPSIS"
+.HP \w'\fBifne\ [\-n]\ command\fR\ 'u
+\fBifne [\-n] command\fR
+.SH "DESCRIPTION"
+.PP
+\fBifne\fR
+runs the following command if and only if the standard input is not empty\&.
+.SH "OPTIONS"
+.PP
+\fB\-n\fR
+.RS 4
+Reverse operation\&. Run the command if the standard input is empty\&.
+.sp
+Note that if the standard input is not empty, it is passed through ifne in this case\&.
+.RE
+.SH "EXAMPLE"
+.HP \w'\fBfind\ \&.\ \-name\ core\ |\ ifne\ mail\ \-s\ "Core\ files\ found"\ root\fR\ 'u
+\fBfind \&. \-name core | ifne mail \-s "Core files found" root\fR
+.SH "AUTHOR"
+.PP
+Copyright 2008 by Javier Merino <cibervicho@gmail\&.com>
.PP
Licensed under the GNU GPL
diff --git a/sysutils/moreutils/files/isutf8.1 b/sysutils/moreutils/files/isutf8.1
index 71ac6e484022..79049b8f5dfb 100644
--- a/sysutils/moreutils/files/isutf8.1
+++ b/sysutils/moreutils/files/isutf8.1
@@ -1,44 +1,59 @@
-.\" -*- coding: us-ascii -*-
-.if \n(.g .ds T< \\FC
-.if \n(.g .ds T> \\F[\n[.fam]]
-.de URL
-\\$2 \(la\\$1\(ra\\$3
-..
-.if \n(.g .mso www.tmac
-.TH isutf8 1 2006-02-19 "" ""
-.SH NAME
-isutf8 \- check whether files are valid UTF-8
-.SH SYNOPSIS
-'nh
-.fi
+'\" t
+.\" Title: isutf8
+.\" Author: Lars Wirzenius
+.\" Generator: DocBook XSL Stylesheets v1.76.1 <http://docbook.sf.net/>
+.\" Date: 2006-02-19
+.\" Manual: moreutils
+.\" Source: moreutils
+.\" Language: English
+.\"
+.TH "ISUTF8" "1" "2006\-02\-19" "moreutils" "moreutils"
+.\" -----------------------------------------------------------------
+.\" * Define some portability stuff
+.\" -----------------------------------------------------------------
+.\" ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+.\" http://bugs.debian.org/507673
+.\" http://lists.gnu.org/archive/html/groff/2009-02/msg00013.html
+.\" ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+.ie \n(.g .ds Aq \(aq
+.el .ds Aq '
+.\" -----------------------------------------------------------------
+.\" * set default formatting
+.\" -----------------------------------------------------------------
+.\" disable hyphenation
+.nh
+.\" disable justification (adjust text to left margin only)
.ad l
-\fBisutf8\fR \kx
-.if (\nx>(\n(.l/2)) .nr x (\n(.l/5)
-'in \n(.iu+\nxu
-[\fB-hq\fR] [\fB--help\fR] [\fB--quiet\fR] [\fIfile\fR\&...]
-'in \n(.iu-\nxu
-.ad b
-'hy
-.SH DESCRIPTION
-\fBisutf8\fR checks whether files are
-syntactically valid UTF-8. Input is either files named on the
-command line, or the standard input. Notices about files with
-invalid UTF-8 are printed to standard output.
-.SH OPTIONS
-.TP
-\*(T<\fB\-h\fR\*(T>, \*(T<\fB\-\-help\fR\*(T>
-Print out a help summary.
-.TP
-\*(T<\fB\-q\fR\*(T>, \*(T<\fB\-\-quiet\fR\*(T>
-Don't print messages telling which files are
-invalid UTF-8, merely indicate it with the exit
-status.
+.\" -----------------------------------------------------------------
+.\" * MAIN CONTENT STARTS HERE *
+.\" -----------------------------------------------------------------
+.SH "NAME"
+isutf8 \- check whether files are valid UTF\-8
+.SH "SYNOPSIS"
+.HP \w'\fBisutf8\fR\ 'u
+\fBisutf8\fR [\fB\-hq\fR] [\fB\-\-help\fR] [\fB\-\-quiet\fR] [[\fIfile\fR...]]
+.SH "DESCRIPTION"
+.PP
+\fBisutf8\fR
+checks whether files are syntactically valid UTF\-8\&. Input is either files named on the command line, or the standard input\&. Notices about files with invalid UTF\-8 are printed to standard output\&.
+.SH "OPTIONS"
+.PP
+\fB\-h\fR, \fB\-\-help\fR
+.RS 4
+Print out a help summary\&.
+.RE
+.PP
+\fB\-q\fR, \fB\-\-quiet\fR
+.RS 4
+Don\*(Aqt print messages telling which files are invalid UTF\-8, merely indicate it with the exit status\&.
+.RE
.SH "EXIT STATUS"
-If the file is valid UTF-8, the exit status is zero.
-If the file is not valid UTF-8, or there is some
-error, the exit status is non-zero.
-.SH AUTHOR
+.PP
+If the file is valid UTF\-8, the exit status is zero\&. If the file is not valid UTF\-8, or there is some error, the exit status is non\-zero\&.
+.SH "AUTHOR"
+.PP
Lars Wirzenius
-
.SH "SEE ALSO"
+.PP
+
\fButf8\fR(7)
diff --git a/sysutils/moreutils/files/lckdo.1 b/sysutils/moreutils/files/lckdo.1
index d3dc928a37ca..745bbd7bc01a 100644
--- a/sysutils/moreutils/files/lckdo.1
+++ b/sysutils/moreutils/files/lckdo.1
@@ -1,72 +1,97 @@
-.\" -*- coding: us-ascii -*-
-.if \n(.g .ds T< \\FC
-.if \n(.g .ds T> \\F[\n[.fam]]
-.de URL
-\\$2 \(la\\$1\(ra\\$3
-..
-.if \n(.g .mso www.tmac
-.TH lckdo 1 2007-08-15 "" ""
-.SH NAME
-lckdo \- run a program with a lock held
-.SH SYNOPSIS
-'nh
-.fi
+'\" t
+.\" Title: lckdo
+.\" Author: Michael Tokarev
+.\" Generator: DocBook XSL Stylesheets v1.76.1 <http://docbook.sf.net/>
+.\" Date: 2007-08-15
+.\" Manual: moreutils
+.\" Source: moreutils
+.\" Language: English
+.\"
+.TH "LCKDO" "1" "2007\-08\-15" "moreutils" "moreutils"
+.\" -----------------------------------------------------------------
+.\" * Define some portability stuff
+.\" -----------------------------------------------------------------
+.\" ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+.\" http://bugs.debian.org/507673
+.\" http://lists.gnu.org/archive/html/groff/2009-02/msg00013.html
+.\" ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+.ie \n(.g .ds Aq \(aq
+.el .ds Aq '
+.\" -----------------------------------------------------------------
+.\" * set default formatting
+.\" -----------------------------------------------------------------
+.\" disable hyphenation
+.nh
+.\" disable justification (adjust text to left margin only)
.ad l
-\fBlckdo\fR \kx
-.if (\nx>(\n(.l/2)) .nr x (\n(.l/5)
-'in \n(.iu+\nxu
-[options] {lockfile} {program} [arguments]
-'in \n(.iu-\nxu
-.ad b
-'hy
-.SH DESCRIPTION
-\fBlckdo\fR runs a program with a lock
-held, in order to prevent multiple processes from running in
-parallel. Use just like \fBnice\fR or
-\fBnohup\fR.
+.\" -----------------------------------------------------------------
+.\" * MAIN CONTENT STARTS HERE *
+.\" -----------------------------------------------------------------
+.SH "NAME"
+lckdo \- run a program with a lock held
+.SH "SYNOPSIS"
+.HP \w'\fBlckdo\fR\ 'u
+\fBlckdo\fR [options] {lockfile} {program} [arguments]
+.SH "DESCRIPTION"
+.PP
+\fBlckdo\fR
+runs a program with a lock held, in order to prevent multiple processes from running in parallel\&. Use just like
+\fBnice\fR
+or
+\fBnohup\fR\&.
+.PP
+Now that util\-linux contains a similar command named
+\fBflock\fR, lckdo is deprecated, and will be removed from some future version of moreutils\&.
+.SH "OPTIONS"
+.PP
+\fB\-w\fR
+.RS 4
+If the lock is already held by another process, wait for it to complete instead of failing immediately\&.
+.RE
+.PP
+\fB\-W {sec}\fR
+.RS 4
+The same as \-w but wait not more than sec seconds\&.
+.RE
+.PP
+\fB\-e\fR
+.RS 4
+Execute the program directly without forking and waiting (keeps an extra file descriptor open)\&.
+.RE
.PP
-Now that util-linux contains a similar command
-named \fBflock\fR, lckdo is deprecated,
-and will be removed from some future version of moreutils.
-.SH OPTIONS
-.TP
-\*(T<\fB\-w\fR\*(T>
-If the lock is already held by another process,
-wait for it to complete instead of failing
-immediately.
-.TP
-\*(T<\fB\-W {sec}\fR\*(T>
-The same as -w but wait not more than sec
-seconds.
-.TP
-\*(T<\fB\-e\fR\*(T>
-Execute the program directly without forking and
-waiting (keeps an extra file descriptor open).
-.TP
-\*(T<\fB\-E {nnn}\fR\*(T>
-Set the file descriptor number to keep open when
-exec()ing (implies -e).
-.TP
-\*(T<\fB\-n\fR\*(T>
-Do not create the lock file if it does not
-exist.
-.TP
-\*(T<\fB\-q\fR\*(T>
-Produce no output if lock is already held.
-.TP
-\*(T<\fB\-s\fR\*(T>
-Lock in shared (read) mode.
-.TP
-\*(T<\fB\-x\fR\*(T>
-Lock in exclusive (write) mode (default).
-.TP
-\*(T<\fB\-t\fR\*(T>
-Test for lock existence.
+\fB\-E {nnn}\fR
+.RS 4
+Set the file descriptor number to keep open when exec()ing (implies \-e)\&.
+.RE
+.PP
+\fB\-n\fR
+.RS 4
+Do not create the lock file if it does not exist\&.
+.RE
+.PP
+\fB\-q\fR
+.RS 4
+Produce no output if lock is already held\&.
+.RE
+.PP
+\fB\-s\fR
+.RS 4
+Lock in shared (read) mode\&.
+.RE
+.PP
+\fB\-x\fR
+.RS 4
+Lock in exclusive (write) mode (default)\&.
+.RE
+.PP
+\fB\-t\fR
+.RS 4
+Test for lock existence\&.
+.RE
.SH "EXIT STATUS"
-If the lock was successfully acquired, the return value is that
-of the program invoked by \fBlckdo\fR. If the lock
-couldn't be acquired, EX_TEMPFAIL is returned. If there was a problem
-opening/creating or locking the lock file, EX_CANTCREAT or EX_OSERR
-will be returned.
-.SH AUTHOR
+.PP
+If the lock was successfully acquired, the return value is that of the program invoked by
+\fBlckdo\fR\&. If the lock couldn\*(Aqt be acquired, EX_TEMPFAIL is returned\&. If there was a problem opening/creating or locking the lock file, EX_CANTCREAT or EX_OSERR will be returned\&.
+.SH "AUTHOR"
+.PP
Michael Tokarev
diff --git a/sysutils/moreutils/files/mispipe.1 b/sysutils/moreutils/files/mispipe.1
index 89e43d1c4300..375994b3fe4d 100644
--- a/sysutils/moreutils/files/mispipe.1
+++ b/sysutils/moreutils/files/mispipe.1
@@ -1,39 +1,47 @@
-.\" -*- coding: us-ascii -*-
-.if \n(.g .ds T< \\FC
-.if \n(.g .ds T> \\F[\n[.fam]]
-.de URL
-\\$2 \(la\\$1\(ra\\$3
-..
-.if \n(.g .mso www.tmac
-.TH mispipe 1 2006-09-07 "" ""
-.SH NAME
-mispipe \- pipe two commands, returning the exit status of the first
-.SH SYNOPSIS
-'nh
-.fi
+'\" t
+.\" Title: mispipe
+.\" Author: Nathanael Nerode
+.\" Generator: DocBook XSL Stylesheets v1.76.1 <http://docbook.sf.net/>
+.\" Date: 2006-09-07
+.\" Manual: moreutils
+.\" Source: moreutils
+.\" Language: English
+.\"
+.TH "MISPIPE" "1" "2006\-09\-07" "moreutils" "moreutils"
+.\" -----------------------------------------------------------------
+.\" * Define some portability stuff
+.\" -----------------------------------------------------------------
+.\" ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+.\" http://bugs.debian.org/507673
+.\" http://lists.gnu.org/archive/html/groff/2009-02/msg00013.html
+.\" ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+.ie \n(.g .ds Aq \(aq
+.el .ds Aq '
+.\" -----------------------------------------------------------------
+.\" * set default formatting
+.\" -----------------------------------------------------------------
+.\" disable hyphenation
+.nh
+.\" disable justification (adjust text to left margin only)
.ad l
-\fBmispipe\fR \kx
-.if (\nx>(\n(.l/2)) .nr x (\n(.l/5)
-'in \n(.iu+\nxu
-[\fI"command1"\fR] [\fI"command2"\fR]
-'in \n(.iu-\nxu
-.ad b
-'hy
-.SH DESCRIPTION
-\fBmispipe\fR pipes two commands
-together like the shell does, but unlike piping in the
-shell, which returns the exit status of the last command;
-when using mispipe, the exit status of the first command
-is returned.
+.\" -----------------------------------------------------------------
+.\" * MAIN CONTENT STARTS HERE *
+.\" -----------------------------------------------------------------
+.SH "NAME"
+mispipe \- pipe two commands, returning the exit status of the first
+.SH "SYNOPSIS"
+.HP \w'\fBmispipe\fR\ 'u
+\fBmispipe\fR [\fI"command1"\fR] [\fI"command2"\fR]
+.SH "DESCRIPTION"
+.PP
+\fBmispipe\fR
+pipes two commands together like the shell does, but unlike piping in the shell, which returns the exit status of the last command; when using mispipe, the exit status of the first command is returned\&.
.PP
-Note that some shells, notably \fBbash\fR,
-do offer a pipefail option, however, that option does not
-behave the same since it makes a failure of any command in
-the pipeline be returned, not just the exit status of the
-first.
+Note that some shells, notably
+\fBbash\fR, do offer a pipefail option, however, that option does not behave the same since it makes a failure of any command in the pipeline be returned, not just the exit status of the first\&.
.SH "EXIT STATUS"
-The exit status of the first command. If the process
-terminated abnormally (due to a signal), 128 will be added
-to its exit status.
-.SH AUTHOR
+.PP
+The exit status of the first command\&. If the process terminated abnormally (due to a signal), 128 will be added to its exit status\&.
+.SH "AUTHOR"
+.PP
Nathanael Nerode
diff --git a/sysutils/moreutils/files/patch-Makefile b/sysutils/moreutils/files/patch-Makefile
deleted file mode 100644
index a1ae5b87de4f..000000000000
--- a/sysutils/moreutils/files/patch-Makefile
+++ /dev/null
@@ -1,76 +0,0 @@
---- Makefile.orig 2012-06-06 01:55:53.000000000 +0800
-+++ Makefile 2013-02-24 13:23:52.068205829 +0800
-@@ -1,14 +1,17 @@
--BINS=isutf8 ifdata ifne pee sponge mispipe lckdo parallel errno
-+BINS=isutf8 ifne pee sponge mispipe lckdo errno
- PERLSCRIPTS=vidir vipe ts combine zrun chronic
--MANS=sponge.1 vidir.1 vipe.1 isutf8.1 ts.1 combine.1 ifdata.1 ifne.1 pee.1 zrun.1 chronic.1 mispipe.1 lckdo.1 parallel.1 errno.1
--CFLAGS?=-O2 -g -Wall
-+MANS=sponge.1 isutf8.1 ifne.1 pee.1 mispipe.1 lckdo.1 errno.1
-+CFLAGS+=-Wall
- INSTALL_BIN?=install -s
--PREFIX?=/usr
-
--DOCBOOK2XMAN=docbook2x-man
-+.SUFFIXES: .1 .docbook
-+
-+DOCBOOK2XMAN=${LOCALBASE}/bin/docbook2man
-
- all: $(BINS) $(MANS)
-
-+bins: errnos.h ${BINS}
-+
- clean:
- rm -f $(BINS) $(MANS) dump.c errnos.h errno.o
-
-@@ -17,44 +20,19 @@
- $(INSTALL_BIN) $(BINS) $(DESTDIR)$(PREFIX)/bin
- install $(PERLSCRIPTS) $(DESTDIR)$(PREFIX)/bin
-
-- mkdir -p $(DESTDIR)$(PREFIX)/share/man/man1
-- install $(MANS) $(DESTDIR)$(PREFIX)/share/man/man1
--
- check: isutf8
- ./check-isutf8
-
--isutf8.1: isutf8.docbook
-- $(DOCBOOK2XMAN) $<
--
--ifdata.1: ifdata.docbook
-- $(DOCBOOK2XMAN) $<
--
--ifne.1: ifne.docbook
-- $(DOCBOOK2XMAN) $<
--
--pee.1: pee.docbook
-- $(DOCBOOK2XMAN) $<
-+.docbook.1:
-+ $(DOCBOOK2XMAN) ${.IMPSRC}
-
--sponge.1: sponge.docbook
-- $(DOCBOOK2XMAN) $<
--
--mispipe.1: mispipe.docbook
-- $(DOCBOOK2XMAN) $<
--
--lckdo.1: lckdo.docbook
-- $(DOCBOOK2XMAN) $<
--
--parallel.1: parallel.docbook
-- $(DOCBOOK2XMAN) $<
--
- errno.o: errnos.h
- errnos.h:
- echo '#include <errno.h>' > dump.c
- $(CC) -E -dD dump.c | awk '/^#define E/ { printf "{\"%s\",%s},\n", $$2, $$2 }' > errnos.h
- rm -f dump.c
-
--errno.1: errno.docbook
-- $(DOCBOOK2XMAN) $<
--
--%.1: %
-- pod2man --center=" " --release="moreutils" $< > $@;
-+mans: ${PERLSCRIPTS}
-+.for i in ${PERLSCRIPTS}
-+ pod2man --center=" " --release="moreutils" ${i} > ${i}.1
-+.endfor
diff --git a/sysutils/moreutils/files/pee.1 b/sysutils/moreutils/files/pee.1
index e6f889f250f9..026a8650479e 100644
--- a/sysutils/moreutils/files/pee.1
+++ b/sysutils/moreutils/files/pee.1
@@ -1,35 +1,51 @@
-.\" -*- coding: us-ascii -*-
-.if \n(.g .ds T< \\FC
-.if \n(.g .ds T> \\F[\n[.fam]]
-.de URL
-\\$2 \(la\\$1\(ra\\$3
-..
-.if \n(.g .mso www.tmac
-.TH pee 1 2006-03-14 "" ""
-.SH NAME
-pee \- tee standard input to pipes
-.SH SYNOPSIS
-'nh
-.fi
+'\" t
+.\" Title: pee
+.\" Author: Joey Hess
+.\" Generator: DocBook XSL Stylesheets v1.76.1 <http://docbook.sf.net/>
+.\" Date: 2006-03-14
+.\" Manual: moreutils
+.\" Source: moreutils
+.\" Language: English
+.\"
+.TH "PEE" "1" "2006\-03\-14" "moreutils" "moreutils"
+.\" -----------------------------------------------------------------
+.\" * Define some portability stuff
+.\" -----------------------------------------------------------------
+.\" ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+.\" http://bugs.debian.org/507673
+.\" http://lists.gnu.org/archive/html/groff/2009-02/msg00013.html
+.\" ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+.ie \n(.g .ds Aq \(aq
+.el .ds Aq '
+.\" -----------------------------------------------------------------
+.\" * set default formatting
+.\" -----------------------------------------------------------------
+.\" disable hyphenation
+.nh
+.\" disable justification (adjust text to left margin only)
.ad l
-\fBpee\fR \kx
-.if (\nx>(\n(.l/2)) .nr x (\n(.l/5)
-'in \n(.iu+\nxu
-[\fI"command"\fR\&...]
-'in \n(.iu-\nxu
-.ad b
-'hy
-.SH DESCRIPTION
-\fBpee\fR is like \fBtee\fR
-but for pipes. Each command is run and fed a copy of the
-standard input. The output of all commands is sent to
-stdout.
+.\" -----------------------------------------------------------------
+.\" * MAIN CONTENT STARTS HERE *
+.\" -----------------------------------------------------------------
+.SH "NAME"
+pee \- tee standard input to pipes
+.SH "SYNOPSIS"
+.HP \w'\fBpee\fR\ 'u
+\fBpee\fR [[\fI"command"\fR...]]
+.SH "DESCRIPTION"
+.PP
+\fBpee\fR
+is like
+\fBtee\fR
+but for pipes\&. Each command is run and fed a copy of the standard input\&. The output of all commands is sent to stdout\&.
.PP
Note that while this is similar to
-\fBtee\fR, a copy of the input is not sent
-to stdout, like tee does. If that is desired, use
-\fBpee cat ...\fR
+\fBtee\fR, a copy of the input is not sent to stdout, like tee does\&. If that is desired, use
+\fBpee cat \&.\&.\&.\fR
.SH "SEE ALSO"
+.PP
+
\fBtee\fR(1)
-.SH AUTHOR
+.SH "AUTHOR"
+.PP
Miek Gieben
diff --git a/sysutils/moreutils/files/sponge.1 b/sysutils/moreutils/files/sponge.1
index 75e31d474d96..3f74fe959c7d 100644
--- a/sysutils/moreutils/files/sponge.1
+++ b/sysutils/moreutils/files/sponge.1
@@ -1,39 +1,45 @@
-.\" -*- coding: us-ascii -*-
-.if \n(.g .ds T< \\FC
-.if \n(.g .ds T> \\F[\n[.fam]]
-.de URL
-\\$2 \(la\\$1\(ra\\$3
-..
-.if \n(.g .mso www.tmac
-.TH sponge 1 2006-02-19 "" ""
-.SH NAME
-sponge \- soak up standard input and write to a file
-.SH SYNOPSIS
-'nh
-.fi
+'\" t
+.\" Title: sponge
+.\" Author: Joey Hess
+.\" Generator: DocBook XSL Stylesheets v1.76.1 <http://docbook.sf.net/>
+.\" Date: 2006-02-19
+.\" Manual: moreutils
+.\" Source: moreutils
+.\" Language: English
+.\"
+.TH "SPONGE" "1" "2006\-02\-19" "moreutils" "moreutils"
+.\" -----------------------------------------------------------------
+.\" * Define some portability stuff
+.\" -----------------------------------------------------------------
+.\" ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+.\" http://bugs.debian.org/507673
+.\" http://lists.gnu.org/archive/html/groff/2009-02/msg00013.html
+.\" ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+.ie \n(.g .ds Aq \(aq
+.el .ds Aq '
+.\" -----------------------------------------------------------------
+.\" * set default formatting
+.\" -----------------------------------------------------------------
+.\" disable hyphenation
+.nh
+.\" disable justification (adjust text to left margin only)
.ad l
-\fBsed '...' file | grep '...' | sponge file\fR \kx
-.if (\nx>(\n(.l/2)) .nr x (\n(.l/5)
-'in \n(.iu+\nxu
-'in \n(.iu-\nxu
-.ad b
-'hy
-.SH DESCRIPTION
-\fBsponge\fR reads standard input and
-writes it out to the specified file. Unlike a shell
-redirect, sponge soaks up all its input before
-opening the output file. This allows constructing
-pipelines that read from and write to
-the same file.
+.\" -----------------------------------------------------------------
+.\" * MAIN CONTENT STARTS HERE *
+.\" -----------------------------------------------------------------
+.SH "NAME"
+sponge \- soak up standard input and write to a file
+.SH "SYNOPSIS"
+.HP \w'\fBsed\ \*(Aq\&.\&.\&.\*(Aq\ file\ |\ grep\ \*(Aq\&.\&.\&.\*(Aq\ |\ sponge\ file\fR\ 'u
+\fBsed \*(Aq\&.\&.\&.\*(Aq file | grep \*(Aq\&.\&.\&.\*(Aq | sponge file\fR
+.SH "DESCRIPTION"
+.PP
+\fBsponge\fR
+reads standard input and writes it out to the specified file\&. Unlike a shell redirect, sponge soaks up all its input before opening the output file\&. This allows constructing pipelines that read from and write to the same file\&.
+.PP
+It also creates the output file atomically by renaming a temp file into place, and preserves the permissions of the output file if it already exists\&. If the output file is a special file or symlink, the data will be written to it\&.
.PP
-It also creates the output file
-atomically by renaming a temp file into place,
-and preserves the permissions of the output file
-if it already exists.
-If the output file is a special file or symlink,
-the data will be written to it.
+If no output file is specified, sponge outputs to stdout\&.
+.SH "AUTHOR"
.PP
-If no output file is specified, sponge outputs to
-stdout.
-.SH AUTHOR
Colin Watson and Tollef Fog Heen