aboutsummaryrefslogtreecommitdiff
path: root/sysutils/moreutils
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2010-02-12 09:23:58 +0000
committerPav Lucistnik <pav@FreeBSD.org>2010-02-12 09:23:58 +0000
commitacf3097b941f11b5189c2f07e705f8b8f2bdac88 (patch)
tree2e85c8da2fd962acc3d733f624307193e5510699 /sysutils/moreutils
parentf43e33bcd69a53e3d2c8a6222adacdc381c503ca (diff)
Notes
Diffstat (limited to 'sysutils/moreutils')
-rw-r--r--sysutils/moreutils/Makefile3
-rw-r--r--sysutils/moreutils/distinfo6
-rw-r--r--sysutils/moreutils/files/patch-Makefile2
-rw-r--r--sysutils/moreutils/files/patch-parallel.c21
4 files changed, 16 insertions, 16 deletions
diff --git a/sysutils/moreutils/Makefile b/sysutils/moreutils/Makefile
index a44bf451cba8..5a74336b5969 100644
--- a/sysutils/moreutils/Makefile
+++ b/sysutils/moreutils/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= moreutils
-PORTVERSION= 0.37
-PORTREVISION= 2
+PORTVERSION= 0.38
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_DEBIAN_POOL}
DISTNAME= ${PORTNAME}_${PORTVERSION}
diff --git a/sysutils/moreutils/distinfo b/sysutils/moreutils/distinfo
index 339033a0d546..d85745f2a3a0 100644
--- a/sysutils/moreutils/distinfo
+++ b/sysutils/moreutils/distinfo
@@ -1,3 +1,3 @@
-MD5 (moreutils_0.37.tar.gz) = 0efb69ef1e913ea4dabc74bfe0e68372
-SHA256 (moreutils_0.37.tar.gz) = 21b5dcf61c1cdf2b479613e5fd4c4652780ba2be872c9631d4493fa74f30eb50
-SIZE (moreutils_0.37.tar.gz) = 39445
+MD5 (moreutils_0.38.tar.gz) = 34f29dc728ead3cae50411e7d158a493
+SHA256 (moreutils_0.38.tar.gz) = 26223e8ac1fe9906dcc0e2e4395d510146001fe285e9f786e80daab8acb237c3
+SIZE (moreutils_0.38.tar.gz) = 40426
diff --git a/sysutils/moreutils/files/patch-Makefile b/sysutils/moreutils/files/patch-Makefile
index dc3639fdc515..ae04c59a5631 100644
--- a/sysutils/moreutils/files/patch-Makefile
+++ b/sysutils/moreutils/files/patch-Makefile
@@ -1,5 +1,5 @@
--- Makefile.orig 2009-07-02 12:00:44.000000000 -0700
-+++ Makefile 2009-11-07 12:51:25.000000000 -0800
++++ Makefile 2010-02-09 22:13:14.000000000 -0800
@@ -1,51 +1,34 @@
-BINS=isutf8 ifdata ifne pee sponge mispipe lckdo parallel
+BINS=isutf8 ifne pee sponge mispipe lckdo parallel
diff --git a/sysutils/moreutils/files/patch-parallel.c b/sysutils/moreutils/files/patch-parallel.c
index 11c8af17d209..55a1ae47e8de 100644
--- a/sysutils/moreutils/files/patch-parallel.c
+++ b/sysutils/moreutils/files/patch-parallel.c
@@ -1,6 +1,6 @@
---- parallel.c.orig 2009-07-25 00:59:37.000000000 -0700
-+++ parallel.c 2009-09-19 15:41:07.000000000 -0700
-@@ -64,6 +64,7 @@
+--- parallel.c.orig 2010-02-09 12:39:08.000000000 -0800
++++ parallel.c 2010-02-09 22:27:25.000000000 -0800
+@@ -76,6 +76,7 @@
return;
}
@@ -8,21 +8,22 @@
int wait_for_child(int options) {
id_t id_ignored = 0;
siginfo_t infop;
-@@ -76,6 +77,17 @@
+@@ -88,6 +89,18 @@
return infop.si_status;
return 1;
}
+#else
+int wait_for_child(int options) {
-+ int status;
++ int status;
+
-+ if(waitpid(-1, &status, options) == -1)
-+ return -1; /* nothing to wait for */
-+ if(WIFEXITED(status))
-+ return WEXITSTATUS(status);
-+ return 1;
++ if(waitpid(-1, &status, options) == -1)
++ return -1; /* nothing to wait for */
++ if(WIFEXITED(status))
++ return WEXITSTATUS(status);
++ return 1;
+}
+#endif
++
int main(int argc, char **argv) {
int maxjobs = -1;