aboutsummaryrefslogtreecommitdiff
path: root/sysutils/moreutils
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-04-26 18:11:23 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-04-26 18:11:23 +0000
commita7c7693a22ba087b321c5ecb97c756362176df0c (patch)
tree5558614ff8f4ded0e3ad9cffc8f24845b09f56d5 /sysutils/moreutils
parent0a5466e038257f17647d904e194b80765ac14237 (diff)
downloadports-a7c7693a22ba087b321c5ecb97c756362176df0c.tar.gz
ports-a7c7693a22ba087b321c5ecb97c756362176df0c.zip
Notes
Diffstat (limited to 'sysutils/moreutils')
-rw-r--r--sysutils/moreutils/Makefile4
-rw-r--r--sysutils/moreutils/files/ifdata.1200
-rw-r--r--sysutils/moreutils/pkg-descr16
-rw-r--r--sysutils/moreutils/pkg-plist2
4 files changed, 214 insertions, 8 deletions
diff --git a/sysutils/moreutils/Makefile b/sysutils/moreutils/Makefile
index ab4c786e79de..f15e9f4cf852 100644
--- a/sysutils/moreutils/Makefile
+++ b/sysutils/moreutils/Makefile
@@ -3,7 +3,7 @@
PORTNAME= moreutils
PORTVERSION= 0.51
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
MASTER_SITES= DEBIAN_POOL
DISTNAME= ${PORTNAME}_${PORTVERSION}
@@ -24,6 +24,7 @@ USES= perl5 shebangfix
WRKSRC= ${WRKDIR}/${PORTNAME}
CANNED_MANPAGES=errno.1 \
+ ifdata.1 \
ifne.1 \
isutf8.1 \
lckdo.1 \
@@ -40,6 +41,7 @@ PERL_MANPAGES= chronic.1 \
SHEBANG_FILES= ${PERL_MANPAGES:R}
post-patch:
+ @${REINPLACE_CMD} -e 's|__APPLE__|__FreeBSD__|' ${WRKSRC}/ifdata.c
@cd ${FILESDIR}/ && ${CP} ${CANNED_MANPAGES} ${WRKSRC}/
post-build:
diff --git a/sysutils/moreutils/files/ifdata.1 b/sysutils/moreutils/files/ifdata.1
new file mode 100644
index 000000000000..3f8767557842
--- /dev/null
+++ b/sysutils/moreutils/files/ifdata.1
@@ -0,0 +1,200 @@
+'\" t
+.\" Title: ifdata
+.\" Author: Joey Hess
+.\" Generator: DocBook XSL Stylesheets v1.76.1 <http://docbook.sf.net/>
+.\" Date: 2006-03-07
+.\" Manual: moreutils
+.\" Source: moreutils
+.\" Language: English
+.\"
+.TH "IFDATA" "1" "2006\-03\-07" "moreutils" "moreutils"
+.\" -----------------------------------------------------------------
+.\" * Define some portability stuff
+.\" -----------------------------------------------------------------
+.\" ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+.\" http://bugs.debian.org/507673
+.\" http://lists.gnu.org/archive/html/groff/2009-02/msg00013.html
+.\" ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+.ie \n(.g .ds Aq \(aq
+.el .ds Aq '
+.\" -----------------------------------------------------------------
+.\" * set default formatting
+.\" -----------------------------------------------------------------
+.\" disable hyphenation
+.nh
+.\" disable justification (adjust text to left margin only)
+.ad l
+.\" -----------------------------------------------------------------
+.\" * MAIN CONTENT STARTS HERE *
+.\" -----------------------------------------------------------------
+.SH "NAME"
+ifdata \- get network interface info without parsing ifconfig output
+.SH "SYNOPSIS"
+.HP \w'\fBifdata\fR\ 'u
+\fBifdata\fR [options] {\fIiface\fR}
+.SH "DESCRIPTION"
+.PP
+
+\fBifdata\fR
+can be used to check for the existence of a network interface, or to get information abut the interface, such as its IP address\&. Unlike
+\fBifconfig\fR
+or
+\fBip\fR,
+\fBifdata\fR
+has simple to parse output that is designed to be easily used by a shell script\&.
+.SH "OPTIONS"
+.PP
+\fB\-h\fR
+.RS 4
+Print out a help summary\&.
+.RE
+.PP
+\fB\-e\fR
+.RS 4
+Test to see if the interface exists, exit nonzero if it does not\&.
+.RE
+.PP
+\fB\-p\fR
+.RS 4
+Prints out the whole configuration of the interface\&.
+.RE
+.PP
+\fB\-pe\fR
+.RS 4
+Prints "yes" or "no" if the interface exists or not\&.
+.RE
+.PP
+\fB\-pa\fR
+.RS 4
+Prints the IPv4 address of the interface\&.
+.RE
+.PP
+\fB\-pn\fR
+.RS 4
+Prints the netmask of the interface\&.
+.RE
+.PP
+\fB\-pN\fR
+.RS 4
+Prints the network address of the interface\&.
+.RE
+.PP
+\fB\-pb\fR
+.RS 4
+Prints the broadcast address of the interface\&.
+.RE
+.PP
+\fB\-pm\fR
+.RS 4
+Prints the MTU of the interface\&.
+.RE
+.PP
+Following options are Linux only\&.
+.PP
+\fB\-ph\fR
+.RS 4
+Prints the hardware address of the interface\&.
+.RE
+.PP
+\fB\-pf\fR
+.RS 4
+Prints the flags of the interface\&.
+.RE
+.PP
+\fB\-si\fR
+.RS 4
+Prints out all the input statistics of the interface\&.
+.RE
+.PP
+\fB\-sip\fR
+.RS 4
+Prints the number of input packets\&.
+.RE
+.PP
+\fB\-sib\fR
+.RS 4
+Prints the number of input bytes\&.
+.RE
+.PP
+\fB\-sie\fR
+.RS 4
+Prints the number of input errors\&.
+.RE
+.PP
+\fB\-sid\fR
+.RS 4
+Prints the number of dropped input packets\&.
+.RE
+.PP
+\fB\-sif\fR
+.RS 4
+Prints the number of input fifo overruns\&.
+.RE
+.PP
+\fB\-sic\fR
+.RS 4
+Print the number of compressed input packets\&.
+.RE
+.PP
+\fB\-sim\fR
+.RS 4
+Prints the number of input multicast packets\&.
+.RE
+.PP
+\fB\-so\fR
+.RS 4
+Prints out all the output statistics of the interface\&.
+.RE
+.PP
+\fB\-sop\fR
+.RS 4
+Prints the number of output packets\&.
+.RE
+.PP
+\fB\-sob\fR
+.RS 4
+Prints the number of output bytes\&.
+.RE
+.PP
+\fB\-soe\fR
+.RS 4
+Prints the number of output errors\&.
+.RE
+.PP
+\fB\-sod\fR
+.RS 4
+Prints the number of dropped output packets\&.
+.RE
+.PP
+\fB\-sof\fR
+.RS 4
+Prints the number of output fifo overruns\&.
+.RE
+.PP
+\fB\-sox\fR
+.RS 4
+Print the number of output collisions\&.
+.RE
+.PP
+\fB\-soc\fR
+.RS 4
+Prints the number of output carrier losses\&.
+.RE
+.PP
+\fB\-som\fR
+.RS 4
+Prints the number of output multicast packets\&.
+.RE
+.PP
+\fB\-bips\fR
+.RS 4
+Prints the number of bytes of incoming traffic measured in one second\&.
+.RE
+.PP
+\fB\-bops\fR
+.RS 4
+Prints the number of bytes of outgoing traffic measured in one second\&.
+.RE
+.SH "AUTHOR"
+.PP
+Benjamin BAYART
diff --git a/sysutils/moreutils/pkg-descr b/sysutils/moreutils/pkg-descr
index 0d0da88d1a58..3a46b5887eca 100644
--- a/sysutils/moreutils/pkg-descr
+++ b/sysutils/moreutils/pkg-descr
@@ -1,12 +1,14 @@
-moreutils is a growing collection of the unix tools that nobody thought to
-write thirty years ago.
+This is a collection of the unix tools that nobody thought to write long ago,
+when unix was young.
-So far, it includes the following utilities:
-- chronic: run a command quietly, unless it fails
+Currently it consists of these tools:
+- chronic: runs a command quietly unless it fails
- combine: combine the lines in two files using boolean operations
-- ifne: run a program if the standard input is not empty
+- errno: look up errno names and descriptions
+- ifdata: get network interface info without parsing ifconfig output
+- ifne: run a command if the standard input is not empty
- isutf8: check if a file or standard input is utf-8
-- lckdo: execute a program with a lock held
+- lckdo: execute a program with a lock held (deprecated)
- mispipe: pipe two commands, returning the exit status of the first
- pee: tee standard input to pipes
- sponge: soak up standard input and write to a file
@@ -15,6 +17,6 @@ So far, it includes the following utilities:
- vipe: insert a text editor into a pipe
- zrun: automatically uncompress arguments to command
-The Linux-specific 'ifdata' utility is not included in this FreeBSD port.
+The 'parallel' utility is split into sysutils/moreutils-parallel.
WWW: http://joeyh.name/code/moreutils/
diff --git a/sysutils/moreutils/pkg-plist b/sysutils/moreutils/pkg-plist
index 899f1660c3cd..200f33a8695d 100644
--- a/sysutils/moreutils/pkg-plist
+++ b/sysutils/moreutils/pkg-plist
@@ -1,6 +1,7 @@
bin/chronic
bin/combine
bin/errno
+bin/ifdata
bin/ifne
bin/isutf8
bin/lckdo
@@ -14,6 +15,7 @@ bin/zrun
%%MANPAGES%%man/man1/chronic.1.gz
%%MANPAGES%%man/man1/combine.1.gz
%%MANPAGES%%man/man1/errno.1.gz
+%%MANPAGES%%man/man1/ifdata.1.gz
%%MANPAGES%%man/man1/ifne.1.gz
%%MANPAGES%%man/man1/isutf8.1.gz
%%MANPAGES%%man/man1/lckdo.1.gz