aboutsummaryrefslogtreecommitdiff
path: root/sysutils/mptd
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2013-10-24 11:35:03 +0000
committerMark Felder <feld@FreeBSD.org>2013-10-24 11:35:03 +0000
commitc2e2766a2c3a4afe59623c5cc4afad9863f0d0bf (patch)
tree0b0b3cd6b26222413ffafaf08567b1c9d7c0d431 /sysutils/mptd
parentb9f534fd683e4ad77e48a232d83e95f68fbd5010 (diff)
downloadports-c2e2766a2c3a4afe59623c5cc4afad9863f0d0bf.tar.gz
ports-c2e2766a2c3a4afe59623c5cc4afad9863f0d0bf.zip
Notes
Diffstat (limited to 'sysutils/mptd')
-rw-r--r--sysutils/mptd/Makefile4
-rw-r--r--sysutils/mptd/files/mptd.in4
2 files changed, 4 insertions, 4 deletions
diff --git a/sysutils/mptd/Makefile b/sysutils/mptd/Makefile
index ca907af60aef..dcb8686d8543 100644
--- a/sysutils/mptd/Makefile
+++ b/sysutils/mptd/Makefile
@@ -3,6 +3,7 @@
PORTNAME= mptd
PORTVERSION= 0.01
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= https://www.glenbarber.us/ports/${CATEGORIES}/${PORTNAME}/
@@ -12,8 +13,7 @@ COMMENT= Monitoring daemon for mpt RAID controllers
USE_RC_SUBR= mptd
PLIST_FILES+= sbin/mptd
-NO_STAGE= yes
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/mptd ${PREFIX}/sbin/mptd
+ ${INSTALL_PROGRAM} ${WRKSRC}/mptd ${STAGEDIR}${PREFIX}/sbin/mptd
.include <bsd.port.mk>
diff --git a/sysutils/mptd/files/mptd.in b/sysutils/mptd/files/mptd.in
index 34d1739f9693..4e091d53365e 100644
--- a/sysutils/mptd/files/mptd.in
+++ b/sysutils/mptd/files/mptd.in
@@ -19,9 +19,9 @@ stop_cmd="killall -9 mptd > /dev/null 2>&1"
mptd_start()
{
- if [ -x "%%PREFIX%%/bin/mptd" -a -e "/dev/mpt0" ]; then
+ if [ -x "%%PREFIX%%/sbin/mptd" -a -e "/dev/mpt0" ]; then
echo "Starting mptd."
- %%PREFIX%%/bin/mptd ${raid_alert_mailto}
+ %%PREFIX%%/sbin/mptd ${raid_alert_mailto}
fi
}