aboutsummaryrefslogtreecommitdiff
path: root/sysutils/msyslog
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2005-09-15 12:01:48 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2005-09-15 12:01:48 +0000
commit1ebf65b052f8807dc25dd84b086e06bb5c4097fd (patch)
tree865e03b16a925580959b057bca7bf21fb44c74ef /sysutils/msyslog
parentec4e450528d55f292c4a96cfb5f30f092cb90463 (diff)
downloadports-1ebf65b052f8807dc25dd84b086e06bb5c4097fd.tar.gz
ports-1ebf65b052f8807dc25dd84b086e06bb5c4097fd.zip
- Update to 1.08g
- Simplify Makefile - Add OPTIONS support - Pass maintainership to submitter PR: ports/86151 Submitted by: Andrej Zverev <az@inec.ru>
Notes
Notes: svn path=/head/; revision=142810
Diffstat (limited to 'sysutils/msyslog')
-rw-r--r--sysutils/msyslog/Makefile102
-rw-r--r--sysutils/msyslog/distinfo4
-rw-r--r--sysutils/msyslog/files/msyslog.sh.sample20
-rw-r--r--sysutils/msyslog/files/msyslogd.sh.in47
-rw-r--r--sysutils/msyslog/files/patch-configure13
-rw-r--r--sysutils/msyslog/files/patch-im_tcp.c22
-rw-r--r--sysutils/msyslog/files/patch-im_udp.c14
-rw-r--r--sysutils/msyslog/files/patch-im_unix.c14
-rw-r--r--sysutils/msyslog/files/patch-ip_misc.c15
-rw-r--r--sysutils/msyslog/files/patch-md5.h11
-rw-r--r--sysutils/msyslog/files/patch-rmd160.h11
-rw-r--r--sysutils/msyslog/files/patch-sha1.h11
-rw-r--r--sysutils/msyslog/files/patch-src-Makefile.in12
-rw-r--r--sysutils/msyslog/files/patch-src-config.h.in154
-rw-r--r--sysutils/msyslog/files/patch-src-modules-Makefile.in11
-rw-r--r--sysutils/msyslog/pkg-descr2
-rw-r--r--sysutils/msyslog/pkg-message17
-rw-r--r--sysutils/msyslog/pkg-plist41
18 files changed, 156 insertions, 365 deletions
diff --git a/sysutils/msyslog/Makefile b/sysutils/msyslog/Makefile
index 4056ec9490ae..0600b3b02177 100644
--- a/sysutils/msyslog/Makefile
+++ b/sysutils/msyslog/Makefile
@@ -6,83 +6,61 @@
#
PORTNAME= msyslog
-PORTVERSION= 1.08f
-PORTREVISION= 3
+PORTVERSION= 1.08g
CATEGORIES= sysutils
-MASTER_SITES= http://www1.corest.com/download/msyslog/ \
- ftp://ftp.nuug.no/pub/anders/distfiles/
-DISTNAME= ${PORTNAME}-v${PORTVERSION}
-EXTRACT_SUFX= .tgz
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://www1.corest.com/download/msyslog/
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-v${PORTVERSION}-src
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= az@inec.ru
COMMENT= Flexible and easy to integrate syslog daemon
-.if defined(WITH_MYSQL)
-LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
-.endif
-.if defined(WITH_PGSQL)
-USE_PGSQL= yes
-.endif
+OPTIONS= MYSQL "With MySQL Support" off \
+ PSSQL "With Postfres Support" off \
+
+WRKSRC= ${WRKDIR}/${DISTNAME:S/-src//}
GNU_CONFIGURE= yes
-USE_REINPLACE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
-USE_PERL5_BUILD= yes
-.if !defined(WITH_MYSQL)
-CONFIGURE_ARGS+= --without-mysql
-.endif
-.if !defined(WITH_PGSQL)
-CONFIGURE_ARGS+= --without-pgsql
-.endif
-.if defined(WITH_DAEMON_NAME)
-CONFIGURE_ARGS+= --with-daemon-name=${WITH_DAEMON_NAME}
-.endif
+USE_REINPLACE= yes
+USE_RC_SUBR= msyslogd.sh
+PKGMESSAGE= ${WRKDIR}/pkg-message
+INSTALLS_SHLIB= yes
+MANCOMPRESSED= yes
+
+.include <bsd.port.pre.mk>
-MAN5= syslog.conf.5
-MAN8= im_bsd.8 im_tcp.8 im_udp.8 im_unix.8 om_classic.8 om_tcp.8 om_peo.8 \
- om_regex.8 peochk.8 syslogd.8 om_udp.8 im_file.8
.if defined(WITH_MYSQL)
+USE_MYSQL= yes
MAN8+= om_mysql.8
+.else
+CONFIGURE_ARGS+= --without-mysql
.endif
-.if defined(WITH_PGSQL)
+
+.if defined(WITH_PSSQL)
+USE_PGSQL= yes
MAN8+= om_pgsql.8
+.else
+CONFIGURE_ARGS+= --without-pgsql
.endif
-MANCOMPRESSED= yes
-INSTALLS_SHLIB= yes
-LDCONFIG_DIRS= %%PREFIX%%/lib/alat
-
-DOCS= AUTHORS COPYING src/TODO README NEWS doc/HOW_TO_WRITE_A_MODULE \
- doc/HOW-TO-UPGRADE
-FIXPREFIX= README src/man/om_peo.8 src/man/syslog.conf.5 \
- src/man/syslogd.8 src/TODO src/syslogd.h
-
-WRKSRC= ${WRKDIR}/${DISTNAME}
-
-pre-patch:
-.for f in ${FIXPREFIX}
- ${REINPLACE_CMD} -e "s|/etc/syslog.conf|${PREFIX}/etc/syslog.conf|g" \
- ${WRKSRC}/${f}
-.endfor
post-patch:
-.for f in README src/syslogd.c src/man/im_file.8 src/man/im_streams.8 \
- src/man/im_unix.8 src/man/syslogd.8 src/modules/im_streams.c src/modules/im_unix.c
- ${REINPLACE_CMD} -e "s|/dev/log|/var/run/log|" ${WRKSRC}/${f}
-.endfor
+ @${FIND} ${WRKSRC}/src/modules -name "*.c" | \
+ ${XARGS} ${REINPLACE_CMD} -e "s|typedef int socklen_t;||g"
+ @${FIND} ${WRKSRC}/src/peo -name "*.h" | \
+ ${XARGS} ${REINPLACE_CMD} -e 's|"typedefs.h"|<sys/types.h>|g'
+ @${FIND} ${WRKSRC}/src/ -name "*.*" | \
+ ${XARGS} ${REINPLACE_CMD} -e 's|/dev/log|/var/run/log|g' \
+ -e "s|/etc/syslog.conf|${PREFIX}/etc/syslog.conf|g"
+ @${FIND} ${WRKSRC}/src/ -name "*.bak" -delete
post-install:
- ${INSTALL} -d -o root -g wheel -m 0755 ${PREFIX}/share/examples/msyslog
- ${INSTALL_DATA} ${WRKSRC}/src/examples/* \
- ${PREFIX}/share/examples/msyslog
-.if !defined(NOPORTDOCS)
- ${INSTALL} -d -o root -g wheel -m 0755 ${DOCSDIR}
-.for f in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
-.endfor
-.endif
- @if [ ! -f ${PREFIX}/etc/rc.d/msyslog.sh.sample ]; then \
- ${ECHO} "Installing ${PREFIX}/etc/rc.d/msyslog.sh.sample startup file."; \
- ${INSTALL_SCRIPT} ${FILESDIR}/msyslog.sh.sample ${PREFIX}/etc/rc.d/msyslog.sh.sample; \
- fi
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/src/examples/* ${EXAMPLESDIR}
+ @${CAT} ${PKGDIR}/pkg-message | ${SED} -e 's|%%PREFIX%%|${PREFIX}|g' \
+ > ${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/sysutils/msyslog/distinfo b/sysutils/msyslog/distinfo
index 8f561c6b6e2e..c183fb4dcd7a 100644
--- a/sysutils/msyslog/distinfo
+++ b/sysutils/msyslog/distinfo
@@ -1,2 +1,2 @@
-MD5 (msyslog-v1.08f.tgz) = 03ac1f3e3f8d1d4dce2fe523061d1e94
-SIZE (msyslog-v1.08f.tgz) = 137417
+MD5 (msyslog-v1.08g-src.tar.gz) = c82b43b2dafe83c62445eb6c4d039fc7
+SIZE (msyslog-v1.08g-src.tar.gz) = 131782
diff --git a/sysutils/msyslog/files/msyslog.sh.sample b/sysutils/msyslog/files/msyslog.sh.sample
deleted file mode 100644
index 3edb0ae0ead6..000000000000
--- a/sysutils/msyslog/files/msyslog.sh.sample
+++ /dev/null
@@ -1,20 +0,0 @@
-#!/bin/sh
-
-if ! PREFIX=$(expr $0 : "\(/.*\)/etc/rc\.d/$(basename $0)\$"); then
- echo "$0: Cannot determine the PREFIX" >&2
- exit 1
-fi
-
-case "$1" in
-start)
- [ -x ${PREFIX}/sbin/syslogd ] && ${PREFIX}/sbin/syslogd && echo -n ' msyslog'
- ;;
-stop)
- killall syslogd && echo -n ' msyslog'
- ;;
-*)
- echo "Usage: `basename $0` {start|stop}" >&2
- ;;
-esac
-
-exit 0
diff --git a/sysutils/msyslog/files/msyslogd.sh.in b/sysutils/msyslog/files/msyslogd.sh.in
new file mode 100644
index 000000000000..2391d4aa2093
--- /dev/null
+++ b/sysutils/msyslog/files/msyslogd.sh.in
@@ -0,0 +1,47 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: syslogd
+# REQUIRE: mountcritremote cleanvar
+# BEFORE: SERVERS
+#
+# Add the following lines to /etc/rc.conf to enable msyslogd:
+#
+#msyslogd_enable="YES"
+#
+
+. %%RC_SUBR%%
+
+name=msyslogd
+rcvar=`set_rcvar`
+
+command=%%PREFIX%%/sbin/syslogd
+pidfile=/var/run/syslog.pid
+required_files=%%PREFIX%%/etc/syslogd.conf
+
+start_precmd=start_precmd
+stop_postcmd=stop_postcmd
+
+extra_commands="reload"
+
+start_precmd()
+{
+ case $syslogd_enable in
+ [Yy][Ee][Ss]|1)
+ warn "syslogd_enable should be set to NO"
+ ;;
+ esac
+}
+
+stop_postcmd()
+{
+ rm -f $pidfile
+}
+
+# read settings, set default values
+load_rc_config $name
+: ${msyslogd_enable="NO"}
+
+run_rc_command "$1"
diff --git a/sysutils/msyslog/files/patch-configure b/sysutils/msyslog/files/patch-configure
index ba9bdf1a134c..c89e4dde78c4 100644
--- a/sysutils/msyslog/files/patch-configure
+++ b/sysutils/msyslog/files/patch-configure
@@ -1,5 +1,5 @@
---- configure.orig Sat Jan 4 15:45:31 2003
-+++ configure Sat Jan 4 15:51:07 2003
+--- configure.orig Fri Apr 11 23:07:44 2003
++++ configure Wed Sep 14 16:39:00 2005
@@ -2941,7 +2941,7 @@
echo "$as_me:2941: result: $ac_cv_lib_dl_dlopen" >&5
echo "${ECHO_T}$ac_cv_lib_dl_dlopen" >&6
@@ -21,6 +21,15 @@
cat >>confdefs.h <<EOF
#define MLIBNAME_STR "$MLIBNAME"
EOF
+@@ -3587,7 +3587,7 @@
+ prefix=$ac_default_prefix
+ fi
+ cat >>confdefs.h <<EOF
+-#define INSTALL_LIBDIR "$prefix/lib/alat"
++#define INSTALL_LIBDIR "$prefix/lib"
+ EOF
+
+ echo "$as_me:3593: checking wheter optreset is needed" >&5
@@ -3644,14 +3644,6 @@
#define PID_DIR "$dir"
EOF
diff --git a/sysutils/msyslog/files/patch-im_tcp.c b/sysutils/msyslog/files/patch-im_tcp.c
deleted file mode 100644
index d75e48cb2a80..000000000000
--- a/sysutils/msyslog/files/patch-im_tcp.c
+++ /dev/null
@@ -1,22 +0,0 @@
---- src/modules/im_tcp.c.orig Sat Jan 4 15:42:05 2003
-+++ src/modules/im_tcp.c Sat Jan 4 15:42:41 2003
-@@ -61,6 +61,7 @@
- #include <sys/types.h>
- #include <sys/socket.h>
- #include <sys/uio.h>
-+#include <sys/param.h>
- #include <ctype.h>
- #include <stdlib.h>
- #include <unistd.h>
-@@ -72,11 +73,6 @@
-
- #include "../modules.h"
- #include "../syslogd.h"
--
--/* recvfrom() and others like socklen_t, Irix doesn't provide it */
--#ifndef HAVE_SOCKLEN_T
-- typedef int socklen_t;
--#endif
-
- struct tcp_conn {
- struct tcp_conn *next;
diff --git a/sysutils/msyslog/files/patch-im_udp.c b/sysutils/msyslog/files/patch-im_udp.c
deleted file mode 100644
index 3dd32fb092cf..000000000000
--- a/sysutils/msyslog/files/patch-im_udp.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/modules/im_udp.c.orig Sat Mar 23 18:14:04 2002
-+++ src/modules/im_udp.c Sat Mar 23 18:14:24 2002
-@@ -58,11 +58,6 @@
- #include "../modules.h"
- #include "../syslogd.h"
-
--/* recvfrom() and others like socklen_t, Irix doesn't provide it */
--#ifndef HAVE_SOCKLEN_T
-- typedef int socklen_t;
--#endif
--
- struct im_udp_ctx {
- int flags;
- };
diff --git a/sysutils/msyslog/files/patch-im_unix.c b/sysutils/msyslog/files/patch-im_unix.c
deleted file mode 100644
index 829ebdd41266..000000000000
--- a/sysutils/msyslog/files/patch-im_unix.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/modules/im_unix.c.orig Thu Apr 26 00:43:50 2001
-+++ src/modules/im_unix.c Sun May 13 23:44:55 2001
-@@ -58,11 +58,6 @@
- #include "../modules.h"
- #include "../syslogd.h"
-
--/* recvfrom() and others like socklen_t, Irix doesn't provide it */
--#ifndef HAVE_SOCKLEN_T
-- typedef int socklen_t;
--#endif
--
- #define DEFAULT_LOGGER "/dev/log"
-
- /*
diff --git a/sysutils/msyslog/files/patch-ip_misc.c b/sysutils/msyslog/files/patch-ip_misc.c
deleted file mode 100644
index 827a6edbade1..000000000000
--- a/sysutils/msyslog/files/patch-ip_misc.c
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/modules/ip_misc.c.orig Thu Apr 26 19:09:26 2001
-+++ src/modules/ip_misc.c Sun May 13 16:30:57 2001
-@@ -62,12 +62,6 @@
- #include "../modules.h"
- #include "../syslogd.h"
-
--/* recvfrom() and others like socklen_t, Irix doesn't provide it */
--#ifndef HAVE_SOCKLEN_T
-- typedef int socklen_t;
--#endif
--
--
- #define TCP_KEEPALIVE 30 /* seconds to probe TCP connection */
- #define MSYSLOG_MAX_TCP_CLIENTS 100
- #define LISTENQ 35
diff --git a/sysutils/msyslog/files/patch-md5.h b/sysutils/msyslog/files/patch-md5.h
deleted file mode 100644
index c87de3fef159..000000000000
--- a/sysutils/msyslog/files/patch-md5.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/peo/md5.h.orig Tue Dec 5 00:17:51 2000
-+++ src/peo/md5.h Sun May 13 00:38:59 2001
-@@ -27,7 +27,7 @@
- #ifndef _MD5_H_
- #define _MD5_H_
-
--#include "typedefs.h"
-+#include <sys/types.h>
-
- /* MD5 context. */
- typedef struct MD5Context {
diff --git a/sysutils/msyslog/files/patch-rmd160.h b/sysutils/msyslog/files/patch-rmd160.h
deleted file mode 100644
index 3e4e464b5a75..000000000000
--- a/sysutils/msyslog/files/patch-rmd160.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/peo/rmd160.h.orig Sun May 13 00:40:04 2001
-+++ src/peo/rmd160.h Sun May 13 00:40:23 2001
-@@ -20,7 +20,7 @@
- #ifndef _RMD160_H /* make sure this file is read only once */
- #define _RMD160_H
-
--#include "typedefs.h"
-+#include <sys/types.h>
-
- /********************************************************************/
-
diff --git a/sysutils/msyslog/files/patch-sha1.h b/sysutils/msyslog/files/patch-sha1.h
deleted file mode 100644
index 664e98dedb82..000000000000
--- a/sysutils/msyslog/files/patch-sha1.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/peo/sha1.h.orig Sun May 13 00:40:12 2001
-+++ src/peo/sha1.h Sun May 13 00:40:37 2001
-@@ -9,7 +9,7 @@
- #ifndef _SHA1_H
- #define _SHA1_H
-
--#include "typedefs.h"
-+#include <sys/types.h>
-
- typedef struct {
- u_int32_t state[5];
diff --git a/sysutils/msyslog/files/patch-src-Makefile.in b/sysutils/msyslog/files/patch-src-Makefile.in
new file mode 100644
index 000000000000..4f4816c5abe7
--- /dev/null
+++ b/sysutils/msyslog/files/patch-src-Makefile.in
@@ -0,0 +1,12 @@
+--- src/Makefile.in.orig Fri Apr 11 20:36:26 2003
++++ src/Makefile.in Thu Sep 15 11:01:15 2005
+@@ -74,9 +74,3 @@
+ $(INSTALL) -s $(PROG) $(INSTALL_DIR)/ ;
+
+ install: install-prog
+- @echo -e \
+- " **********************************************************\n"\
+- "** A new syslog daemon was installed !! **\n"\
+- "** Please read the INSTALL and README files **\n"\
+- "** to get your syslog configuration ready **\n"\
+- "**********************************************************\n"
diff --git a/sysutils/msyslog/files/patch-src-config.h.in b/sysutils/msyslog/files/patch-src-config.h.in
deleted file mode 100644
index 1bd54f043981..000000000000
--- a/sysutils/msyslog/files/patch-src-config.h.in
+++ /dev/null
@@ -1,154 +0,0 @@
---- src/config.h.in.orig Sat Jan 4 20:23:08 2003
-+++ src/config.h.in Sat Jan 4 20:22:53 2003
-@@ -0,0 +1,151 @@
-+/* config.h.in. Generated automatically from configure.in by autoheader. */
-+
-+/* Define to empty if the keyword does not work. */
-+#undef const
-+
-+/* Define if you don't have vprintf but do have _doprnt. */
-+#undef HAVE_DOPRNT
-+
-+/* Define if you have the vprintf function. */
-+#undef HAVE_VPRINTF
-+
-+/* Define to `long' if <sys/types.h> doesn't define. */
-+#undef off_t
-+
-+/* Define as the return type of signal handlers (int or void). */
-+#undef RETSIGTYPE
-+
-+/* Define to `unsigned' if <sys/types.h> doesn't define. */
-+#undef size_t
-+
-+/* Define if you have the ANSI C header files. */
-+#undef STDC_HEADERS
-+
-+/* Define if you can safely include both <sys/time.h> and <time.h>. */
-+#undef TIME_WITH_SYS_TIME
-+
-+/* Define if your <sys/time.h> declares struct tm. */
-+#undef TM_IN_SYS_TIME
-+
-+/* Define if you have the gethostname function. */
-+#undef HAVE_GETHOSTNAME
-+
-+/* Define if you have the regcomp function. */
-+#undef HAVE_REGCOMP
-+
-+/* Define if you have the select function. */
-+#undef HAVE_POLL
-+
-+/* Define if you have the select function. */
-+#undef HAVE_SELECT
-+
-+/* Define if you have the socket function. */
-+#undef HAVE_SOCKET
-+
-+/* Define if you have the strdup function. */
-+#undef HAVE_STRDUP
-+
-+/* Define if you have the strerror function. */
-+#undef HAVE_STRERROR
-+
-+/* Define if you have the strstr function. */
-+#undef HAVE_STRSTR
-+
-+/* Define if you have the strtoul function. */
-+#undef HAVE_STRTOUL
-+
-+/* Define if you have the <dirent.h> header file. */
-+#undef HAVE_DIRENT_H
-+
-+/* Define if you have the <fcntl.h> header file. */
-+#undef HAVE_FCNTL_H
-+
-+/* Define if you have the <limits.h> header file. */
-+#undef HAVE_LIMITS_H
-+
-+/* Define if you have the <ndir.h> header file. */
-+#undef HAVE_NDIR_H
-+
-+/* Define if you have the <paths.h> header file. */
-+#undef HAVE_PATHS_H
-+
-+/* Define if you have the <strings.h> header file. */
-+#undef HAVE_STRINGS_H
-+
-+/* Define if you have the <sys/dir.h> header file. */
-+#undef HAVE_SYS_DIR_H
-+
-+/* Define if you have the <sys/ioctl.h> header file. */
-+#undef HAVE_SYS_IOCTL_H
-+
-+/* Define if you have the <sys/ndir.h> header file. */
-+#undef HAVE_SYS_NDIR_H
-+
-+/* Define if you have the <sys/time.h> header file. */
-+#undef HAVE_SYS_TIME_H
-+
-+/* Define if you have the <syslog.h> header file. */
-+#undef HAVE_SYSLOG_H
-+
-+/* Define if you have the <unistd.h> header file. */
-+#undef HAVE_UNISTD_H
-+
-+#undef HAVE_SYSCTL_H
-+#undef HAVE_ERR_H
-+
-+#undef MSYSLOG_VERSION_STR
-+#undef MLIBNAME_STR
-+#undef INSTALL_LIBDIR
-+#undef PID_DIR
-+#undef PID_FILE
-+
-+#undef HAVE_OPTRESET
-+
-+#undef DLOPEN_FLAGS
-+#undef SYMBOL_PREFIX
-+
-+#undef HAVE_SRANDOM
-+#undef HAVE_MD5
-+#undef HAVE_SHA1
-+#undef HAVE_RMD160
-+
-+#undef HAVE_SOCKLEN_T
-+#undef HAVE_UINT32_T
-+#undef HAVE_UINT64_T
-+#undef HAVE_U_INT32_T
-+#undef HAVE___UINT32_T
-+#undef HAVE_U_INT64_T
-+#undef HAVE___UINT64_T
-+
-+#undef HAVE_CODE
-+
-+#undef MLIBNAME
-+
-+#undef HAVE_SYS_WAIT_H
-+
-+#undef HAVE_GETADDRINFO
-+
-+#undef HAVE_INET_NTOP
-+
-+#undef HAVE_STREAMS_IMODULE
-+#undef HAVE_LINUX_IMODULE
-+#undef HAVE_BSD_IMODULE
-+#undef HAVE_UNIX_IMODULE
-+
-+#undef HAVE_SOCKADDR_SA_LEN
-+
-+#undef _USE_IRS
-+#undef SIGALTSTACK_WITH_STACK_T
-+#undef HAVE_SYS_CONTEXT_H
-+
-+#undef NEEDS_DLOPEN_NULL
-+
-+#undef _SGIAPI
-+#undef INET6
-+
-+#undef WORDS_BIGENDIAN
-+
-+#undef _GNU_SOURCE
-+
-+/* for Solaris */
-+#undef _REENTRANT
diff --git a/sysutils/msyslog/files/patch-src-modules-Makefile.in b/sysutils/msyslog/files/patch-src-modules-Makefile.in
new file mode 100644
index 000000000000..b375ab39d621
--- /dev/null
+++ b/sysutils/msyslog/files/patch-src-modules-Makefile.in
@@ -0,0 +1,11 @@
+--- src/modules/Makefile.in.orig Fri Apr 11 20:36:36 2003
++++ src/modules/Makefile.in Wed Sep 14 16:44:15 2005
+@@ -35,7 +35,7 @@
+ CPPFLAGS= -I.. @CPPFLAGS@
+
+ INSTALL= @INSTALL@
+-INSTALL_LIBDIR= @prefix@/lib/alat
++INSTALL_LIBDIR= @prefix@/lib
+
+ MLIBNAME= @MLIBNAME@
+ MSRCS= @MSRCS@
diff --git a/sysutils/msyslog/pkg-descr b/sysutils/msyslog/pkg-descr
index 4e279e512a0f..d65f7226eec0 100644
--- a/sysutils/msyslog/pkg-descr
+++ b/sysutils/msyslog/pkg-descr
@@ -6,6 +6,6 @@ integrity checking), om_mysql and om_pgsql (modules that sends output to a
MySQL and PostgreSQL database, respectively) and om_regex (a module that allows
output redirection using regular expressions).
-WWW: http://www.corest.com/products/corewisdom/CW01.php
+WWW: http://oss.coresecurity.com/projects/msyslog.html
- Anders Nordby <anders@fix.no>
diff --git a/sysutils/msyslog/pkg-message b/sysutils/msyslog/pkg-message
index b0d0e238058d..ec230912abb3 100644
--- a/sysutils/msyslog/pkg-message
+++ b/sysutils/msyslog/pkg-message
@@ -1,14 +1,17 @@
================================================================================
To replace FreeBSD's standard syslogd with msyslog, do this:
-a) create a configuration in ${PREFIX}/etc/syslog.conf.
- See ${PREFIX}/share/examples/msyslog for examples.
+1) Create a configuration in %%PREFIX%%/etc/syslog.conf.
+ See %%PREFIX%%/share/examples/msyslog for examples.
-b) Set up a startup script in ${PREFIX}/etc/rc.d.
- For your convinience, a msyslog.sh.sample has been provided.
+2) Set up a startup script in %%PREFIX%%/etc/rc.d.
+ For your convinience, a msyslog.sh has been provided.
+ put this in /etc/rc.conf
+
+ msyslogd_enable="YES"
-c) Stop the standard FreeBSD syslogd from starting automatically by putting this
- in the end of /etc/rc.conf:
+3) Stop the standard FreeBSD syslogd from starting automatically by putting this
+ in the end of /etc/rc.conf:
-syslogd_enable="NO"
+ syslogd_enable="NO"
================================================================================
diff --git a/sysutils/msyslog/pkg-plist b/sysutils/msyslog/pkg-plist
index 10d198b39017..b51f792c669f 100644
--- a/sysutils/msyslog/pkg-plist
+++ b/sysutils/msyslog/pkg-plist
@@ -1,21 +1,24 @@
-etc/rc.d/msyslog.sh.sample
-lib/alat/libmsyslog.so.1
sbin/peochk
sbin/syslogd
-share/examples/msyslog/im_mymodule.c
-share/examples/msyslog/om_mymodule.c
-share/examples/msyslog/syslog.conf.classic
-share/examples/msyslog/syslog.conf.mysql
-share/examples/msyslog/syslog.conf.peo
-share/examples/msyslog/syslog.conf.pgsql
-share/examples/msyslog/syslog.conf.regex
-@dirrm share/examples/msyslog
-%%PORTDOCS%%share/doc/msyslog/AUTHORS
-%%PORTDOCS%%share/doc/msyslog/COPYING
-%%PORTDOCS%%share/doc/msyslog/HOW-TO-UPGRADE
-%%PORTDOCS%%share/doc/msyslog/HOW_TO_WRITE_A_MODULE
-%%PORTDOCS%%share/doc/msyslog/NEWS
-%%PORTDOCS%%share/doc/msyslog/README
-%%PORTDOCS%%share/doc/msyslog/TODO
-%%PORTDOCS%%@dirrm share/doc/msyslog
-@unexec rmdir %D/lib/alat 2>/dev/null || true
+lib/libmsyslog.so.1
+man/man5/syslog.conf.5.gz
+man/man8/im_bsd.8.gz
+man/man8/im_file.8.gz
+man/man8/im_tcp.8.gz
+man/man8/im_udp.8.gz
+man/man8/im_unix.8.gz
+man/man8/om_classic.8.gz
+man/man8/om_peo.8.gz
+man/man8/om_regex.8.gz
+man/man8/om_tcp.8.gz
+man/man8/om_udp.8.gz
+man/man8/peochk.8.gz
+man/man8/syslogd.8.gz
+%%EXAMPLESDIR%%/im_mymodule.c
+%%EXAMPLESDIR%%/om_mymodule.c
+%%EXAMPLESDIR%%/syslog.conf.classic
+%%EXAMPLESDIR%%/syslog.conf.mysql
+%%EXAMPLESDIR%%/syslog.conf.peo
+%%EXAMPLESDIR%%/syslog.conf.pgsql
+%%EXAMPLESDIR%%/syslog.conf.regex
+@dirrm %%EXAMPLESDIR%%