aboutsummaryrefslogtreecommitdiff
path: root/sysutils/munin-master
diff options
context:
space:
mode:
authorDag-Erling Smørgrav <des@FreeBSD.org>2010-02-25 12:15:38 +0000
committerDag-Erling Smørgrav <des@FreeBSD.org>2010-02-25 12:15:38 +0000
commit94ebcf4d98b6bc7bc2e56f64f1a780eb894f5df1 (patch)
treebd54b030ba59ee28794bf303646386745eb0891c /sysutils/munin-master
parent78ee99eb30514dee52bbfe2d229191a226af257d (diff)
downloadports-94ebcf4d98b6bc7bc2e56f64f1a780eb894f5df1.tar.gz
ports-94ebcf4d98b6bc7bc2e56f64f1a780eb894f5df1.zip
Notes
Diffstat (limited to 'sysutils/munin-master')
-rw-r--r--sysutils/munin-master/Makefile17
-rw-r--r--sysutils/munin-master/files/patch-Makefile.config82
-rw-r--r--sysutils/munin-master/pkg-plist6
3 files changed, 7 insertions, 98 deletions
diff --git a/sysutils/munin-master/Makefile b/sysutils/munin-master/Makefile
index fa9457ff37c4..4a145e421649 100644
--- a/sysutils/munin-master/Makefile
+++ b/sysutils/munin-master/Makefile
@@ -7,7 +7,7 @@
PORTNAME= munin
PORTVERSION= 1.4.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils perl5
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20stable/${PORTVERSION}
PKGNAMESUFFIX= -master
@@ -39,17 +39,10 @@ RUN_DEPENDS= ${SITE_PERL}/Munin/Common/Defaults.pm:${PORTSDIR}/sysutils/munin-co
USE_PERL5= yes
USE_GMAKE= yes
-PATCH_STRIP= -p1
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/.r/rc/}
PKGMESSAGE= ${WRKDIR}/pkg-message
-USERS= munin
-GROUPS= munin
+.include "${.CURDIR}/../munin-common/munin.mk"
-DBDIR= /var/${PORTNAME}
-MAKE_ARGS= LIBDIR=${DATADIR} CONFDIR=${ETCDIR} DBDIR=${DBDIR} \
- WWWDIR=${WWWDIR} CGIDIR=${WWWDIR}/cgi-bin \
- PERL=${PERL} SITE_PERL_REL=${SITE_PERL_REL}
ALL_TARGET= build-master build-man
INSTALL_TARGET= install-master-prime
@@ -80,7 +73,9 @@ pre-install:
${SH} ${PKGDIR}/pkg-install ${PKGNAME} PRE-INSTALL
post-install:
- @${INSTALL_DATA} ${WRKSRC}/build/master/munin.conf ${PREFIX}/etc/munin/munin.conf.sample
+ @${CHOWN} ${USERS}:${GROUPS} ${DBDIR} ${STATEDIR} ${WWWDIR}
+ @${INSTALL_DATA} ${WRKSRC}/build/master/munin.conf \
+ ${PREFIX}/etc/munin/munin.conf.sample
@(cd ${WRKSRC}/master/blib/libdoc && for man in ${MAN3}; do \
${INSTALL_MAN} -C $$man ${PREFIX}/man/man3; \
done)
@@ -92,8 +87,6 @@ post-install:
done)
@${SETENV} ${SCRIPTS_ENV} PKG_PREFIX=${PREFIX} \
${SH} ${PKGDIR}/pkg-install ${PKGNAME} POST-INSTALL
- @${CHOWN} munin /var/log/munin-master
- @${CHGRP} munin /var/run/munin /var/log/munin-master ${WWWDIR} ${DBDIR}
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/sysutils/munin-master/files/patch-Makefile.config b/sysutils/munin-master/files/patch-Makefile.config
index d26dd1be439c..98a7052bf8ae 100644
--- a/sysutils/munin-master/files/patch-Makefile.config
+++ b/sysutils/munin-master/files/patch-Makefile.config
@@ -1,87 +1,5 @@
--- Makefile.config.orig 2009-12-30 05:55:56.000000000 -0700
+++ Makefile.config 2010-01-30 11:17:34.000000000 -0700
-@@ -17,29 +17,33 @@
- #
- # the base of the Munin installation.
- #
--PREFIX = $(DESTDIR)/opt/munin
-+ifdef PREFIX
-+UPREFIX=$(PREFIX)
-+else
-+UPREFIX=/usr
-+endif
-
- # Where Munin keeps its configurations (server.conf, client.conf, ++)
--CONFDIR = $(DESTDIR)/etc/opt/munin
-+CONFDIR = $(PREFIX)/etc/munin
-
- # Server only - where to put munin-cron
--BINDIR = $(PREFIX)/bin
-+BINDIR = $(UPREFIX)/bin
-
- # Client only - where to put munin-node, munin-node-configure, and munin-run
--SBINDIR = $(PREFIX)/sbin
-+SBINDIR = $(UPREFIX)/sbin
-
- # Where to put text and html documentation
--DOCDIR = $(PREFIX)/doc
-+DOCDIR = $(UPREFIX)/doc
-
- # Where to put man pages
--MANDIR = $(PREFIX)/man
-+MANDIR = $(UPREFIX)/man
-
- # Where to put internal binaries and plugin repository
--LIBDIR = $(PREFIX)/lib
-+LIBDIR = $(DATADIR)
-
- # Server only - Output directory
--HTMLDIR = $(PREFIX)/www/docs
--CGIDIR = $(PREFIX)/www/cgi
-+HTMLDIR = $(WWWDIR)
-+CGIDIR = $(PREFIX)/www/cgi-bin
-
- # Server only - spool directory for data gathered from nodes by
- # munin-gather - experimental. Place on ramdisk to make munin
-@@ -52,21 +56,20 @@
- # SSPOOLDIR := /tmp/muninspool
-
- # Client only - Where to put RRD files and other intenal data
--DBDIR = $(DESTDIR)/var/opt/munin
-+DBDIR = $(PREFIX)/var/munin
-
- # Client only - Where plugins should put their states. Must be writable by
- # group "munin", and should be preserved between reboots
- PLUGSTATE = $(DBDIR)/plugin-state
-
- # Where Munin should place its logs.
--LOGDIR = $(PREFIX)/log/munin
-+LOGDIR = /var/log/munin-master
-
- # Location of PID files and other statefiles. On the server, must be
- # writable by the user "munin".
--STATEDIR = $(DESTDIR)/var/run/munin
-+STATEDIR = /var/run/munin
-
- # The perl interpreter to use
--PERL := $(shell which perl)
-
- # The python interpreter to use (used by some plugins)
- PYTHON := /usr/bin/env python
-@@ -95,11 +98,11 @@
- GOODSH := $(shell PATH=`getconf PATH` sh -c 'type sh | sed "s/.* //"')
-
- # Path of bash for bash specific plugins
--BASH := /bin/bash
-+BASH := /usr/local/bin/bash
-
- # Server only - Where to install the perl libraries
- PERLSITELIB := $(shell $(PERL) -V:sitelib | cut -d"'" -f2)
--PERLLIB = $(DESTDIR)$(PERLSITELIB)
-+PERLLIB = $(PREFIX)/$(SITE_PERL_REL)
-
- # Client only - Install plugins for this architecture
- OSTYPE := $(shell uname | tr '[A-Z]' '[a-z]')
@@ -126,9 +129,8 @@
# Which command to use to check if the USER and GROUP to run Munin as, exists.
# These will work on most modern OSes:
diff --git a/sysutils/munin-master/pkg-plist b/sysutils/munin-master/pkg-plist
index 2ec21a94100d..b0de0415664e 100644
--- a/sysutils/munin-master/pkg-plist
+++ b/sysutils/munin-master/pkg-plist
@@ -44,10 +44,8 @@ bin/munin-cron
%%DATADIR%%/munin-html
%%DATADIR%%/munin-limits
%%DATADIR%%/munin-update
-%%WWWDIR%%/cgi-bin/munin-cgi-graph
-%%WWWDIR%%/cgi-bin/munin-fastcgi-graph
-%%WWWDIR%%/.htaccess
-@dirrmtry %%WWWDIR%%/cgi-bin
+www/cgi-bin/munin-cgi-graph
+www/cgi-bin/munin-fastcgi-graph
@dirrmtry %%WWWDIR%%
@dirrmtry %%DATADIR%%
@dirrmtry %%DBDIR%%